96 lines
4.3 KiB
Diff
96 lines
4.3 KiB
Diff
From be770ecd2fb902d0e7080663890d9f01ca3bb84b Mon Sep 17 00:00:00 2001
|
|
From: orbea <orbea@riseup.net>
|
|
Date: Mon, 19 Aug 2019 15:03:52 -0700
|
|
Subject: [PATCH 1/2] Add a desktop file.
|
|
|
|
---
|
|
CMakeLists.txt | 5 +++++
|
|
zelda-xd2-mercuris-chess.desktop | 9 +++++++++
|
|
2 files changed, 14 insertions(+)
|
|
create mode 100644 zelda-xd2-mercuris-chess.desktop
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 890919b..74b50fc 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -76,3 +76,8 @@ install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${quest_name}
|
|
DESTINATION ${SOLARUS_INSTALL_BINDIR}
|
|
)
|
|
|
|
+# FreeDesktop compatible start menu launcher
|
|
+if(UNIX AND NOT APPLE)
|
|
+ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/zelda-xd2-mercuris-chess.desktop
|
|
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications)
|
|
+endif(UNIX AND NOT APPLE)
|
|
diff --git a/zelda-xd2-mercuris-chess.desktop b/zelda-xd2-mercuris-chess.desktop
|
|
new file mode 100644
|
|
index 0000000..0a8d339
|
|
--- /dev/null
|
|
+++ b/zelda-xd2-mercuris-chess.desktop
|
|
@@ -0,0 +1,9 @@
|
|
+[Desktop Entry]
|
|
+Name=Zelda XD2: Mercuris Chess
|
|
+GenericName=Zelda fangame for the Solarus engine
|
|
+Comment=Zelda XD2: Mercuris Ches (Parodic Zelda game)
|
|
+Exec=zelda_xd2_mercuris_chess
|
|
+Terminal=false
|
|
+Type=Application
|
|
+Icon=zelda_xd2_mercuris_chess
|
|
+Categories=Game;AdventureGame;
|
|
--
|
|
2.22.0
|
|
|
|
From 0912e4d1c0f235fcc6470bd163bd3e5144377d49 Mon Sep 17 00:00:00 2001
|
|
From: orbea <orbea@riseup.net>
|
|
Date: Mon, 19 Aug 2019 15:12:41 -0700
|
|
Subject: [PATCH 2/2] Install icons.
|
|
|
|
---
|
|
CMakeLists.txt | 30 ++++++++++++++++++++++++++++++
|
|
1 file changed, 30 insertions(+)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 74b50fc..297205d 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -76,6 +76,36 @@ install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${quest_name}
|
|
DESTINATION ${SOLARUS_INSTALL_BINDIR}
|
|
)
|
|
|
|
+# FreeDesktop compatible icons
|
|
+if(UNIX AND NOT APPLE)
|
|
+ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_16.png
|
|
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/16x16/apps RENAME zelda-xd2-mercuris-chess.png)
|
|
+ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_20.png
|
|
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/20x20/apps RENAME zelda-xd2-mercuris-chess.png)
|
|
+ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_22.png
|
|
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/22x22/apps RENAME zelda-xd2-mercuris-chess.png)
|
|
+ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_32.png
|
|
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/32x32/apps RENAME zelda-xd2-mercuris-chess.png)
|
|
+ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_40.png
|
|
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/40x40/apps RENAME zelda-xd2-mercuris-chess.png)
|
|
+ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_48.png
|
|
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/48x48/apps RENAME zelda-xd2-mercuris-chess.png)
|
|
+ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_64.png
|
|
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/64x64/apps RENAME zelda-xd2-mercuris-chess.png)
|
|
+ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_96.png
|
|
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/96x96/apps RENAME zelda-xd2-mercuris-chess.png)
|
|
+ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_128.png
|
|
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/128x128/apps RENAME zelda-xd2-mercuris-chess.png)
|
|
+ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_256.png
|
|
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/256x256/apps RENAME zelda-xd2-mercuris-chess.png)
|
|
+ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_512.png
|
|
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/512x512/apps RENAME zelda-xd2-mercuris-chess.png)
|
|
+ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_1024.png
|
|
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/1024x1024/apps RENAME zelda-xd2-mercuris-chess.png)
|
|
+ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/logo_2x.png
|
|
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/pixmaps RENAME zelda-xd2-mercuris-chess.png)
|
|
+endif(UNIX AND NOT APPLE)
|
|
+
|
|
# FreeDesktop compatible start menu launcher
|
|
if(UNIX AND NOT APPLE)
|
|
install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/zelda-xd2-mercuris-chess.desktop
|
|
--
|
|
2.22.0
|
|
|