23 lines
1.5 KiB
Diff
23 lines
1.5 KiB
Diff
--- poco-1.7.3-all/Makefile.original 2016-05-21 10:30:38.468392077 +0100
|
|
+++ poco-1.7.3-all/Makefile 2016-05-21 10:31:06.823679098 +0100
|
|
@@ -95,7 +95,7 @@
|
|
|
|
install: libexecs
|
|
mkdir -p $(INSTALLDIR)/include/Poco
|
|
- mkdir -p $(INSTALLDIR)/lib
|
|
+ mkdir -p $(INSTALLDIR)/lib64
|
|
mkdir -p $(INSTALLDIR)/bin
|
|
for comp in $(filter-out $(foreach f,$(OMIT),$f%),$(COMPONENTS)) ; do \
|
|
if [ -d "$(POCO_BASE)/$$comp/include" ] ; then \
|
|
@@ -109,8 +109,8 @@
|
|
find $(POCO_BUILD)/lib/$(OSNAME)/$(OSARCH) -name "cygPoco*" -type f -exec cp -f {} $(INSTALLDIR)/bin \;
|
|
find $(POCO_BUILD)/lib/$(OSNAME)/$(OSARCH) -name "cygPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/bin \;
|
|
endif
|
|
- find $(POCO_BUILD)/lib/$(OSNAME)/$(OSARCH) -name "libPoco*" -type f -exec cp -f {} $(INSTALLDIR)/lib \;
|
|
- find $(POCO_BUILD)/lib/$(OSNAME)/$(OSARCH) -name "libPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/lib \;
|
|
+ find $(POCO_BUILD)/lib/$(OSNAME)/$(OSARCH) -name "libPoco*" -type f -exec cp -f {} $(INSTALLDIR)/lib64 \;
|
|
+ find $(POCO_BUILD)/lib/$(OSNAME)/$(OSARCH) -name "libPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/lib64 \;
|
|
|
|
libexecs = Foundation-libexec XML-libexec JSON-libexec Util-libexec Net-libexec Crypto-libexec NetSSL_OpenSSL-libexec Data-libexec Data/SQLite-libexec Data/ODBC-libexec Data/MySQL-libexec MongoDB-libexec Zip-libexec PageCompiler-libexec PageCompiler/File2Page-libexec
|
|
tests = Foundation-tests XML-tests JSON-tests Util-tests Net-tests Crypto-tests NetSSL_OpenSSL-tests Data-tests Data/SQLite-tests Data/ODBC-tests Data/MySQL-tests MongoDB-tests Zip-tests
|