26 lines
908 B
Diff
26 lines
908 B
Diff
From fe221f7d6fcf04e296f3b8598f57abc9e3dea821 Mon Sep 17 00:00:00 2001
|
|
From: Sergey Avseyev <sergey.avseyev@gmail.com>
|
|
Date: Wed, 16 Jan 2019 20:00:40 +0300
|
|
Subject: [PATCH 3/4] use shell loop instead makefile function
|
|
|
|
this avoids failure when too long string passed to exec
|
|
---
|
|
Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 2bdfa6395d..51614620af 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -2950,7 +2950,7 @@ install-headers_c:
|
|
install-headers_cxx:
|
|
$(E) "[INSTALL] Installing public C++ headers"
|
|
$(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
|
|
- $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
|
|
+ $(Q) for h in $(PUBLIC_HEADERS_CXX); do $(INSTALL) $$h $(prefix)/$$h; done || exit 1
|
|
|
|
install-static: install-static_c install-static_cxx
|
|
|
|
--
|
|
2.21.0
|