174 lines
5.1 KiB
Bash
174 lines
5.1 KiB
Bash
#!/bin/bash
|
|
|
|
# SlackBuild script for ITK
|
|
|
|
# Copyright 2018-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use in source and binary forms, with or without
|
|
# modification, are permitted provided that the following conditions are
|
|
# met:
|
|
#
|
|
# * Redistributions of source code must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
|
|
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
|
|
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
|
|
# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
|
|
# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
|
|
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
|
|
# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
|
|
# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
|
|
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
|
|
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PRGNAM=ITK
|
|
SRCNAM=InsightToolkit
|
|
VERSION=${VERSION:-4.13.2}
|
|
BUILD=${BUILD:-1}
|
|
TAG=${TAG:-_SBo}
|
|
PKGTYPE=${PKGTYPE:-tgz}
|
|
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) ARCH=i586 ;;
|
|
arm*) ARCH=arm ;;
|
|
*) ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
|
|
exit 0
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp/SBo}
|
|
PKG=$TMP/package-$PRGNAM
|
|
OUTPUT=${OUTPUT:-/tmp}
|
|
|
|
if [ "$ARCH" = "i586" ]; then
|
|
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
set -e
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG $OUTPUT
|
|
cd $TMP
|
|
rm -rf $SRCNAM-$VERSION
|
|
tar xvf $CWD/$SRCNAM-$VERSION.tar.xz
|
|
cd $SRCNAM-$VERSION
|
|
chown -R root:root .
|
|
find -L . \
|
|
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
|
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
|
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
|
|
|
patch -p1 <<'endpatch'
|
|
--- InsightToolkit-4.13.2/Modules/ThirdParty/VNL/src/vxl/vcl/vcl_compiler.h.cp
|
|
+++ InsightToolkit-4.13.2/Modules/ThirdParty/VNL/src/vxl/vcl/vcl_compiler.h
|
|
@@ -96,6 +96,39 @@
|
|
# define VCL_GCC_81
|
|
# else
|
|
# define VCL_GCC_80
|
|
+# endif
|
|
+# elif (__GNUC__==9)
|
|
+# define VCL_GCC_9
|
|
+# if (__GNUC_MINOR__ > 2 )
|
|
+# define VCL_GCC_93
|
|
+# elif (__GNUC_MINOR__ > 1 )
|
|
+# define VCL_GCC_92
|
|
+# elif (__GNUC_MINOR__ > 0 )
|
|
+# define VCL_GCC_91
|
|
+# else
|
|
+# define VCL_GCC_90
|
|
+# endif
|
|
+# elif (__GNUC__==10)
|
|
+# define VCL_GCC_10
|
|
+# if (__GNUC_MINOR__ > 2 )
|
|
+# define VCL_GCC_103
|
|
+# elif (__GNUC_MINOR__ > 1 )
|
|
+# define VCL_GCC_102
|
|
+# elif (__GNUC_MINOR__ > 0 )
|
|
+# define VCL_GCC_101
|
|
+# else
|
|
+# define VCL_GCC_100
|
|
+# endif
|
|
+# elif (__GNUC__==11)
|
|
+# define VCL_GCC_11
|
|
+# if (__GNUC_MINOR__ > 2 )
|
|
+# define VCL_GCC_113
|
|
+# elif (__GNUC_MINOR__ > 1 )
|
|
+# define VCL_GCC_112
|
|
+# elif (__GNUC_MINOR__ > 0 )
|
|
+# define VCL_GCC_111
|
|
+# else
|
|
+# define VCL_GCC_110
|
|
# endif
|
|
# else
|
|
# error "Dunno about this gcc"
|
|
endpatch
|
|
|
|
sed -i "s/lib\b/lib${LIBDIRSUFFIX}/" CMakeLists.txt
|
|
sed -i "s|/opj_config.h|& \$\{CMAKE_CURRENT_BINARY_DIR\}/openjpeg_mangle.h|" \
|
|
Modules/ThirdParty/GDCM/src/gdcm/Utilities/gdcmopenjpeg/src/lib/openjp2/CMakeLists.txt
|
|
|
|
mkdir -p build
|
|
cd build
|
|
cmake \
|
|
-DCMAKE_C_FLAGS="$SLKCFLAGS" \
|
|
-DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
|
|
-DCMAKE_INSTALL_PREFIX=/usr \
|
|
-DITK_FORBID_DOWNLOADS=ON \
|
|
-DITK_WRAP_PYTHON=OFF \
|
|
-DBUILD_SHARED_LIBS=ON \
|
|
-DBUILD_EXAMPLES=OFF \
|
|
-DITK_USE_SYSTEM_LIBRARIES=ON \
|
|
-DITK_USE_SYSTEM_DCMTK=ON \
|
|
-DITK_USE_SYSTEM_DOUBLECONVERSION=ON \
|
|
-DITK_USE_SYSTEM_EXPAT=ON \
|
|
-DITK_USE_SYSTEM_FFTW=ON \
|
|
-DITK_USE_SYSTEM_HDF5=ON \
|
|
-DITK_USE_SYSTEM_JPEG=ON \
|
|
-DITK_USE_SYSTEM_PNG=ON \
|
|
-DITK_USE_SYSTEM_TIFF=ON \
|
|
-DITK_USE_SYSTEM_ZLIB=ON \
|
|
-DCMAKE_BUILD_TYPE=Release ..
|
|
make install DESTDIR=$PKG
|
|
cd ..
|
|
|
|
# remove pkg-config file for openjpeg since this overwrites system package for something that should be internal to ITK
|
|
rm -rf $PKG/usr/lib64/pkgconfig
|
|
|
|
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
|
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
|
|
|
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
|
mv $PKG/usr/share/doc/$PRGNAM-$(echo $VERSION | cut -d "." -f 1,2)/* $PKG/usr/doc/$PRGNAM-$VERSION
|
|
rm -r $PKG/usr/share/doc
|
|
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
|
|
|
mkdir $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|