desktop/pypanel: Updated for version 2.4
This commit is contained in:
parent
5cb4ca98ee
commit
fcb536188c
|
@ -1,7 +1,11 @@
|
|||
PyPanel is a lightweight panel/taskbar written in Python and C for X11 window
|
||||
managers. It can be easily customized to match any desktop theme or taste. It
|
||||
works with WindowMaker and EWMH-compliant WMs (Kahakai, Openbox, FVWM, PekWM,
|
||||
etc).
|
||||
PyPanel is a lightweight panel/taskbar written in Python and C for X11
|
||||
window managers. It can be easily customized to match any desktop
|
||||
theme or taste. It works with WindowMaker and EWMH-compliant WMs
|
||||
(Kahakai, Openbox, FVWM, PekWM, etc).
|
||||
|
||||
Pypanel depends on python-xlib and imlib2, both available from slackbuilds.org
|
||||
NOTE: The pypanel.SlackBuild has support for an optional third-party
|
||||
patch which introduces a STARTUP_DELAY variable that makes pypanel
|
||||
load after an interval of time. This is useful in case the window
|
||||
manager is slow to load up before pypanel starts.
|
||||
|
||||
Pypanel requires python-xlib and imlib2.
|
||||
|
|
|
@ -0,0 +1,46 @@
|
|||
--- pypanel 2005-06-27 02:24:43.000000000 +0300
|
||||
+++ pypanel.new 2007-06-23 21:47:56.000000000 +0300
|
||||
@@ -95,6 +95,7 @@
|
||||
self.root.change_attributes(event_mask=(X.PropertyChangeMask))
|
||||
self.window.map()
|
||||
self.display.flush()
|
||||
+ self.updatePanel(self.root, self.window, self.panel)
|
||||
self.loop(self.display, self.root, self.window, self.panel)
|
||||
|
||||
#------------------------------------
|
||||
@@ -944,6 +945,9 @@
|
||||
main = 2.4
|
||||
config = globals().get("VERSION", None)
|
||||
|
||||
+ # Get the startup delay
|
||||
+ delay = globals().get("STARTUP_DELAY", None)
|
||||
+
|
||||
# Set locale to user's default
|
||||
locale.setlocale(locale.LC_ALL, "")
|
||||
|
||||
@@ -953,5 +957,9 @@
|
||||
sys.stderr.write("\nA current pypanelrc example can be found here -\n")
|
||||
sys.stderr.write("%s/pypanel/pypanelrc\n\n" % sysconfig.get_python_lib())
|
||||
del main, config
|
||||
-
|
||||
+
|
||||
+ # If delay is set, pause, and let windowmanager load
|
||||
+ if delay:
|
||||
+ time.sleep(delay)
|
||||
+
|
||||
PyPanel(display.Display())
|
||||
--- pypanelrc 2005-06-27 02:27:37.000000000 +0300
|
||||
+++ pypanelrc.new 2007-06-23 21:46:01.000000000 +0300
|
||||
@@ -9,6 +9,12 @@
|
||||
VERSION = 2.4 # Config file version
|
||||
|
||||
#------------------------------------------------------------------------------
|
||||
+# Startup delay: The time to wait before painting the pypanel window. This lets
|
||||
+# the background load up so that pypanel will be displayed correctly.
|
||||
+#------------------------------------------------------------------------------
|
||||
+STARTUP_DELAY = 2
|
||||
+
|
||||
+#------------------------------------------------------------------------------
|
||||
# Colors: Format is hex triplet - 0xrrggbb
|
||||
#------------------------------------------------------------------------------
|
||||
BG_COLOR = "0xd6d6d6" # Panel background and tinting color
|
|
@ -1,46 +1,53 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for pypanel
|
||||
# Written by Vasilis Papavasileiou <el03020 at mail dot ntua dot gr>
|
||||
# Originally written by Vasilis Papavasileiou
|
||||
# <el03020 at mail dot ntua dot gr>
|
||||
|
||||
# Modified by the SlackBuilds.org project
|
||||
# and Chess Griffin <chess@chessgriffin.com>
|
||||
|
||||
PRGNAM=pypanel
|
||||
VERSION=2.4
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-1}
|
||||
ARCH=i486 # See note below
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
# Re ARCH, this will use whatever CFLAGS python was compiled with, so...
|
||||
# Since this contains some C code, you will get an i486 package when
|
||||
# building on official Slackware. Adjust as appropriate.
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
ORIG_PRGNAM=PyPanel
|
||||
DOCS="COPYING PKG-INFO README"
|
||||
PYTHON_VERSION=${PYTHON_VERSION:-2.4}
|
||||
DOCS="COPYING PKG-INFO README pypanelrc"
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
fi
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $ORIG_PRGNAM-$VERSION
|
||||
tar -xzvf $CWD/$ORIG_PRGNAM-$VERSION.tar.gz || exit 1
|
||||
tar xvf $CWD/$ORIG_PRGNAM-$VERSION.tar.gz
|
||||
cd $ORIG_PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
chmod -R u+w,go+r-w,a-s .
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
python setup.py build || exit 1
|
||||
# Uncomment the patch line below if you want the STARTUP_DELAY
|
||||
# variable. This introduces a new configuration file variable called
|
||||
# STARTUP_DELAY which will make pypanel load after an interval of
|
||||
# time. This is useful in case the window manager is slow to load up
|
||||
# before pypanel starts.
|
||||
#patch < $CWD/loaddelay.patch
|
||||
|
||||
python setup.py install --root $PKG || exit 1
|
||||
|
||||
( cd $PKG
|
||||
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
||||
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null
|
||||
)
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
|
@ -48,7 +55,7 @@ cp $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
|
|||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
# Remove docs from site-packages
|
||||
rm $PKG/usr/lib/python${PYTHON_VERSION}/site-packages/${PRGNAM}/{COPYING,README}
|
||||
rm $PKG/usr/lib/python?.?/site-packages/${PRGNAM}/{COPYING,README}
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="pypanel"
|
||||
VERSION="2.4"
|
||||
HOMEPAGE="http://pypanel.sourceforge.net"
|
||||
DOWNLOAD="http://switch.dl.sourceforge.net/sourceforge/pypanel/PyPanel-2.4.tar.gz"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/pypanel/PyPanel-2.4.tar.gz"
|
||||
MD5SUM="f1f9a2ed80be72ab36e748833618daba"
|
||||
MAINTAINER="Vasilis Papavasileiou"
|
||||
EMAIL="el03020@mail.ntua.gr"
|
||||
MAINTAINER="Chess Griffin"
|
||||
EMAIL="chess@chessgriffin.com"
|
||||
APPROVED="rworkman"
|
||||
|
|
Loading…
Reference in New Issue