misc/stardict: Updated for version 3.0.6.2.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
ba05e0d9dc
commit
fc13eb20fa
File diff suppressed because it is too large
Load Diff
|
@ -1,24 +0,0 @@
|
|||
diff --git a/src/sigc++/signal_base.h b/src/sigc++/signal_base.h
|
||||
index 582a8f4..0d77ac5 100644
|
||||
--- a/src/sigc++/signal_base.h
|
||||
+++ b/src/sigc++/signal_base.h
|
||||
@@ -21,6 +21,7 @@
|
||||
#ifndef _SIGC_SIGNAL_BASE_H_
|
||||
#define _SIGC_SIGNAL_BASE_H_
|
||||
|
||||
+#include <cstddef>
|
||||
#include <list>
|
||||
#include <sigc++config.h>
|
||||
#include <sigc++/type_traits.h>
|
||||
diff --git a/stardict-plugins/stardict-wordnet-plugin/scene.hpp b/stardict-plugins/stardict-wordnet-plugin/scene.hpp
|
||||
index 54003ca..270b2e2 100644
|
||||
--- a/stardict-plugins/stardict-wordnet-plugin/scene.hpp
|
||||
+++ b/stardict-plugins/stardict-wordnet-plugin/scene.hpp
|
||||
@@ -9,6 +9,7 @@
|
||||
#include "partic.hpp"
|
||||
#include "spring.hpp"
|
||||
|
||||
+#include <cstdlib>
|
||||
#include <vector>
|
||||
using namespace std;
|
||||
|
|
@ -1,101 +0,0 @@
|
|||
Index: src/eggtrayicon.c
|
||||
===================================================================
|
||||
--- src/eggtrayicon.c (revision 248)
|
||||
+++ src/eggtrayicon.c (working copy)
|
||||
@@ -66,6 +66,8 @@
|
||||
|
||||
static void egg_tray_icon_realize (GtkWidget *widget);
|
||||
static void egg_tray_icon_unrealize (GtkWidget *widget);
|
||||
+static void egg_tray_icon_add (GtkContainer *container,
|
||||
+ GtkWidget *widget);
|
||||
|
||||
#ifdef GDK_WINDOWING_X11
|
||||
static void egg_tray_icon_update_manager_window (EggTrayIcon *icon,
|
||||
@@ -113,6 +115,7 @@
|
||||
{
|
||||
GObjectClass *gobject_class = (GObjectClass *)klass;
|
||||
GtkWidgetClass *widget_class = (GtkWidgetClass *)klass;
|
||||
+ GtkContainerClass *container_class = (GtkContainerClass *)klass;
|
||||
|
||||
parent_class = g_type_class_peek_parent (klass);
|
||||
|
||||
@@ -121,6 +124,8 @@
|
||||
widget_class->realize = egg_tray_icon_realize;
|
||||
widget_class->unrealize = egg_tray_icon_unrealize;
|
||||
|
||||
+ container_class->add = egg_tray_icon_add;
|
||||
+
|
||||
g_object_class_install_property (gobject_class,
|
||||
PROP_ORIENTATION,
|
||||
g_param_spec_enum ("orientation",
|
||||
@@ -159,8 +164,37 @@
|
||||
}
|
||||
|
||||
#ifdef GDK_WINDOWING_X11
|
||||
+static gboolean
|
||||
+transparent_expose_event (GtkWidget *widget, GdkEventExpose *event, gpointer user_data)
|
||||
+{
|
||||
+ gdk_window_clear_area (widget->window, event->area.x, event->area.y,
|
||||
+ event->area.width, event->area.height);
|
||||
+ return FALSE;
|
||||
+}
|
||||
|
||||
static void
|
||||
+make_transparent_again (GtkWidget *widget, GtkStyle *previous_style,
|
||||
+ gpointer user_data)
|
||||
+{
|
||||
+ gdk_window_set_back_pixmap(widget->window, NULL, TRUE);
|
||||
+}
|
||||
+
|
||||
+static void
|
||||
+make_transparent (GtkWidget *widget, gpointer user_data)
|
||||
+{
|
||||
+ if (GTK_WIDGET_NO_WINDOW (widget) || GTK_WIDGET_APP_PAINTABLE (widget))
|
||||
+ return;
|
||||
+
|
||||
+ gtk_widget_set_app_paintable (widget, TRUE);
|
||||
+ gtk_widget_set_double_buffered (widget, FALSE);
|
||||
+ gdk_window_set_back_pixmap (widget->window, NULL, TRUE);
|
||||
+ g_signal_connect (widget, "expose_event",
|
||||
+ G_CALLBACK (transparent_expose_event), NULL);
|
||||
+ g_signal_connect_after (widget, "style_set",
|
||||
+ G_CALLBACK (make_transparent_again), NULL);
|
||||
+}
|
||||
+
|
||||
+static void
|
||||
egg_tray_icon_get_orientation_property (EggTrayIcon *icon)
|
||||
{
|
||||
Display *xdisplay;
|
||||
@@ -238,10 +272,22 @@
|
||||
}
|
||||
return GDK_FILTER_CONTINUE;
|
||||
}
|
||||
-
|
||||
+#else
|
||||
+static void
|
||||
+make_transparent (GtkWidget *widget, gpointer user_data)
|
||||
+{
|
||||
+}
|
||||
#endif
|
||||
|
||||
static void
|
||||
+egg_tray_icon_add (GtkContainer *container, GtkWidget *widget)
|
||||
+{
|
||||
+ g_signal_connect (widget, "realize",
|
||||
+ G_CALLBACK (make_transparent), NULL);
|
||||
+ GTK_CONTAINER_CLASS (parent_class)->add (container, widget);
|
||||
+}
|
||||
+
|
||||
+static void
|
||||
egg_tray_icon_unrealize (GtkWidget *widget)
|
||||
{
|
||||
#ifdef GDK_WINDOWING_X11
|
||||
@@ -381,6 +427,8 @@
|
||||
if (GTK_WIDGET_CLASS (parent_class)->realize)
|
||||
GTK_WIDGET_CLASS (parent_class)->realize (widget);
|
||||
|
||||
+ make_transparent (widget, NULL);
|
||||
+
|
||||
screen = gtk_widget_get_screen (widget);
|
||||
display = gdk_screen_get_display (screen);
|
||||
xdisplay = gdk_x11_display_get_xdisplay (display);
|
|
@ -27,14 +27,14 @@
|
|||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=stardict
|
||||
VERSION=${VERSION:-3.0.6}
|
||||
VERSION=${VERSION:-3.0.6.2}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
i?86) ARCH=i586 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
|
@ -54,8 +54,8 @@ OUTPUT=${OUTPUT:-/tmp}
|
|||
|
||||
DOCS="AUTHORS COPYING ChangeLog INSTALL README"
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
if [ "$ARCH" = "i586" ]; then
|
||||
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
|
@ -74,7 +74,7 @@ rm -rf $PKG
|
|||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
|
||||
tar xf $CWD/$PRGNAM-$VERSION-github-2.tar.?z*
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
|
@ -83,6 +83,14 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
sed -i 's/, enchant/, enchant-2/' dict/configure.ac
|
||||
sed -i '/AM_GCONF_SOURCE_2/d' dict/configure.ac
|
||||
sed -i '/GNOME_DOC_INIT/d' dict/configure.ac
|
||||
sed -i '/gnome-doc-utils.make/d' dict/help/Makefile.am
|
||||
|
||||
./autogen.sh
|
||||
( cd dict ; ./autogen.sh )
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS -std=c++11" \
|
||||
./configure \
|
||||
|
@ -94,6 +102,7 @@ CXXFLAGS="$SLKCFLAGS -std=c++11" \
|
|||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--disable-gucharmap \
|
||||
--disable-festival \
|
||||
--disable-flite \
|
||||
--disable-espeak \
|
||||
--disable-gnome-support \
|
||||
--disable-schemas-install \
|
||||
|
@ -101,6 +110,7 @@ CXXFLAGS="$SLKCFLAGS -std=c++11" \
|
|||
--disable-static \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
sed -e 's/ -shared / -Wl,-O1,--as-needed\0/g' -i {dict,lib,tools}/libtool
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="stardict"
|
||||
VERSION="3.0.6"
|
||||
VERSION="3.0.6.2"
|
||||
HOMEPAGE="http://stardict-4.sourceforge.net/"
|
||||
DOWNLOAD="http://sourceforge.net/projects/stardict-4/files/3.0.6/stardict-3.0.6.tar.bz2"
|
||||
MD5SUM="93371b35482e6380e8bd4ba5d256b864"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/stardict-4/stardict-3.0.6.2-github-2.tar.xz"
|
||||
MD5SUM="bd16a483917f4ff356370feaf2bb8347"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="rarian"
|
||||
|
|
Loading…
Reference in New Issue