games/pcsx2: Removed by maintainer request.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
48546572c4
commit
f8e4e9d869
|
@ -1,27 +0,0 @@
|
|||
PCSX2 is an open source Playstation 2 emulator. Its purpose is to
|
||||
mimic the PS2 hardware, using a combination of MIPS CPU Interpreters,
|
||||
Recompilers and a Virtual Machine which manages hardware states and PS2
|
||||
system memory.
|
||||
|
||||
portaudio is an optional dependency.
|
||||
|
||||
NOTE: This is buildable only on x86 32bit platforms and will require
|
||||
a PS2 bios dump to play games. For x86_64 64bit platforms multilib
|
||||
support will be needed including compat32 versions of SDL2, wxGTK3,
|
||||
soundtouch and optionally portaudio.
|
||||
|
||||
PCSX2 offers experimental support for the EGL api instead of GLX. This
|
||||
can be used by building PCSX2 with:
|
||||
EGL_API=yes ./pcsx2.SlackBuild
|
||||
|
||||
To build debugging symbols for PCSX2 use:
|
||||
DEBUG=yes ./pcsx2.SlackBuild
|
||||
|
||||
Alternatively a devel build can be used:
|
||||
DEVEL=yes ./pcsx2.SlackBuild
|
||||
|
||||
If a debug or devel build is used, asan support can also be built:
|
||||
ASAN=yes ./pcsx2.SlackBuild
|
||||
|
||||
The following environment variable will be required to use asan:
|
||||
ASAN_OPTIONS=allow_user_segv_handler=1:abort_on_error=1
|
|
@ -1,13 +0,0 @@
|
|||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
|
||||
if [ -d /usr/lib/gdk-pixbuf-2.0/2.10.0 ]; then
|
||||
/usr/bin/gdk-pixbuf-query-loaders > /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache
|
||||
fi
|
||||
fi
|
||||
|
||||
if [ -x /sbin/setcap ] && [ -f usr/bin/PCSX2 ]; then
|
||||
/sbin/setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' usr/bin/PCSX2
|
||||
fi
|
|
@ -1,167 +0,0 @@
|
|||
#!/bin/bash
|
||||
|
||||
# Slackware build script for pcsx2
|
||||
|
||||
# Copyright 2016-2018, 2020 Hunter Sezen California, USA
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=pcsx2
|
||||
VERSION=${VERSION:-1.6.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i586 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
||||
# the name of the created package would be, and then exit. This information
|
||||
# could be useful to other scripts.
|
||||
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
||||
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
|
||||
exit 0
|
||||
fi
|
||||
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i586" ]; then
|
||||
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=core2"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -eu
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# pcsx2 does not support x86_64 yet and does
|
||||
# not plan to for the foreseeable future.
|
||||
BINDIR=; MULTILIB=
|
||||
if [ "$ARCH" = 'x86_64' ]; then
|
||||
BINDIR='/32'
|
||||
MULTILIB='-DCMAKE_TOOLCHAIN_FILE=cmake/linux-compiler-i386-multilib.cmake'
|
||||
fi
|
||||
|
||||
RELEASE=Debug
|
||||
|
||||
if [ "${DEVEL:-0}" != 0 ]; then
|
||||
DEBUG=1
|
||||
RELEASE=Devel
|
||||
fi
|
||||
|
||||
if [ "${DEBUG:=0}" != 0 ]; then
|
||||
[ "${ASAN:=FALSE}" != FALSE ] && ASAN=TRUE
|
||||
SLKCFLAGS="$(printf %s "$SLKCFLAGS" | sed 's/-O2/-O0/')"
|
||||
else
|
||||
ASAN=FALSE
|
||||
RELEASE=Release
|
||||
fi
|
||||
|
||||
[ "${EGL_API:=OFF}" != OFF ] && EGL_API=ON
|
||||
|
||||
# Handle this in doinst.sh instead
|
||||
# https://github.com/PCSX2/pcsx2/issues/2699
|
||||
sed -i '/setcap/d' pcsx2/CMakeLists.txt
|
||||
|
||||
# Use a font included with Slackware
|
||||
# osd error: 'Failed to init the freetype face'
|
||||
sed -i \
|
||||
's|truetype/freefont/FreeSerif.ttf|TTF/LiberationSerif-Regular.ttf|' \
|
||||
plugins/GSdx/GSdx.cpp
|
||||
|
||||
# spu2-x: Make portaudio an optional dependency.
|
||||
# https://github.com/PCSX2/pcsx2/pull/3110
|
||||
# https://github.com/PCSX2/pcsx2/commit/84d090e2fde50c66b965b84c73abd9f04a1770dd
|
||||
patch -p1 < $CWD/portaudio.patch
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
cmake \
|
||||
-DCMAKE_C_FLAGS="$SLKCFLAGS" \
|
||||
-DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DDOC_DIR=/usr/doc/$PRGNAM-$VERSION \
|
||||
-DMAN_DIR=/usr/man \
|
||||
-DwxWidgets_CONFIG_EXECUTABLE=/usr/bin${BINDIR}/wx-config \
|
||||
-DwxWidgets_wxrc_EXECUTABLE=/usr/bin${BINDIR}/wxrc-3.0 \
|
||||
-DBUILD_REPLAY_LOADERS=TRUE \
|
||||
-DDISABLE_BUILD_DATE=ON \
|
||||
-DGSDX_LEGACY=ON \
|
||||
-DPACKAGE_MODE=ON \
|
||||
-DXDG_STD=ON \
|
||||
-DEGL_API=$EGL_API \
|
||||
-DUSE_ASAN=$ASAN \
|
||||
$MULTILIB \
|
||||
-DCMAKE_BUILD_TYPE=$RELEASE ..
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
cd ..
|
||||
|
||||
if [ "$DEBUG" = 0 ]; then
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
|
||||
grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
fi
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a pcsx2/Docs/* bin/docs/*.html bin/docs/*.txt CONTRIBUTING.md COPYING* \
|
||||
README.md $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
# Fix doinst.sh for x86_64
|
||||
[ "$ARCH" != 'x86_64' ] ||
|
||||
sed -i 's|-loaders |-loaders-32 |' $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|
|
@ -1,10 +0,0 @@
|
|||
PRGNAM="pcsx2"
|
||||
VERSION="1.6.0"
|
||||
HOMEPAGE="https://pcsx2.net"
|
||||
DOWNLOAD="https://github.com/PCSX2/pcsx2/archive/v1.6.0/pcsx2-1.6.0.tar.gz"
|
||||
MD5SUM="51185d06f77b39df03e42fc68710c174"
|
||||
DOWNLOAD_x86_64="UNSUPPORTED"
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="wxGTK3 soundtouch"
|
||||
MAINTAINER="Hunter Sezen"
|
||||
EMAIL="orbea@riseup.net"
|
|
@ -1,320 +0,0 @@
|
|||
From 84d090e2fde50c66b965b84c73abd9f04a1770dd Mon Sep 17 00:00:00 2001
|
||||
From: orbea <orbea@riseup.net>
|
||||
Date: Thu, 7 May 2020 15:31:48 +0000
|
||||
Subject: [PATCH] spu2-x: Make portaudio an optional dependency. (#3110)
|
||||
|
||||
* spu2-x: Make portaudio an optional dependency.
|
||||
|
||||
v2: Fix crash in the audio settings with SDL1 and without portaudio.
|
||||
|
||||
* cmake: Add PORTAUDIO_API to disable portaudio support.
|
||||
---
|
||||
build.sh | 4 +++-
|
||||
cmake/BuildParameters.cmake | 1 +
|
||||
cmake/SearchForStuff.cmake | 6 ++++--
|
||||
cmake/SelectPcsx2Plugins.cmake | 15 ++++++++-------
|
||||
plugins/spu2-x/src/CMakeLists.txt | 19 ++++++++++++++++---
|
||||
plugins/spu2-x/src/Linux/Config.cpp | 20 +++++++++++++++++++-
|
||||
plugins/spu2-x/src/SndOut.cpp | 2 ++
|
||||
plugins/spu2-x/src/SndOut.h | 2 ++
|
||||
8 files changed, 55 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/build.sh b/build.sh
|
||||
index e1bc256475..54b30e404e 100755
|
||||
--- a/build.sh
|
||||
+++ b/build.sh
|
||||
@@ -213,6 +213,7 @@ for ARG in "$@"; do
|
||||
--pgo-optimize ) flags="$flags -DUSE_PGO_OPTIMIZE=TRUE" ;;
|
||||
--pgo-generate ) flags="$flags -DUSE_PGO_GENERATE=TRUE" ;;
|
||||
--no-dev9ghzdrk ) flags="$flags -DDISABLE_DEV9GHZDRK=TRUE" ;;
|
||||
+ --no-portaudio ) flags="$flags -DPORTAUDIO_API=FALSE" ;;
|
||||
--no-simd ) flags="$flags -DDISABLE_ADVANCE_SIMD=TRUE" ;;
|
||||
--no-trans ) flags="$flags -DNO_TRANSLATION=TRUE" ;;
|
||||
--cross-multilib ) flags="$flags -DCMAKE_TOOLCHAIN_FILE=$toolfile"; useCross=1; ;;
|
||||
@@ -244,7 +245,8 @@ for ARG in "$@"; do
|
||||
echo
|
||||
echo "** Distribution Compatibilities **"
|
||||
echo "--sdl12 : Build with SDL1.2 (requires if wx is linked against SDL1.2)"
|
||||
- echo "--no-dev9ghzdrk : Skip dev9ghzdrk. (Avoids needing escalated privileges to build.)"
|
||||
+ echo "--no-dev9ghzdrk : Skip dev9ghzdrk. (Avoids needing escalated privileges to build.)"
|
||||
+ echo "--no-portaudio : Skip portaudio for spu2x."
|
||||
echo
|
||||
echo "** Expert Developer option **"
|
||||
echo "--gtk3 : replace GTK2 by GTK3"
|
||||
diff --git a/cmake/BuildParameters.cmake b/cmake/BuildParameters.cmake
|
||||
index 235bdb8e59..83bab90dab 100644
|
||||
--- a/cmake/BuildParameters.cmake
|
||||
+++ b/cmake/BuildParameters.cmake
|
||||
@@ -48,6 +48,7 @@ option(DISABLE_CHEATS_ZIP "Disable including the cheats_ws.zip file")
|
||||
option(DISABLE_PCSX2_WRAPPER "Disable including the PCSX2-linux.sh file")
|
||||
option(XDG_STD "Use XDG standard path instead of the standard PCSX2 path")
|
||||
option(EXTRA_PLUGINS "Build various 'extra' plugins")
|
||||
+option(PORTAUDIO_API "Build portaudio support on spu2x" ON)
|
||||
option(SDL2_API "Use SDL2 on spu2x and onepad (wxWidget mustn't be built with SDL1.2 support" ON)
|
||||
option(GTK3_API "Use GTK3 api (experimental/wxWidget must be built with GTK3 support)")
|
||||
|
||||
diff --git a/cmake/SearchForStuff.cmake b/cmake/SearchForStuff.cmake
|
||||
index a062d457a3..50f8f5f3e8 100644
|
||||
--- a/cmake/SearchForStuff.cmake
|
||||
+++ b/cmake/SearchForStuff.cmake
|
||||
@@ -105,7 +105,9 @@ endif()
|
||||
if(OPENCL_API)
|
||||
check_lib(OPENCL OpenCL CL/cl.hpp)
|
||||
endif()
|
||||
-check_lib(PORTAUDIO portaudio portaudio.h pa_linux_alsa.h)
|
||||
+if(PORTAUDIO_API)
|
||||
+ check_lib(PORTAUDIO portaudio portaudio.h pa_linux_alsa.h)
|
||||
+endif()
|
||||
check_lib(SOUNDTOUCH SoundTouch soundtouch/SoundTouch.h)
|
||||
|
||||
if(SDL2_API)
|
||||
@@ -227,4 +229,4 @@ if((GCC_VERSION VERSION_EQUAL "9.0" OR GCC_VERSION VERSION_GREATER "9.0") AND GC
|
||||
https://gitweb.gentoo.org/proj/gcc-patches.git/commit/?id=275ab714637a64672c6630cfd744af2c70957d5a
|
||||
Even with that patch, compiling with LTO may still segfault. Use at your own risk!
|
||||
This text being in a compile log in an open issue may cause it to be closed.")
|
||||
-endif()
|
||||
\ No newline at end of file
|
||||
+endif()
|
||||
diff --git a/cmake/SelectPcsx2Plugins.cmake b/cmake/SelectPcsx2Plugins.cmake
|
||||
index 69d0e07b91..00bf22e6ca 100644
|
||||
--- a/cmake/SelectPcsx2Plugins.cmake
|
||||
+++ b/cmake/SelectPcsx2Plugins.cmake
|
||||
@@ -7,7 +7,7 @@ set(msg_dep_cdvdgiga "check these libraries -> gtk2, libudev")
|
||||
set(msg_dep_zerogs "check these libraries -> glew, opengl, X11, nvidia-cg-toolkit (>=2.1)")
|
||||
set(msg_dep_gsdx "check these libraries -> opengl, png (>=1.2), zlib (>=1.2.4), X11, liblzma")
|
||||
set(msg_dep_onepad "check these libraries -> sdl2, X11, gtk2")
|
||||
-set(msg_dep_spu2x "check these libraries -> soundtouch (>=1.5), alsa, portaudio (>=1.9), sdl (>=1.2) pcsx2 common libs")
|
||||
+set(msg_dep_spu2x "check these libraries -> soundtouch (>=1.5), alsa, portaudio (optional, >=1.9), sdl (>=1.2), pcsx2 common libs")
|
||||
set(msg_dep_zerospu2 "check these libraries -> soundtouch (>=1.5), alsa")
|
||||
set(msg_dep_dev "check these libraries -> gtk2, pcap, libxml2")
|
||||
if(GLSL_API)
|
||||
@@ -267,12 +267,13 @@ endif()
|
||||
# spu2-x
|
||||
#---------------------------------------
|
||||
# requires: -SoundTouch
|
||||
-# -ALSA
|
||||
-# -Portaudio
|
||||
+# -ALSA
|
||||
# -SDL
|
||||
# -common_libs
|
||||
+#
|
||||
+# optional: -Portaudio
|
||||
#---------------------------------------
|
||||
-if((PORTAUDIO_FOUND AND SOUNDTOUCH_FOUND AND SDLn_FOUND AND common_libs)
|
||||
+if((SOUNDTOUCH_FOUND AND SDLn_FOUND AND common_libs)
|
||||
AND ((Linux AND ALSA_FOUND) OR (UNIX AND NOT Linux)))
|
||||
set(spu2-x TRUE)
|
||||
elseif(NOT EXISTS "${CMAKE_SOURCE_DIR}/plugins/spu2-x")
|
||||
@@ -287,8 +288,8 @@ endif()
|
||||
# zerospu2
|
||||
#---------------------------------------
|
||||
# requires: -SoundTouch
|
||||
-# -ALSA
|
||||
-# -PortAudio
|
||||
+# -ALSA
|
||||
+# -PortAudio
|
||||
#---------------------------------------
|
||||
if(EXTRA_PLUGINS)
|
||||
if(EXISTS "${CMAKE_SOURCE_DIR}/plugins/zerospu2" AND SOUNDTOUCH_FOUND AND ALSA_FOUND)
|
||||
@@ -312,4 +313,4 @@ if(GTKn_FOUND)
|
||||
set(USBnull TRUE)
|
||||
endif()
|
||||
#---------------------------------------
|
||||
-#-------------------------------------------------------------------------------
|
||||
\ No newline at end of file
|
||||
+#-------------------------------------------------------------------------------
|
||||
diff --git a/plugins/spu2-x/src/CMakeLists.txt b/plugins/spu2-x/src/CMakeLists.txt
|
||||
index e4c7141287..d17538e33e 100644
|
||||
--- a/plugins/spu2-x/src/CMakeLists.txt
|
||||
+++ b/plugins/spu2-x/src/CMakeLists.txt
|
||||
@@ -45,7 +45,6 @@ set(spu2xSources
|
||||
RegTable.cpp
|
||||
Reverb.cpp
|
||||
SndOut.cpp
|
||||
- SndOut_Portaudio.cpp
|
||||
SndOut_SDL.cpp
|
||||
spu2freeze.cpp
|
||||
Spu2replay.cpp
|
||||
@@ -111,7 +110,6 @@ else()
|
||||
include_directories(Linux)
|
||||
endif()
|
||||
|
||||
-
|
||||
set(spu2xFinalSources
|
||||
${spu2xSources}
|
||||
${spu2xHeaders}
|
||||
@@ -121,11 +119,26 @@ set(spu2xFinalSources
|
||||
set(spu2xFinalLibs
|
||||
Utilities_NO_TLS
|
||||
${ALSA_LIBRARIES}
|
||||
- ${PORTAUDIO_LIBRARIES}
|
||||
${GTK2_LIBRARIES}
|
||||
${SOUNDTOUCH_LIBRARIES}
|
||||
)
|
||||
|
||||
+if (PORTAUDIO_FOUND)
|
||||
+ set(spu2xFinalFlags
|
||||
+ ${spu2xFinalFlags}
|
||||
+ "-DSPU2X_PORTAUDIO"
|
||||
+ )
|
||||
+
|
||||
+ LIST(APPEND spu2xFinalSources
|
||||
+ SndOut_Portaudio.cpp
|
||||
+ )
|
||||
+
|
||||
+ set(spu2xFinalLibs
|
||||
+ ${spu2xFinalLibs}
|
||||
+ ${PORTAUDIO_LIBRARIES}
|
||||
+ )
|
||||
+endif()
|
||||
+
|
||||
if (SDL2_API)
|
||||
set(spu2xFinalLibs
|
||||
${spu2xFinalLibs}
|
||||
diff --git a/plugins/spu2-x/src/Linux/Config.cpp b/plugins/spu2-x/src/Linux/Config.cpp
|
||||
index 998f9bd25a..96a9e7bc8b 100644
|
||||
--- a/plugins/spu2-x/src/Linux/Config.cpp
|
||||
+++ b/plugins/spu2-x/src/Linux/Config.cpp
|
||||
@@ -76,7 +76,9 @@ bool _visual_debug_enabled = false; // windows only feature
|
||||
u32 OutputModule = 0;
|
||||
int SndOutLatencyMS = 300;
|
||||
int SynchMode = 0; // Time Stretch, Async or Disabled
|
||||
+#ifdef SPU2X_PORTAUDIO
|
||||
static u32 OutputAPI = 0;
|
||||
+#endif
|
||||
static u32 SdlOutputAPI = 0;
|
||||
|
||||
int numSpeakers = 0;
|
||||
@@ -122,7 +124,7 @@ void ReadSettings()
|
||||
|
||||
wxString temp;
|
||||
|
||||
-#if SDL_MAJOR_VERSION >= 2
|
||||
+#if SDL_MAJOR_VERSION >= 2 || !defined(SPU2X_PORTAUDIO)
|
||||
CfgReadStr(L"OUTPUT", L"Output_Module", temp, SDLOut->GetIdent());
|
||||
#else
|
||||
CfgReadStr(L"OUTPUT", L"Output_Module", temp, PortaudioOut->GetIdent());
|
||||
@@ -130,6 +132,7 @@ void ReadSettings()
|
||||
OutputModule = FindOutputModuleById(temp.c_str()); // find the driver index of this module
|
||||
|
||||
// find current API
|
||||
+#ifdef SPU2X_PORTAUDIO
|
||||
#ifdef __linux__
|
||||
CfgReadStr(L"PORTAUDIO", L"HostApi", temp, L"ALSA");
|
||||
if (temp == L"OSS")
|
||||
@@ -142,6 +145,7 @@ void ReadSettings()
|
||||
CfgReadStr(L"PORTAUDIO", L"HostApi", temp, L"OSS");
|
||||
OutputAPI = 0; // L"OSS"
|
||||
#endif
|
||||
+#endif
|
||||
|
||||
#ifdef __unix__
|
||||
CfgReadStr(L"SDL", L"HostApi", temp, L"pulseaudio");
|
||||
@@ -158,7 +162,9 @@ void ReadSettings()
|
||||
SndOutLatencyMS = CfgReadInt(L"OUTPUT", L"Latency", 300);
|
||||
SynchMode = CfgReadInt(L"OUTPUT", L"Synch_Mode", 0);
|
||||
|
||||
+#ifdef SPU2X_PORTAUDIO
|
||||
PortaudioOut->ReadSettings();
|
||||
+#endif
|
||||
#ifdef __unix__
|
||||
SDLOut->ReadSettings();
|
||||
#endif
|
||||
@@ -209,7 +215,9 @@ void WriteSettings()
|
||||
CfgWriteInt(L"OUTPUT", L"Synch_Mode", SynchMode);
|
||||
CfgWriteInt(L"DEBUG", L"DelayCycles", delayCycles);
|
||||
|
||||
+#ifdef SPU2X_PORTAUDIO
|
||||
PortaudioOut->WriteSettings();
|
||||
+#endif
|
||||
#ifdef __unix__
|
||||
SDLOut->WriteSettings();
|
||||
#endif
|
||||
@@ -273,7 +281,9 @@ void DisplayDialog()
|
||||
|
||||
GtkWidget *output_frame, *output_box;
|
||||
GtkWidget *mod_label, *mod_box;
|
||||
+#ifdef SPU2X_PORTAUDIO
|
||||
GtkWidget *api_label, *api_box;
|
||||
+#endif
|
||||
#if SDL_MAJOR_VERSION >= 2
|
||||
GtkWidget *sdl_api_label, *sdl_api_box;
|
||||
#endif
|
||||
@@ -309,11 +319,14 @@ void DisplayDialog()
|
||||
mod_label = gtk_label_new("Module:");
|
||||
mod_box = gtk_combo_box_text_new();
|
||||
gtk_combo_box_text_append_text(GTK_COMBO_BOX_TEXT(mod_box), "0 - No Sound (Emulate SPU2 only)");
|
||||
+#ifdef SPU2X_PORTAUDIO
|
||||
gtk_combo_box_text_append_text(GTK_COMBO_BOX_TEXT(mod_box), "1 - PortAudio (Cross-platform)");
|
||||
+#endif
|
||||
gtk_combo_box_text_append_text(GTK_COMBO_BOX_TEXT(mod_box), "2 - SDL Audio (Recommended for PulseAudio)");
|
||||
//gtk_combo_box_text_append_text(GTK_COMBO_BOX_TEXT(mod_box), "3 - Alsa (probably doesn't work)");
|
||||
gtk_combo_box_set_active(GTK_COMBO_BOX(mod_box), OutputModule);
|
||||
|
||||
+#ifdef SPU2X_PORTAUDIO
|
||||
api_label = gtk_label_new("PortAudio API:");
|
||||
api_box = gtk_combo_box_text_new();
|
||||
#ifdef __linux__
|
||||
@@ -325,6 +338,7 @@ void DisplayDialog()
|
||||
gtk_combo_box_text_append_text(GTK_COMBO_BOX_TEXT(api_box), "OSS");
|
||||
#endif
|
||||
gtk_combo_box_set_active(GTK_COMBO_BOX(api_box), OutputAPI);
|
||||
+#endif
|
||||
|
||||
#if SDL_MAJOR_VERSION >= 2
|
||||
sdl_api_label = gtk_label_new("SDL API:");
|
||||
@@ -383,8 +397,10 @@ void DisplayDialog()
|
||||
|
||||
gtk_container_add(GTK_CONTAINER(output_box), mod_label);
|
||||
gtk_container_add(GTK_CONTAINER(output_box), mod_box);
|
||||
+#ifdef SPU2X_PORTAUDIO
|
||||
gtk_container_add(GTK_CONTAINER(output_box), api_label);
|
||||
gtk_container_add(GTK_CONTAINER(output_box), api_box);
|
||||
+#endif
|
||||
#if SDL_MAJOR_VERSION >= 2
|
||||
gtk_container_add(GTK_CONTAINER(output_box), sdl_api_label);
|
||||
gtk_container_add(GTK_CONTAINER(output_box), sdl_api_box);
|
||||
@@ -430,6 +446,7 @@ void DisplayDialog()
|
||||
if (gtk_combo_box_get_active(GTK_COMBO_BOX(mod_box)) != -1)
|
||||
OutputModule = gtk_combo_box_get_active(GTK_COMBO_BOX(mod_box));
|
||||
|
||||
+#ifdef SPU2X_PORTAUDIO
|
||||
if (gtk_combo_box_get_active(GTK_COMBO_BOX(api_box)) != -1) {
|
||||
OutputAPI = gtk_combo_box_get_active(GTK_COMBO_BOX(api_box));
|
||||
#ifdef __linux__
|
||||
@@ -456,6 +473,7 @@ void DisplayDialog()
|
||||
}
|
||||
#endif
|
||||
}
|
||||
+#endif
|
||||
|
||||
#if SDL_MAJOR_VERSION >= 2
|
||||
if (gtk_combo_box_get_active(GTK_COMBO_BOX(sdl_api_box)) != -1) {
|
||||
diff --git a/plugins/spu2-x/src/SndOut.cpp b/plugins/spu2-x/src/SndOut.cpp
|
||||
index 7963b12b75..6d9d58c2b3 100644
|
||||
--- a/plugins/spu2-x/src/SndOut.cpp
|
||||
+++ b/plugins/spu2-x/src/SndOut.cpp
|
||||
@@ -88,7 +88,9 @@ SndOutModule *mods[] =
|
||||
DSoundOut,
|
||||
WaveOut,
|
||||
#endif
|
||||
+#if defined(_WIN32) || defined(SPU2X_PORTAUDIO)
|
||||
PortaudioOut,
|
||||
+#endif
|
||||
#if defined(SPU2X_SDL) || defined(SPU2X_SDL2)
|
||||
SDLOut,
|
||||
#endif
|
||||
diff --git a/plugins/spu2-x/src/SndOut.h b/plugins/spu2-x/src/SndOut.h
|
||||
index ba84075aec..918d9d08ff 100644
|
||||
--- a/plugins/spu2-x/src/SndOut.h
|
||||
+++ b/plugins/spu2-x/src/SndOut.h
|
||||
@@ -673,7 +673,9 @@ extern SndOutModule *DSoundOut;
|
||||
extern SndOutModule *XAudio2_27_Out;
|
||||
extern SndOutModule *XAudio2Out;
|
||||
#endif
|
||||
+#if defined(_WIN32) || defined(SPU2X_PORTAUDIO)
|
||||
extern SndOutModule *PortaudioOut;
|
||||
+#endif
|
||||
#if defined(SPU2X_SDL) || defined(SPU2X_SDL2)
|
||||
extern SndOutModule *const SDLOut;
|
||||
#endif
|
|
@ -1,19 +0,0 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
pcsx2: pcsx2 (Playstation 2 emulator)
|
||||
pcsx2:
|
||||
pcsx2: PCSX2 is a PlayStation 2 emulator for Windows and Linux, started by
|
||||
pcsx2: the same team that brought you PCSX (a Sony PlayStation 1 emulator).
|
||||
pcsx2:
|
||||
pcsx2: homepage: https://pcsx2.net
|
||||
pcsx2:
|
||||
pcsx2:
|
||||
pcsx2:
|
||||
pcsx2:
|
||||
pcsx2:
|
Loading…
Reference in New Issue