office/pdfshuffler: Built against newer PyPDF + new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
930330f992
commit
f8d31f1f93
|
@ -0,0 +1,12 @@
|
|||
diff -Naur pdfshuffler-0.6.0/pdfshuffler/pdfshuffler.py pdfshuffler-0.6.0-patched/pdfshuffler/pdfshuffler.py
|
||||
--- pdfshuffler-0.6.0/pdfshuffler/pdfshuffler.py 2012-04-28 15:15:17.000000000 +0100
|
||||
+++ pdfshuffler-0.6.0-patched/pdfshuffler/pdfshuffler.py 2015-11-24 16:27:34.381182962 +0000
|
||||
@@ -71,7 +71,7 @@
|
||||
import cairo
|
||||
|
||||
import poppler #for the rendering of pdf pages
|
||||
-from pyPdf import PdfFileWriter, PdfFileReader
|
||||
+from PyPDF2 import PdfFileWriter, PdfFileReader
|
||||
|
||||
from pdfshuffler_iconview import CellRendererImage
|
||||
gobject.type_register(CellRendererImage)
|
|
@ -23,8 +23,8 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=pdfshuffler
|
||||
VERSION=0.6.0
|
||||
BUILD=${BUILD:-1}
|
||||
VERSION=${VERSION:-0.6.0}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -53,10 +53,12 @@ cd $PRGNAM-$VERSION
|
|||
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
patch --verbose -p1 < $CWD/pdfshuffler-PyPDF2.diff
|
||||
|
||||
python setup.py install --root=$PKG
|
||||
|
||||
|
|
|
@ -6,5 +6,5 @@ MD5SUM="573f42e8392d20e6f03557096c85c178"
|
|||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="pyPdf pypoppler"
|
||||
MAINTAINER="Howard Pepper"
|
||||
EMAIL="h_pepper <at> bellsouth {dot} net"
|
||||
MAINTAINER="Rob van Nues"
|
||||
EMAIL="rvnues at tesco {dot} net"
|
||||
|
|
Loading…
Reference in New Issue