graphics/tuxpaint: Added to 13.0 repository
This commit is contained in:
parent
4e74b51c78
commit
f885c29e2c
|
@ -0,0 +1,15 @@
|
|||
Tux Paint: Open Source Drawing Software for Children
|
||||
|
||||
"Tux Paint" is a drawing program for young children.
|
||||
It provides a simple interface and fixed canvas size,
|
||||
and provides access to previous images using a thumbnail
|
||||
browser (e.g., no access to the underlying file-system).
|
||||
|
||||
Unlike popular drawing programs like "The GIMP," it has a
|
||||
very limited tool-set. However, it provides a much simpler
|
||||
interface, and has entertaining, child-oriented additions
|
||||
such as sound effects.
|
||||
|
||||
Require: libpaper.
|
||||
|
||||
Optional libraries: SDL_pango, librsvg.
|
|
@ -0,0 +1,29 @@
|
|||
config() {
|
||||
NEW="$1"
|
||||
OLD="$(dirname $NEW)/$(basename $NEW .new)"
|
||||
# If there's no config file by that name, mv it over:
|
||||
if [ ! -r $OLD ]; then
|
||||
mv $NEW $OLD
|
||||
elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
|
||||
# toss the redundant copy
|
||||
rm $NEW
|
||||
fi
|
||||
# Otherwise, we leave the .new copy for the admin to consider...
|
||||
}
|
||||
|
||||
config etc/tuxpaint/tuxpaint.conf.new
|
||||
|
||||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -x /usr/bin/update-mime-database ]; then
|
||||
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
|
||||
fi
|
||||
fi
|
||||
|
|
@ -0,0 +1,114 @@
|
|||
diff -ur tuxpaint-0.9.21.org/Makefile tuxpaint-0.9.21/Makefile
|
||||
--- tuxpaint-0.9.21.org/Makefile 2009-04-29 02:18:57.000000000 -0300
|
||||
+++ tuxpaint-0.9.21/Makefile 2009-10-31 20:56:18.000000000 -0300
|
||||
@@ -120,14 +120,14 @@
|
||||
|
||||
# Magic Tool plug-ins
|
||||
INCLUDE_PREFIX:=$(DESTDIR)$(PREFIX)/include
|
||||
-MAGIC_PREFIX:=$(DESTDIR)$(PREFIX)/lib/tuxpaint/plugins
|
||||
+MAGIC_PREFIX:=$(DESTDIR)$(PREFIX)/lib$(LIBDIRSUFFIX)/tuxpaint/plugins
|
||||
|
||||
|
||||
# Docs and man page:
|
||||
-DOC_PREFIX:=$(DESTDIR)$(PREFIX)/share/doc/tuxpaint
|
||||
-DEVDOC_PREFIX:=$(DESTDIR)$(PREFIX)/share/doc/tuxpaint-dev
|
||||
-MAN_PREFIX:=$(DESTDIR)$(PREFIX)/share/man
|
||||
-DEVMAN_PREFIX:=$(DESTDIR)$(PREFIX)/share/man
|
||||
+DOC_PREFIX:=$(DESTDIR)$(PREFIX)/doc/tuxpaint-$(VER_VERSION)
|
||||
+DEVDOC_PREFIX:=$(DESTDIR)$(PREFIX)/doc/tuxpaint-$(VER_VERSION)/tuxpaint-dev
|
||||
+MAN_PREFIX:=$(DESTDIR)$(PREFIX)/man
|
||||
+DEVMAN_PREFIX:=$(DESTDIR)$(PREFIX)/man
|
||||
|
||||
|
||||
# 'System-wide' Config file:
|
||||
@@ -139,10 +139,10 @@
|
||||
|
||||
# Icons and launchers:
|
||||
ICON_PREFIX:=$(DESTDIR)$(PREFIX)/share/pixmaps
|
||||
-X11_ICON_PREFIX:=$(DESTDIR)$(PREFIX)/X11R6/include/X11/pixmaps
|
||||
+X11_ICON_PREFIX:=$(DESTDIR)$(PREFIX)/share/pixmaps
|
||||
GNOME_PREFIX:=$(shell gnome-config --prefix 2> /dev/null)
|
||||
-KDE_PREFIX:=$(shell kde-config --install apps --expandvars 2> /dev/null)
|
||||
-KDE_ICON_PREFIX:=$(shell kde-config --install icon --expandvars 2> /dev/null)
|
||||
+KDE_PREFIX:=/usr/share/applications
|
||||
+KDE_ICON_PREFIX:=$(shell kde4-config --install icon --expandvars 2> /dev/null)
|
||||
|
||||
# Maemo flag
|
||||
MAEMOFLAG:=
|
||||
@@ -393,7 +393,7 @@
|
||||
windows_ARCH_INSTALL:=
|
||||
osx_ARCH_INSTALL:=
|
||||
beos_ARCH_INSTALL:=
|
||||
-linux_ARCH_INSTALL:=install-gnome install-kde install-kde-icons
|
||||
+linux_ARCH_INSTALL:=install-kde install-kde-icons
|
||||
ARCH_INSTALL:=$($(OS)_ARCH_INSTALL)
|
||||
|
||||
# "make install" installs all of the various parts
|
||||
@@ -449,7 +449,8 @@
|
||||
@cp src/tp_magic_api.h $(INCLUDE_PREFIX)/tuxpaint
|
||||
@chmod a+r,g-w,o-w $(INCLUDE_PREFIX)/tuxpaint/tp_magic_api.h
|
||||
@install -d $(DEVDOC_PREFIX)
|
||||
- @cp -R magic/docs/* $(DEVDOC_PREFIX)
|
||||
+ @cp magic/docs/*.txt $(DEVDOC_PREFIX)
|
||||
+ @cp magic/magic-docs/*.txt $(DEVDOC_PREFIX)
|
||||
@chmod a=rX,g=rX,u=rwX $(DEVDOC_PREFIX)
|
||||
|
||||
# Installs the various parts for the MinGW/MSYS development/testing environment.
|
||||
@@ -521,7 +522,7 @@
|
||||
rm /usr/share/pixmaps/tuxpaint.png; \
|
||||
fi
|
||||
-if [ "x$(KDE_PREFIX)" != "x" ]; then \
|
||||
- rm $(KDE_PREFIX)/Graphics/tuxpaint.desktop; \
|
||||
+ rm $(KDE_PREFIX)/tuxpaint.desktop; \
|
||||
fi
|
||||
-rm $(ICON_PREFIX)/tuxpaint.png
|
||||
-rm $(X11_ICON_PREFIX)/tuxpaint.xpm
|
||||
@@ -628,9 +629,9 @@
|
||||
@echo
|
||||
@echo "...Installing launcher icon into KDE..."
|
||||
@if [ "x$(KDE_PREFIX)" != "x" ]; then \
|
||||
- install -d $(DESTDIR)$(KDE_PREFIX)/Graphics; \
|
||||
- cp src/tuxpaint.desktop $(DESTDIR)$(KDE_PREFIX)/Graphics/; \
|
||||
- chmod 644 $(DESTDIR)$(KDE_PREFIX)/Graphics/tuxpaint.desktop; \
|
||||
+ install -d $(DESTDIR)$(KDE_PREFIX)/; \
|
||||
+ cp src/tuxpaint.desktop $(DESTDIR)$(KDE_PREFIX)/; \
|
||||
+ chmod 644 $(DESTDIR)$(KDE_PREFIX)/tuxpaint.desktop; \
|
||||
fi
|
||||
|
||||
.PHONY: install-kde-icons
|
||||
@@ -791,8 +792,7 @@
|
||||
@echo
|
||||
@echo "...Installing documentation..."
|
||||
@install -d $(DOC_PREFIX)
|
||||
- @cp -R docs/* $(DOC_PREFIX)
|
||||
- @cp -R magic/magic-docs $(DOC_PREFIX)
|
||||
+ @cp docs/*.txt $(DOC_PREFIX)
|
||||
@chmod -R a=rX,g=rX,u=rwX $(DOC_PREFIX)
|
||||
|
||||
|
||||
@@ -806,21 +806,21 @@
|
||||
@# tuxpaint.1
|
||||
@cp src/manpage/tuxpaint.1 $(MAN_PREFIX)/man1
|
||||
@gzip -f $(MAN_PREFIX)/man1/tuxpaint.1
|
||||
- @chmod a+rx,g-w,o-w $(MAN_PREFIX)/man1/tuxpaint.1.gz
|
||||
+ @chmod 644 $(MAN_PREFIX)/man1/tuxpaint.1.gz
|
||||
@# pl/man1 directory...
|
||||
@install -d $(MAN_PREFIX)/pl/man1/
|
||||
@# tuxpaint-pl.1
|
||||
@cp src/manpage/tuxpaint-pl.1 $(MAN_PREFIX)/pl/man1/tuxpaint.1
|
||||
@gzip -f $(MAN_PREFIX)/pl/man1/tuxpaint.1
|
||||
- @chmod a+rx,g-w,o-w $(MAN_PREFIX)/pl/man1/tuxpaint.1.gz
|
||||
+ @chmod 644 $(MAN_PREFIX)/pl/man1/tuxpaint.1.gz
|
||||
@# tuxpaint-import.1
|
||||
@cp src/manpage/tuxpaint-import.1 $(MAN_PREFIX)/man1/
|
||||
@gzip -f $(MAN_PREFIX)/man1/tuxpaint-import.1
|
||||
- @chmod a+rx,g-w,o-w $(MAN_PREFIX)/man1/tuxpaint-import.1.gz
|
||||
+ @chmod 644 $(MAN_PREFIX)/man1/tuxpaint-import.1.gz
|
||||
@# tp-magic-config.1
|
||||
@cp src/manpage/tp-magic-config.1 $(MAN_PREFIX)/man1/
|
||||
@gzip -f $(MAN_PREFIX)/man1/tp-magic-config.1
|
||||
- @chmod a+rx,g-w,o-w $(MAN_PREFIX)/man1/tp-magic-config.1.gz
|
||||
+ @chmod 644 $(MAN_PREFIX)/man1/tp-magic-config.1.gz
|
||||
|
||||
|
||||
|
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|' on
|
||||
# the right side marks the last column you can put a character in. You must make
|
||||
# exactly 11 lines for the formatting to be correct. It's also customary to
|
||||
# leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
tuxpaint: tuxpaint (A drawing program for young children)
|
||||
tuxpaint:
|
||||
tuxpaint: "Tux Paint" is a drawing program for young children.
|
||||
tuxpaint: It provides a simple interface and fixed canvas size,
|
||||
tuxpaint: and provides access to previous images using a thumbnail
|
||||
tuxpaint: browser (e.g., no access to the underlying file-system).
|
||||
tuxpaint:
|
||||
tuxpaint:
|
||||
tuxpaint:
|
||||
tuxpaint:
|
||||
tuxpaint:
|
|
@ -0,0 +1,69 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for tuxpaint
|
||||
|
||||
# Written by Pablo Santamaria (pablosantamaria@gmail.com)
|
||||
|
||||
|
||||
PRGNAM=tuxpaint
|
||||
VERSION=${VERSION:-0.9.21}
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
fi
|
||||
|
||||
set -e # Exit on most errors
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Create a more util Makefile
|
||||
patch -p1 < $CWD/patch.diff
|
||||
|
||||
make PREFIX=/usr LIBDIRSUFFIX=$LIBDIRSUFFIX OPTFLAGS="$SLKCFLAGS"
|
||||
make PREFIX=/usr LIBDIRSUFFIX=$LIBDIRSUFFIX DESTDIR=$PKG install
|
||||
mv $PKG/etc/tuxpaint/tuxpaint.conf $PKG/etc/tuxpaint/tuxpaint.conf.new
|
||||
|
||||
# Puzzle plugin is broken
|
||||
rm -f $PKG/usr/lib64/tuxpaint/plugins/puzzle.so
|
||||
|
||||
( cd $PKG
|
||||
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null || true
|
||||
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null || true
|
||||
)
|
||||
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="tuxpaint"
|
||||
VERSION="0.9.21"
|
||||
HOMEPAGE="http://www.tuxpaint.org"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/tuxpaint/tuxpaint-0.9.21.tar.gz"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM="a88401d1860648098eeed819cff038fa"
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Pablo Santamaria"
|
||||
EMAIL="pablosantamaria@gmail.com"
|
||||
APPROVED="dsomero"
|
Loading…
Reference in New Issue