ham/gridloc: Added (Maidenhead grid locator).

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
JK Wood 2014-07-14 07:43:28 +07:00 committed by Willy Sudiarto Raharjo
parent 1538120989
commit f507c627d6
5 changed files with 165 additions and 0 deletions

View File

@ -0,0 +1,38 @@
--- Makefile 2013-01-12 09:35:12.000000000 -0600
+++ Makefile.fixed 2014-07-12 22:27:44.617601703 -0500
@@ -1,9 +1,10 @@
#Makefile for gridloc
+DESTDIR ?= /usr
SHELL = /bin/sh
PROJECT = gridloc
-BINDIR = /usr/local/bin
-DOCDIR = /usr/local/share/doc/
+BINDIR = /usr/bin/
+DOCDIR = /usr/doc/$(PROJECT)-0.7/
CC = gcc -Wall -O2 -march=native -D_FORTIFY_SOURCE=2
objects = calculate.o gridloc.o shared.o screen.o
@@ -14,14 +15,16 @@
$(objects) : $(PROJECT).h
install : $(PROJECT)
- install -m 755 --strip $(PROJECT) $(BINDIR)
- install -m 644 doc/$(PROJECT).html $(DOCDIR)
- install -m 644 default/.$(PROJECT)rc $(HOME)
+ install -d -v $(DESTDIR)$(BINDIR)
+ install -d -v $(DESTDIR)$(DOCDIR)
+ install -m 755 --strip $(PROJECT) $(DESTDIR)$(BINDIR)
+ install -m 644 doc/$(PROJECT).html $(DESTDIR)$(DOCDIR)
+ install -m 644 default/.$(PROJECT)rc $(DESTDIR)$(DOCDIR)
uninstall :
- rm $(BINDIR)/$(PROJECT)
- rm $(DOCDIR)/$(PROJECT).html
- rm $(HOME)/.$(PROJECT)rc
+ rm $(DESTDIR)$(BINDIR)$(PROJECT)
+ rm $(DESTDIR)$(DOCDIR)/$(PROJECT).html
+ rm $(DESTDIR)$(DOCDIR)/.$(PROJECT)rc
clean :
rm -f *.o *~

8
ham/gridloc/README Normal file
View File

@ -0,0 +1,8 @@
gridloc is a ncurses console application for the calculation of
Maidenhead QRA Locators from location co-ordinates, and vice
versa. gridloc also calculates distance and direction (long-path
or short-path) from a "home" location to another (DX) location.
The package places a /usr/doc/gridloc/.gridlocrc on your system.
If you copy this to the $HOME of your user, it will use this
config file.

View File

@ -0,0 +1,90 @@
#!/bin/sh
# Slackbuild for gridloc
# Written by JK Wood joshuakwood@gmail.com
# Slackbuild is released under the Dog-on-Fire License:
# If use of this script causes your dog to catch on fire,
# you agree to send me five dollars. Or a picture
# of the dog on fire.
# Otherwise, you're on your own. I've tested the script
# on my own computer, and it hasn't broken anything.
# So if it does it on your computer, that falls in
# the realm of "Not my problem."
#
# Of course, if you'll send a bug report to the above
# email address, I may be able to see what you did
# wrong and prevent it from happening in the future.
# In which case, I may just send YOU five dollars.
# Oh, and feel free to copy it and modify it as you
# see fit. Or as I see fit. Or as I fit. Although
# that is unlikely, as I am rather tall.
PRGNAM=gridloc
VERSION=${VERSION:-0.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar -xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
# Fix up Makefile to behave
patch -p0 < $CWD/Makefile.patch
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING README doc/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
find $PKG/usr/doc -name "Makefile" -exec rm {} \;
find $PKG/usr/doc -type f -exec chmod 644 {} \;
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

10
ham/gridloc/gridloc.info Normal file
View File

@ -0,0 +1,10 @@
PRGNAM="gridloc"
VERSION="0.7"
HOMEPAGE="http://www.qsl.net/5b4az/"
DOWNLOAD="http://www.qsl.net/5b4az/pkg/locator/gridloc/gridloc-0.7.tar.bz2"
MD5SUM="9e1437ea29f5b9380501fd5258c8bdf5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="JK Wood"
EMAIL="joshuakwood@gmail.com"

19
ham/gridloc/slack-desc Normal file
View File

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
gridloc: gridloc (Maidenhead grid locator)
gridloc:
gridloc: gridloc: A ncurses application for calculating the Maidenhead
gridloc: Grid Locator given a position's Longitude and Latitude, or
gridloc: vice-versa. Also to calculate the long-path, short-path Distance
gridloc: and Bearing to a second location, given it Grid Locator or
gridloc: Longitude and Latitude.
gridloc:
gridloc:
gridloc: Homepage: http://www.qsl.net/5b4az/
gridloc: