system/slim: Updated for version 1.3.2.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
d8731e9a03
commit
f34c439e22
|
@ -1,7 +1,7 @@
|
|||
README.SLACKWARE for Slim
|
||||
README.SLACKWARE for SLiM
|
||||
|
||||
Frank Caraballo (the Slim maintainer for SlackBuilds.org) took the time to
|
||||
create a custom Slackware theme which goes nicely with the lilo boot theme.
|
||||
Frank Caraballo took the time to create a custom Slackware theme which goes
|
||||
nicely with the lilo boot theme.
|
||||
If you would like to use that theme, you will need to edit /etc/slim.conf
|
||||
and change the 'current_theme' directive from 'default' to 'slackware-black'
|
||||
|
||||
|
|
|
@ -5,7 +5,7 @@
|
|||
# exactly 11 lines for the formatting to be correct. It's also customary to
|
||||
# leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
slim: SLiM (graphical login manager similar to xdm/kdm/gdm)
|
||||
slim:
|
||||
slim: SLiM is a lightweight login manager based on GNUstep's Login.app. It
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
diff -Nur slim-1.3.1.orig/switchuser.cpp slim-1.3.1/switchuser.cpp
|
||||
--- slim-1.3.1.orig/switchuser.cpp 2008-09-25 19:54:15.000000000 -0500
|
||||
+++ slim-1.3.1/switchuser.cpp 2009-11-09 12:05:40.694438191 -0600
|
||||
@@ -9,6 +9,7 @@
|
||||
(at your option) any later version.
|
||||
*/
|
||||
|
||||
+#include <stdio.h>
|
||||
#include "switchuser.h"
|
||||
|
||||
using namespace std;
|
|
@ -1,6 +1,6 @@
|
|||
diff --git a/Makefile b/Makefile
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
diff -Nur slim-1.3.2.orig//Makefile slim-1.3.2/Makefile
|
||||
--- slim-1.3.2.orig//Makefile 2010-07-08 00:04:10.000000000 -0500
|
||||
+++ slim-1.3.2/Makefile 2010-08-16 15:41:08.470912088 -0500
|
||||
@@ -5,9 +5,9 @@
|
||||
#######################################################
|
||||
CXX=/usr/bin/g++
|
||||
|
@ -8,8 +8,8 @@ diff --git a/Makefile b/Makefile
|
|||
-CFLAGS=-Wall -I. -I/usr/include/freetype2 -I/usr/include/freetype2/config -I/usr/include/libpng12 -I/usr/include
|
||||
+CFLAGS=-Wall -I. -I/usr/include/freetype2 -I/usr/include/freetype2/config -I/usr/include/libpng14 -I/usr/include
|
||||
CXXFLAGS=$(CFLAGS)
|
||||
-LDFLAGS=-lXft -lX11 -lfreetype -lXrender -lfontconfig -lpng12 -lz -lm -lcrypt -lXmu -lpng -ljpeg
|
||||
+LDFLAGS=-lXft -lX11 -lfreetype -lXrender -lfontconfig -lpng14 -lz -lm -lcrypt -lXmu -ljpeg
|
||||
-LDFLAGS=-lXft -lX11 -lfreetype -lXrender -lfontconfig -lpng12 -lz -lm -lcrypt -lXmu -lpng -ljpeg -lrt
|
||||
+LDFLAGS=-lXft -lX11 -lfreetype -lXrender -lfontconfig -lpng14 -lz -lm -lcrypt -lXmu -ljpeg -lrt
|
||||
CUSTOM=-DHAVE_SHADOW
|
||||
ifdef USE_PAM
|
||||
LDFLAGS+= -lpam
|
|
@ -22,19 +22,20 @@
|
|||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
# Script maintained by Frank Caraballo <fecaraballo{at}gmail{dot}com>
|
||||
# Maintained until v1.3.1 by Frank Caraballo <fecaraballo{at}gmail{dot}com>
|
||||
|
||||
# As of v1.3.2 maintained by Niels Horn <niels.horn@gmail.com>
|
||||
# revision date: 2010/09/15
|
||||
|
||||
PRGNAM=slim
|
||||
VERSION=${VERSION:-1.3.1}
|
||||
BUILD=${BUILD:-3}
|
||||
VERSION=${VERSION:-1.3.2}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
# Unless $ARCH is already set, use uname -m for all other archs:
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
@ -65,21 +66,6 @@ fi
|
|||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
|
@ -96,11 +82,8 @@ find . \
|
|||
# Correct the path used for suspend:
|
||||
patch -p0 < $CWD/slim.conf.patch
|
||||
|
||||
# Include stdio.h
|
||||
patch -p1 < $CWD/slim-1.3.1-include_stdio_h.patch
|
||||
|
||||
# Use libpng14
|
||||
patch -p1 < $CWD/slim-1.3.1-use_libpng14.patch
|
||||
patch -p1 < $CWD/slim-1.3.2-use_libpng14.patch
|
||||
|
||||
make \
|
||||
CFLAGS+="$SLKCFLAGS" \
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="slim"
|
||||
VERSION="1.3.1"
|
||||
VERSION="1.3.2"
|
||||
HOMEPAGE="http://slim.berlios.de/"
|
||||
DOWNLOAD="http://download.berlios.de/slim/slim-1.3.1.tar.gz"
|
||||
MD5SUM="727d0acb24c0fbf0751134c37a9c895f"
|
||||
DOWNLOAD="http://download.berlios.de/slim/slim-1.3.2.tar.gz"
|
||||
MD5SUM="ca1ae6120e6f4b4969f2d6cf94f47b42"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Frank Caraballo"
|
||||
EMAIL="fecaraballo{at}gmail{dot}com"
|
||||
MAINTAINER="Niels Horn"
|
||||
EMAIL="niels.horn@gmail.com"
|
||||
APPROVED="rworkman"
|
||||
|
|
Loading…
Reference in New Issue