libraries/argon2: Updated for version 20190702.

Signed-off-by: Mario Preksavec <mario@slackware.hr>
This commit is contained in:
Mario Preksavec 2020-02-14 01:20:52 +01:00 committed by Willy Sudiarto Raharjo
parent 071331660f
commit efde3be502
No known key found for this signature in database
GPG Key ID: 887B8374D7333381
4 changed files with 13 additions and 46 deletions

View File

@ -2,7 +2,7 @@
# Slackware build script for argon2
# Copyright 2017 Mario Preksavec, Zagreb, Croatia
# Copyright 2017, 2020 Mario Preksavec, Zagreb, Croatia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -23,9 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=argon2
VERSION=${VERSION:-20170329_1eea010}
SRCNAM=phc-winner-argon2
COMMIT=${COMMIT:-1eea0104e7cb2a38c617cf90ffa46ce5db6aceda}
VERSION=${VERSION:-20190702}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -57,9 +56,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-COMMIT
tar xvf $CWD/$SRCNAM-$COMMIT.tar.gz
cd $SRCNAM-$COMMIT
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@ -67,10 +66,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
sed -e "s|@@LIBDIRSUFFIX@@|$LIBDIRSUFFIX|" \
-e "s|@@VERSION@@|$VERSION|" $CWD/patches/pkgconfig.diff | patch -p1
sed -e "s|@@LIBDIRSUFFIX@@|$LIBDIRSUFFIX|" $CWD/patches/Makefile.diff | patch -p1
# Fix build options and library path:
sed -i "s/CFLAGS += -std=c89 -O3 -Wall -g -Iinclude -Isrc/CFLAGS += -std=c89 -Iinclude -Isrc/g" Makefile
sed -i "s/LIBRARY_REL ?= lib.*/LIBRARY_REL = lib${LIBDIRSUFFIX}/g" Makefile
sed -i "s/CFLAGS += -march=\$(OPTTARGET)/CFLAGS += ${SLKCFLAGS}/g" Makefile
make libs DESTDIR=$PKG
make install DESTDIR=$PKG
@ -85,7 +84,7 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README.md argon2-specs.pdf $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGELOG.md LICENSE README.md argon2-specs.pdf $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install

View File

@ -1,8 +1,8 @@
PRGNAM="argon2"
VERSION="20170329_1eea010"
VERSION="20190702"
HOMEPAGE="https://github.com/P-H-C/phc-winner-argon2/"
DOWNLOAD="https://github.com/P-H-C/phc-winner-argon2/archive/1eea010/phc-winner-argon2-1eea0104e7cb2a38c617cf90ffa46ce5db6aceda.tar.gz"
MD5SUM="c65e2070180a65c34db7190a6a932f3c"
DOWNLOAD="https://github.com/P-H-C/phc-winner-argon2/archive/20190702.tar.gz"
MD5SUM="0f234cc21ac6cebfe373da6afa70bb1d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""

View File

@ -1,11 +0,0 @@
--- argon2-20170329_1eea010/Makefile.orig 2017-03-29 00:44:20.000000000 +0200
+++ argon2-20170329_1eea010/Makefile 2017-08-01 14:01:49.766250175 +0200
@@ -114,7 +114,7 @@
DESTDIR =
PREFIX = /usr
INCLUDE_REL = include
-LIBRARY_REL = lib
+LIBRARY_REL = lib@@LIBDIRSUFFIX@@
BINARY_REL = bin
INST_INCLUDE = $(DESTDIR)$(PREFIX)/$(INCLUDE_REL)

View File

@ -1,21 +0,0 @@
--- argon2-20170329_1eea010/libargon2.pc.orig 2017-03-29 00:44:20.000000000 +0200
+++ argon2-20170329_1eea010/libargon2.pc 2017-08-01 13:47:25.874580099 +0200
@@ -1,16 +1,11 @@
-# libargon2 info for pkg-config
-## Template for downstream installers:
-## - replace @HOST_MULTIARCH@ with target arch, eg 'x86_64-linux-gnu'
-## - replace @UPSTREAM_VER@ with current version, eg '20160406'
-
prefix=/usr
exec_prefix=${prefix}
-libdir=${prefix}/lib/@HOST_MULTIARCH@
+libdir=${prefix}/lib@@LIBDIRSUFFIX@@
includedir=${prefix}/include
Name: libargon2
Description: Development libraries for libargon2
-Version: @UPSTREAM_VER@
+Version: @@VERSION@@
Libs: -L${libdir} -largon2 -lrt -ldl
Cflags:
URL: https://github.com/P-H-C/phc-winner-argon2