graphics/k3d: Patch for gcc >= 7.x.
Move graphviz between the mandatory dependencies or docs aren't built correctly (and compilation breaks) Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
parent
310cfb2724
commit
ed8fc297a5
|
@ -7,7 +7,6 @@ patches, curves and animation.
|
|||
|
||||
Optional dependencies:
|
||||
|
||||
graphviz
|
||||
gtksourceview
|
||||
libgnome
|
||||
OpenCASCADE
|
||||
|
|
|
@ -0,0 +1,23 @@
|
|||
From d9786540a205bec0b381f339497d7c2cce00376b Mon Sep 17 00:00:00 2001
|
||||
From: Jonathan Wakely <jwakely@redhat.com>
|
||||
Date: Wed, 1 Feb 2017 02:07:28 +0000
|
||||
Subject: [PATCH] Add required header for ostream operations
|
||||
|
||||
This file uses std::ostream::operator<<(double) without including
|
||||
<ostream> and so fails to compile using GCC 7.
|
||||
---
|
||||
k3dsdk/measurement.h | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/k3dsdk/measurement.h b/k3dsdk/measurement.h
|
||||
index 9edf7aef..67df5aa0 100644
|
||||
--- a/k3dsdk/measurement.h
|
||||
+++ b/k3dsdk/measurement.h
|
||||
@@ -27,6 +27,7 @@
|
||||
|
||||
#include <cassert>
|
||||
#include <iosfwd>
|
||||
+#include <ostream>
|
||||
#include <map>
|
||||
#include <string>
|
||||
#include <typeinfo>
|
|
@ -73,6 +73,9 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# From upstream
|
||||
patch -p1 < $CWD/gcc7.patch
|
||||
|
||||
# Fix man install directory.
|
||||
sed -i "s|share/man|man|" share/man/CMakeLists.txt
|
||||
|
||||
|
|
|
@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/K-3D/k3d/archive/k3d-0.8.0.6/k3d-k3d-0.8.0.6.tar.gz
|
|||
MD5SUM="129e051a1e724c14139808c25cd170f0"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="gtkglext ftgl"
|
||||
REQUIRES="graphviz gtkglext ftgl"
|
||||
MAINTAINER="David Spencer"
|
||||
EMAIL="baildon.research@googlemail.com"
|
||||
|
|
Loading…
Reference in New Issue