system/incron: Upgraded to 0.5.10.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
90f6d06305
commit
ecafd17f33
|
@ -1,57 +0,0 @@
|
|||
diff -uNr incron-0.5.9/appargs.cpp incron-0.5.9_patched/appargs.cpp
|
||||
--- incron-0.5.9/appargs.cpp 2009-06-21 23:27:24.000000000 +0300
|
||||
+++ incron-0.5.9_patched/appargs.cpp 2011-04-06 15:35:32.565888675 +0300
|
||||
@@ -22,6 +22,8 @@
|
||||
|
||||
#include <cstring>
|
||||
|
||||
+#include <stdio.h>
|
||||
+
|
||||
#include "strtok.h"
|
||||
|
||||
#include "appargs.h"
|
||||
diff -uNr incron-0.5.9/icd-main.cpp incron-0.5.9_patched/icd-main.cpp
|
||||
--- incron-0.5.9/icd-main.cpp 2009-06-21 23:27:24.000000000 +0300
|
||||
+++ incron-0.5.9_patched/icd-main.cpp 2011-04-06 15:32:20.007891134 +0300
|
||||
@@ -23,6 +23,7 @@
|
||||
#include <errno.h>
|
||||
#include <sys/poll.h>
|
||||
#include <sys/stat.h>
|
||||
+#include <stdio.h>
|
||||
#include <cstring>
|
||||
|
||||
#include "inotify-cxx.h"
|
||||
diff -uNr incron-0.5.9/incroncfg.cpp incron-0.5.9_patched/incroncfg.cpp
|
||||
--- incron-0.5.9/incroncfg.cpp 2009-06-21 23:27:24.000000000 +0300
|
||||
+++ incron-0.5.9_patched/incroncfg.cpp 2011-04-06 15:35:04.422890150 +0300
|
||||
@@ -181,7 +181,7 @@
|
||||
|
||||
bool IncronCfg::IsComment(const char* s)
|
||||
{
|
||||
- char* sx = strchr(s, '#');
|
||||
+ const char* sx = strchr(s, '#');
|
||||
if (sx == NULL)
|
||||
return false;
|
||||
|
||||
diff -uNr incron-0.5.9/inotify-cxx.cpp incron-0.5.9_patched/inotify-cxx.cpp
|
||||
--- incron-0.5.9/inotify-cxx.cpp 2009-06-21 23:27:24.000000000 +0300
|
||||
+++ incron-0.5.9_patched/inotify-cxx.cpp 2011-04-06 15:32:39.878890586 +0300
|
||||
@@ -22,6 +22,7 @@
|
||||
|
||||
#include <errno.h>
|
||||
#include <unistd.h>
|
||||
+#include <stdio.h>
|
||||
#include <fcntl.h>
|
||||
|
||||
#include "inotify-cxx.h"
|
||||
diff -uNr incron-0.5.9/usertable.cpp incron-0.5.9_patched/usertable.cpp
|
||||
--- incron-0.5.9/usertable.cpp 2009-06-21 23:27:24.000000000 +0300
|
||||
+++ incron-0.5.9_patched/usertable.cpp 2011-04-06 15:33:09.499888673 +0300
|
||||
@@ -25,6 +25,7 @@
|
||||
#include <unistd.h>
|
||||
#include <grp.h>
|
||||
#include <stdlib.h>
|
||||
+#include <stdio.h>
|
||||
#include <sys/stat.h>
|
||||
#include <cstring>
|
||||
|
|
@ -1,60 +0,0 @@
|
|||
diff -uNr incron-0.5.9/Makefile incron-0.5.9_patched/Makefile
|
||||
--- incron-0.5.9/Makefile 2009-06-21 23:27:24.000000000 +0300
|
||||
+++ incron-0.5.9_patched/Makefile 2011-04-06 18:09:10.661890554 +0300
|
||||
@@ -44,33 +44,35 @@
|
||||
distclean: clean
|
||||
|
||||
install: all install-man
|
||||
- [ -d $(PREFIX) ]
|
||||
- $(INSTALL) -m 04755 -o $(USER) incrontab $(PREFIX)/bin/
|
||||
- $(INSTALL) -m 0755 incrond $(PREFIX)/sbin/
|
||||
- $(INSTALL) -m 0755 -o $(USER) -d $(USERDATADIR)
|
||||
- $(INSTALL) -m 0755 -o $(USER) -d $(SYSDATADIR)
|
||||
- $(INSTALL) -m 0644 -o $(USER) incron.conf.example $(CFGDIR)
|
||||
+ [ -d $(DESTDIR)$(PREFIX) ]
|
||||
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(PREFIX)/bin
|
||||
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(PREFIX)/sbin
|
||||
+ $(INSTALL) -m 04755 -o $(USER) incrontab $(DESTDIR)$(PREFIX)/bin/
|
||||
+ $(INSTALL) -m 0755 incrond $(DESTDIR)$(PREFIX)/sbin/
|
||||
+ $(INSTALL) -m 0755 -o $(USER) -d $(DESTDIR)$(USERDATADIR)
|
||||
+ $(INSTALL) -m 0755 -o $(USER) -d $(DESTDIR)$(SYSDATADIR)
|
||||
+ $(INSTALL) -m 0644 -o $(USER) incron.conf.example $(DESTDIR)$(CFGDIR)
|
||||
|
||||
install-man: incrontab.1 incrontab.5 incrond.8 incron.conf.5
|
||||
- $(INSTALL) -m 0755 -d $(MANPATH)/man1
|
||||
- $(INSTALL) -m 0755 -d $(MANPATH)/man5
|
||||
- $(INSTALL) -m 0755 -d $(MANPATH)/man8
|
||||
- $(INSTALL) -m 0644 incrontab.1 $(MANPATH)/man1
|
||||
- $(INSTALL) -m 0644 incrontab.5 $(MANPATH)/man5
|
||||
- $(INSTALL) -m 0644 incrond.8 $(MANPATH)/man8
|
||||
- $(INSTALL) -m 0644 incron.conf.5 $(MANPATH)/man5
|
||||
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(MANPATH)/man1
|
||||
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(MANPATH)/man5
|
||||
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(MANPATH)/man8
|
||||
+ $(INSTALL) -m 0644 incrontab.1 $(DESTDIR)$(MANPATH)/man1
|
||||
+ $(INSTALL) -m 0644 incrontab.5 $(DESTDIR)$(MANPATH)/man5
|
||||
+ $(INSTALL) -m 0644 incrond.8 $(DESTDIR)$(MANPATH)/man8
|
||||
+ $(INSTALL) -m 0644 incron.conf.5 $(DESTDIR)$(MANPATH)/man5
|
||||
|
||||
uninstall: uninstall-man
|
||||
- [ -d $(PREFIX) ]
|
||||
- rm -f $(PREFIX)/bin/incrontab
|
||||
- rm -f $(PREFIX)/sbin/incrond
|
||||
- rm -f $(CFGDIR)/incron.conf.example
|
||||
+ [ -d $(DESTDIR)$(PREFIX) ]
|
||||
+ rm -f $(DESTDIR)$(PREFIX)/bin/incrontab
|
||||
+ rm -f $(DESTDIR)$(PREFIX)/sbin/incrond
|
||||
+ rm -f $(DESTDIR)$(CFGDIR)/incron.conf.example
|
||||
|
||||
uninstall-man:
|
||||
- rm -f $(MANPATH)/man1/incrontab.1
|
||||
- rm -f $(MANPATH)/man5/incrontab.5
|
||||
- rm -f $(MANPATH)/man8/incrond.8
|
||||
- rm -f $(MANPATH)/man5/incron.conf.5
|
||||
+ rm -f $(DESTDIR)$(MANPATH)/man1/incrontab.1
|
||||
+ rm -f $(DESTDIR)$(MANPATH)/man5/incrontab.5
|
||||
+ rm -f $(DESTDIR)$(MANPATH)/man8/incrond.8
|
||||
+ rm -f $(DESTDIR)$(MANPATH)/man5/incron.conf.5
|
||||
|
||||
update: uninstall install
|
||||
|
|
@ -3,9 +3,10 @@
|
|||
# Slackware build script for incrond
|
||||
|
||||
# Written by Asaf Ohaion asaf@lingnu.com
|
||||
# Modified by Willy Sudiarto Raharjo <willysr@slackware-id.org>
|
||||
|
||||
PRGNAM=incron
|
||||
VERSION=${VERSION:-0.5.9}
|
||||
VERSION=${VERSION:-0.5.10}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -51,8 +52,9 @@ find . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
patch -p1 < $CWD/fix-compiliation.diff
|
||||
patch -p1 < $CWD/fix-make-install.diff
|
||||
sed -i '1,1i#include <unistd.h>' inotify-cxx.cpp icd-main.cpp
|
||||
sed -i '1,1i#include <stdio.h>' icd-main.cpp inotify-cxx.cpp usertable.cpp appargs.cpp
|
||||
sed -i 's|strchr(s,|(char*)strchr(s,|' incroncfg.cpp
|
||||
|
||||
make PREFIX=/usr
|
||||
make install DESTDIR=$PKG PREFIX=/usr MANPATH=/usr/man
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="incron"
|
||||
VERSION="0.5.9"
|
||||
VERSION="0.5.10"
|
||||
HOMEPAGE="http://inotify.aiken.cz"
|
||||
DOWNLOAD="http://inotify.aiken.cz/download/incron/incron-0.5.9.tar.bz2"
|
||||
MD5SUM="ccae2ca5cb4b142be002ab482250fb5f"
|
||||
DOWNLOAD_x86_64="http://inotify.aiken.cz/download/incron/incron-0.5.9.tar.bz2"
|
||||
MD5SUM_x86_64="ccae2ca5cb4b142be002ab482250fb5f"
|
||||
DOWNLOAD="http://inotify.aiken.cz/download/incron/incron-0.5.10.tar.bz2"
|
||||
MD5SUM="038190dc64568883a206f3d58269b850"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
MAINTAINER="Asaf Ohaion"
|
||||
EMAIL="asaf@lingnu.com"
|
||||
|
|
Loading…
Reference in New Issue