desktop/notion: Fix lookup PREFIX installation.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
This commit is contained in:
parent
7724888b6c
commit
ea7aa1b578
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for notion
|
||||
|
||||
# Copyright 2014-2015 Dimitris Zlatanidis Orestiada, Greece
|
||||
# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -25,7 +25,7 @@
|
|||
PRGNAM=notion
|
||||
SRCVER=${SRCVER:-3-2015061300}
|
||||
VERSION=$(echo $SRCVER | tr - _)
|
||||
BUILD=${BUILD:-1}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -69,6 +69,13 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Fix notion lookup PREFIX installation
|
||||
if [ "$ARCH" = "x86_64" ]; then
|
||||
patch -p1 < $CWD/system64.patch
|
||||
else
|
||||
patch -p1 < $CWD/system.patch
|
||||
fi
|
||||
|
||||
make
|
||||
make install \
|
||||
OPTS="$SLKCFLAGS" \
|
||||
|
|
|
@ -0,0 +1,32 @@
|
|||
--- notion-3-2015061300/system-autodetect.mk.orig 2016-01-28 07:43:36.217463685 +0200
|
||||
+++ notion-3-2015061300/system-autodetect.mk 2016-01-28 07:47:27.529477603 +0200
|
||||
@@ -12,7 +12,7 @@
|
||||
# Installation path prefix. Unless you know what you're doing, the default
|
||||
# of /usr/local is likely the correct choice.
|
||||
#DIST: PREFIX=/usr/local
|
||||
-PREFIX ?= /usr/local
|
||||
+PREFIX ?= /usr
|
||||
|
||||
# Unless you are creating a package conforming to some OS's standards, you
|
||||
# probably do not want to modify the following directories:
|
||||
@@ -22,9 +22,9 @@
|
||||
# Some .lua files and ion-* shell scripts
|
||||
SHAREDIR=$(PREFIX)/share/notion
|
||||
# Manual pages
|
||||
-MANDIR=$(PREFIX)/share/man
|
||||
+MANDIR=$(PREFIX)/man
|
||||
# Some documents
|
||||
-DOCDIR=$(PREFIX)/share/doc/notion
|
||||
+DOCDIR=$(PREFIX)/doc/notion
|
||||
# Nothing at the moment
|
||||
LIBDIR=$(PREFIX)/lib
|
||||
# Modules
|
||||
@@ -40,7 +40,7 @@
|
||||
|
||||
# Configuration .lua files. Overrideable, as config files are usually
|
||||
# not placed under $(PREFIX).
|
||||
-ETCDIR ?= $(PREFIX)/etc/notion
|
||||
+ETCDIR ?= /etc/notion
|
||||
|
||||
# Force all include files to be installed to /usr even if the
|
||||
# PREFIX is unset. No header files are installed at the moment
|
|
@ -0,0 +1,35 @@
|
|||
--- notion-3-2015061300/system-autodetect.mk.orig 2016-01-28 07:23:03.582723687 +0200
|
||||
+++ notion-3-2015061300/system-autodetect.mk 2016-01-28 07:22:14.593336139 +0200
|
||||
@@ -12,7 +12,7 @@
|
||||
# Installation path prefix. Unless you know what you're doing, the default
|
||||
# of /usr/local is likely the correct choice.
|
||||
#DIST: PREFIX=/usr/local
|
||||
-PREFIX ?= /usr/local
|
||||
+PREFIX ?= /usr
|
||||
|
||||
# Unless you are creating a package conforming to some OS's standards, you
|
||||
# probably do not want to modify the following directories:
|
||||
@@ -22,11 +22,11 @@
|
||||
# Some .lua files and ion-* shell scripts
|
||||
SHAREDIR=$(PREFIX)/share/notion
|
||||
# Manual pages
|
||||
-MANDIR=$(PREFIX)/share/man
|
||||
+MANDIR=$(PREFIX)/man
|
||||
# Some documents
|
||||
-DOCDIR=$(PREFIX)/share/doc/notion
|
||||
+DOCDIR=$(PREFIX)/doc/notion
|
||||
# Nothing at the moment
|
||||
-LIBDIR=$(PREFIX)/lib
|
||||
+LIBDIR=$(PREFIX)/lib64
|
||||
# Modules
|
||||
MODULEDIR=$(LIBDIR)/notion/mod
|
||||
# Compiled Lua source code
|
||||
@@ -40,7 +40,7 @@
|
||||
|
||||
# Configuration .lua files. Overrideable, as config files are usually
|
||||
# not placed under $(PREFIX).
|
||||
-ETCDIR ?= $(PREFIX)/etc/notion
|
||||
+ETCDIR ?= /etc/notion
|
||||
|
||||
# Force all include files to be installed to /usr even if the
|
||||
# PREFIX is unset. No header files are installed at the moment
|
Loading…
Reference in New Issue