network/rdma-core: Updated for version 51.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
40bfc3b431
commit
e9b5741326
|
@ -1,7 +1,7 @@
|
|||
diff -ru rdma-core-48.0.orig/CMakeLists.txt rdma-core-48.0/CMakeLists.txt
|
||||
--- rdma-core-48.0.orig/CMakeLists.txt 2023-09-18 13:24:24.000000000 +0800
|
||||
+++ rdma-core-48.0/CMakeLists.txt 2023-09-18 14:59:56.134525340 +0800
|
||||
@@ -708,27 +708,41 @@
|
||||
diff -ru rdma-core-51.0.orig/CMakeLists.txt rdma-core-51.0/CMakeLists.txt
|
||||
--- rdma-core-51.0.orig/CMakeLists.txt 2024-04-01 05:29:36.000000000 +0000
|
||||
+++ rdma-core-51.0/CMakeLists.txt 2024-04-12 09:23:05.833329702 +0000
|
||||
@@ -723,28 +723,44 @@
|
||||
add_subdirectory(kernel-headers)
|
||||
# Libraries
|
||||
add_subdirectory(libibumad)
|
||||
|
@ -27,6 +27,9 @@ diff -ru rdma-core-48.0.orig/CMakeLists.txt rdma-core-48.0/CMakeLists.txt
|
|||
+endif()
|
||||
add_subdirectory(providers/erdma)
|
||||
add_subdirectory(providers/hns)
|
||||
+if (PANDOC_FOUND)
|
||||
add_subdirectory(providers/hns/man)
|
||||
+endif()
|
||||
add_subdirectory(providers/irdma)
|
||||
add_subdirectory(providers/mana)
|
||||
+if (PANDOC_FOUND)
|
||||
|
@ -43,7 +46,7 @@ diff -ru rdma-core-48.0.orig/CMakeLists.txt rdma-core-48.0/CMakeLists.txt
|
|||
add_subdirectory(providers/mthca)
|
||||
add_subdirectory(providers/ocrdma)
|
||||
add_subdirectory(providers/qedr)
|
||||
@@ -738,15 +752,21 @@
|
||||
@@ -754,15 +770,21 @@
|
||||
add_subdirectory(providers/hfi1verbs)
|
||||
add_subdirectory(providers/ipathverbs)
|
||||
add_subdirectory(providers/rxe)
|
||||
|
|
|
@ -25,8 +25,8 @@
|
|||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=rdma-core
|
||||
VERSION=${VERSION:-48.0}
|
||||
BUILD=${BUILD:-2}
|
||||
VERSION=${VERSION:-51.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="rdma-core"
|
||||
VERSION="48.0"
|
||||
VERSION="51.0"
|
||||
HOMEPAGE="https://github.com/linux-rdma"
|
||||
DOWNLOAD="https://github.com/linux-rdma/rdma-core/releases/download/v48.0/rdma-core-48.0.tar.gz"
|
||||
MD5SUM="f8901665b2fbf03b4ffb6bf7f6207ac4"
|
||||
DOWNLOAD="https://github.com/linux-rdma/rdma-core/releases/download/v51.0/rdma-core-51.0.tar.gz"
|
||||
MD5SUM="ed95d79f782ea00bd7233d453abd60b3"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
Loading…
Reference in New Issue