audio/swh-plugins-lv2: Added (GPL audio plugins for LV2)

Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
B. Watson 2011-07-13 04:31:11 -04:00 committed by Niels Horn
parent 3f27426cd2
commit e7f6177976
6 changed files with 139 additions and 0 deletions

View File

@ -0,0 +1,8 @@
swh-plugins-lv2 (GPL free software audio plugins for LV2)
This requires lv2core and slv2.
For LADSPA versions of these plugins, see swh-plugins.
These plugins work in lv2_jack_host and ardour, but do NOT work in lv2rack
(attempting to load them will cause lv2rack to segfault).

View File

@ -0,0 +1,12 @@
diff -Naur swh-lv2-1.0.15/Makefile swh-lv2-1.0.15.patched/Makefile
--- swh-lv2-1.0.15/Makefile 2008-01-09 16:02:08.000000000 -0500
+++ swh-lv2-1.0.15.patched/Makefile 2010-01-02 19:30:31.000000000 -0500
@@ -72,7 +72,7 @@
%.so: NAME = $(shell echo -n $@ | sed 's/plugins\/\(.*\)-swh.*/\1/')
%.so: %.xml %.o %.ttl
- $(CC) $*.o $(PLUGIN_LDFLAGS) $($(NAME)_LDFLAGS) -o $@
+ $(CC) $*.o $(PLUGIN_LDFLAGS) $($(NAME)_LDFLAGS) -o $@ -lm
cp $@ $*-$(OS).$(EXT)
sed 's/@OS@/$(OS)/g' < `dirname $@`/manifest.ttl.in > `dirname $@`/manifest.ttl

View File

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
swh-plugins-lv2: swh-plugins-lv2 (GPL free software audio plugins for LV2)
swh-plugins-lv2:
swh-plugins-lv2: Requires lv2core and slv2, available at SlackBuilds.org
swh-plugins-lv2:
swh-plugins-lv2: For LADSPA versions of these plugins, see swh-plugins.
swh-plugins-lv2:
swh-plugins-lv2:
swh-plugins-lv2:
swh-plugins-lv2:
swh-plugins-lv2:
swh-plugins-lv2:

View File

@ -0,0 +1,12 @@
diff -Naur swh-lv2-1.0.15/Makefile swh-lv2-1.0.15.patched/Makefile
--- swh-lv2-1.0.15/Makefile 2008-01-09 16:02:08.000000000 -0500
+++ swh-lv2-1.0.15.patched/Makefile 2010-06-24 18:28:09.000000000 -0400
@@ -44,7 +44,7 @@
BUILD_PLUGINS = $(PLUGINS)
else
EXT = so
-PLUGIN_CFLAGS = -Wall -I. -Iinclude -O3 -fomit-frame-pointer -fstrength-reduce -funroll-loops -fPIC -DPIC $(CFLAGS)
+PLUGIN_CFLAGS = -Wall -I. -Iinclude -fPIC -DPIC $(SLKCFLAGS)
PLUGIN_LDFLAGS = -shared $(LDFLAGS)
BUILD_PLUGINS = $(PLUGINS) $(FFT_PLUGINS)
endif

View File

@ -0,0 +1,78 @@
#!/bin/sh
# Slackware build script for swh-plugins-lv2
# Written by B. Watson (yalhcru@gmail.com)
PRGNAM=swh-plugins-lv2
VERSION=${VERSION:-1.0.15}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
TARNAME="swh-lv2"
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $TARNAME-$VERSION
tar xvf $CWD/$TARNAME-$VERSION.tar.gz
cd $TARNAME-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
if [ "${FORCE_SLACK_CFLAGS:-no}" = "yes" ]; then
patch -p1 < $CWD/slkcflags.diff
fi
# Add -lm when linking the .so files. Without this, the plugins fail to
# load in ardour.
patch -p1 < $CWD/libm.diff
make PREFIX=/usr SLKCFLAGS="$SLKCFLAGS"
make install-system INSTALL_DIR=$PKG/usr/lib$LIBDIRSUFFIX/lv2
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View File

@ -0,0 +1,10 @@
PRGNAM="swh-plugins-lv2"
VERSION="1.0.15"
HOMEPAGE="http://plugin.org.uk/"
DOWNLOAD="http://distfiles.gentoo.org/distfiles/swh-lv2-1.0.15.tar.gz"
DOWNLOAD_x86_64=""
MD5SUM="c78f42c36d7bf2fb5b17f795ef9636d1"
MD5SUM_x86_64=""
MAINTAINER="B. Watson"
EMAIL="yalhcru@gmail.com"
APPROVED="dsomero"