desktop/murrine: Fix build with slibtool.

Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
This commit is contained in:
Hunter Sezen 2018-05-17 23:06:18 +01:00 committed by David Spencer
parent 11cf17584d
commit e58fd7a361
2 changed files with 17 additions and 1 deletions

View File

@ -0,0 +1,11 @@
=== modified file 'Makefile.am'
--- Makefile.am 2012-01-25 14:09:03 +0000
+++ Makefile.am 2012-01-25 16:05:43 +0000
@@ -36,5 +36,5 @@
./src/stack-blur.h
libmurrine_la_LDFLAGS = -module -avoid-version -no-undefined
-libmurrine_la_LIBADD = $(GTK_LIBS) $(pixman_LIBS)
+libmurrine_la_LIBADD = $(GTK_LIBS) $(pixman_LIBS) -lm

View File

@ -25,7 +25,7 @@
PRGNAM=murrine
VERSION=${VERSION:-0.98.2}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -70,6 +70,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix build with slibtool
# https://bazaar.launchpad.net/~murrine-daily/murrine/trunk/revision/380/Makefile.am
patch -p0 < $CWD/380_379.diff
autoreconf -fi
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \