system/dieharder: improved patch and added option for PDF manual.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
A. Green 2016-05-03 19:33:25 -06:00 committed by Willy Sudiarto Raharjo
parent 4194c4c32e
commit e42a8548bf
3 changed files with 53 additions and 28 deletions

View File

@ -1,11 +1,13 @@
Dieharder is a random number generator (RNG) testing suite, designed to make
it easy to time and test RNGs implemented in both software and hardware. It
makes extensive use of the GNU Scientific Library (GSL), and includes a
battery of pseudorandom number generators (PRNG) and testing algorithms for
research and cryptographic applications.
Dieharder is a random number generator (RNG) testing suite, designed
to make it easy to time and test RNGs implemented in both software and
hardware. It makes extensive use of the GNU Scientific Library (GSL),
and includes a battery of pseudorandom number generators (PRNG) and
testing algorithms for research and cryptographic applications.
The software saw its last release in 2011, and differences with newer versions
of autoconf are starting to become apparent. Patches are applied mostly to
overcome these differences, as well as one trivial fix to appease C99. The
build installs the dieharder software as well as the libdieharder libraries
that can be called from your program code.
The software saw its last release in 2011, and patches are applied
mostly to overcome differences with newer versions of autoconf. This
build installs the dieharder program as well as the libdieharder
shared libraries that can be called from your program code.
If you have latex2html installed and want the PDF manual, execute the
build script like so: PDFMAN=yes ./dieharder.SlackBuild

View File

@ -1,33 +1,34 @@
#!/bin/sh -e
# SlackBuild for dieharder, 9 March 2016
# SlackBuild for dieharder, 3 May 2016
# Arthur W. Green <lynx@panix.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
# Redistribution and use of this script, with or without modification,
# is permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR
# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
# ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
# DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE
# GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# dieharder itself remains a copyrighted work under the terms of the
# GNU GPL v2 (with beverage provision). Please see the file COPYING
# in the dieharder source distribution for more on this.
## dieharder itself remains a copyrighted work under the terms of the
## GNU GPL v2 (with beverage provision). Please see the file COPYING
## in the dieharder source distribution for more on this.
PRGNAM=dieharder
VERSION=${VERSION:-3.31.1}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -70,6 +71,7 @@ find -L . -exec chmod -R u+w,go-w,a+rX-st {} \;
# apply patches, mostly to appease crusty autoconf.
patch -p1 < $CWD/$PRGNAM.patch
mkdir -p manual/m4 # a useless stub.
./autogen.sh
@ -97,6 +99,10 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING NOTES AUTHORS $PKG/usr/doc/$PRGNAM-$VERSION
if [ "${PDFMAN:-no}" = "yes" ]; then
( cd manual; make pdf )
cp -a manual/dieharder.pdf $PKG/usr/doc/$PRGNAM-$VERSION
fi
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install

View File

@ -64,12 +64,29 @@
#========================================================================
--- dieharder-3.31.1/manual/Makefile.am 2011-10-14 07:41:37.000000000 -0600
+++ dieharder-3.31.1/manual/Makefile.am 2016-03-09 17:24:24.291466526 -0700
+++ dieharder-3.31.1/manual/Makefile.am 2016-03-30 11:57:59.567234623 -0600
@@ -6,3 +6,3 @@
SVNPATH = $(SVNTREE)/dieharder
-SVNTIME = $(HOME/Src/Projects/dieharder/dieharder.svn.time)
+SVNTIME = $(HOME)/Src/Projects/dieharder/dieharder.svn.time
@@ -30,4 +30,4 @@
all: $(PDF)
-ps: $(DVI) $(PS)
-pdf: $(DVI) $(PS) $(PDF)
+ps-local: $(DVI) $(PS)
+pdf-local: $(DVI) $(PS) $(PDF)
a4ps: $(DVI) $(A4PS)
@@ -49,6 +49,6 @@
# Clean up all the junk build files and output formats to save space.
-clean:
+clean-local:
rm -f $(DVI) $(AUX) $(LOGS) $(TOC) $(ERR) $(PS) $(PDF)
-install: $(PDF)
+install-data-local: $(PDF)
cp $(PDF) ..
--- dieharder-3.31.1/include/dieharder/libdieharder.h 2011-10-14 07:41:37.000000000 -0600
+++ dieharder-3.31.1/include/dieharder/libdieharder.h 2016-03-09 17:24:24.291466526 -0700
@@ -21,2 +21,3 @@