academic/gwyddion: Updated for version 2.30, added license.

Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
Daniil Bratashov 2012-12-20 16:37:08 +01:00 committed by Matteo Bernardini
parent 7d7f9ecaf3
commit e1937f6d31
4 changed files with 62 additions and 29 deletions

View File

@ -0,0 +1,37 @@
Index: modules/file/pixmap.c
===================================================================
--- modules/file/pixmap.c (revision 13902)
+++ modules/file/pixmap.c (revision 13903)
@@ -2933,8 +2933,6 @@
gwy_rgba_to_gdk_color(&controls->args->inset_color, &gdkcolor);
dialog = gtk_color_selection_dialog_new(_("Change Inset Color"));
- if (gtk_major_version == 2 && gtk_minor_version < 10)
-
selector = GTK_COLOR_SELECTION_DIALOG(dialog)->colorsel;
gtk_color_selection_set_current_color(GTK_COLOR_SELECTION(selector),
&gdkcolor);
Index: libgwydgets/gwygraphareadialog.c
===================================================================
--- libgwydgets/gwygraphareadialog.c (revision 13902)
+++ libgwydgets/gwygraphareadialog.c (revision 13903)
@@ -383,7 +383,6 @@
dialog->color_dialog = selector;
dialog->old_color = cmodel->color;
- if (gtk_major_version == 2 && gtk_minor_version < 10)
colorsel = GTK_COLOR_SELECTION_DIALOG(selector)->colorsel;
g_signal_connect(selector, "response",
G_CALLBACK(colorsel_response_cb), dialog);
Index: libgwydgets/gwydgetutils.c
===================================================================
--- libgwydgets/gwydgetutils.c (revision 13902)
+++ libgwydgets/gwydgetutils.c (revision 13903)
@@ -561,7 +561,6 @@
dialog = gtk_color_selection_dialog_new(dialog_title
? dialog_title
: _("Change Mask Color"));
- if (gtk_major_version == 2 && gtk_minor_version < 10)
selector = GTK_COLOR_SELECTION_DIALOG(dialog)->colorsel;
gtk_color_selection_set_current_color(GTK_COLOR_SELECTION(selector),
&gdkcolor);

View File

@ -1,22 +0,0 @@
--- a/gwyddion-2.26/plugins/process/Makefile.am 2007-10-18 20:06:34.000000000 +0700
+++ b/gwyddion-2.26/plugins/process/Makefile.am 2012-02-11 12:11:13.000000000 +0700
@@ -84,7 +84,7 @@
$(cpp_plugins_sources) \
$(all_rgis)
-PASCAL_FLAGS = -Mdelphi -l- -Sh -WC -O2 -Xc -XX
+PASCAL_FLAGS = -Mdelphi -l- -Sh -O2 -Xc -XX
clean-local:
rm -f core.* *~ *.ppu
--- a/gwyddion-2.26/plugins/process/Makefile.in 2011-12-17 16:58:01.000000000 +0700
+++ b/gwyddion-2.26/plugins/process/Makefile.in 2012-02-11 12:10:59.000000000 +0700
@@ -401,7 +401,7 @@
$(cpp_plugins_sources) \
$(all_rgis)
-PASCAL_FLAGS = -Mdelphi -l- -Sh -WC -O2 -Xc -XX
+PASCAL_FLAGS = -Mdelphi -l- -Sh -O2 -Xc -XX
all: all-am
.SUFFIXES:

View File

@ -2,10 +2,28 @@
# Slackware build script for gwyddion
# Written by Daniil Bratashov <dn2010@gmail.com>
# Copyright 2012 Daniil Bratashov <dn2010@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=gwyddion
VERSION=${VERSION:-2.28}
VERSION=${VERSION:-2.30}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -51,8 +69,8 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Allow us to compile with fpc 2.6.0.
patch -p2 < $CWD/gwyddion-fpc-2.6.0.patch
# Color selector crash in mask color (2.30 only)
patch -p0 < $CWD/gwyddion-2.30-color-button-debris-crash.patch
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \

View File

@ -1,8 +1,8 @@
PRGNAM="gwyddion"
VERSION="2.28"
VERSION="2.30"
HOMEPAGE="http://gwyddion.net"
DOWNLOAD="http://downloads.sourceforge.net/gwyddion/gwyddion-2.28.tar.xz"
MD5SUM="ef568ffbaf21c5090bbfaadca0a8845a"
DOWNLOAD="http://downloads.sourceforge.net/gwyddion/gwyddion-2.30.tar.xz"
MD5SUM="69c4eff68481b998bbcd1aadd2d96112"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="gtkglext"