python/python3-jinja2-time: Added (Jinja2 Extension for Dates+Times)
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
0a6704c679
commit
df3ef47dc2
|
@ -0,0 +1 @@
|
|||
Jinja2 Time is a Jinja2 Extension for Dates and Times.
|
|
@ -0,0 +1,41 @@
|
|||
This patch was taken from Arch Linux:
|
||||
https://github.com/archlinux/svntogit-community/blob/packages/python-jinja-time/trunk/python-jinja-time-0.2.0-arrow_shift.patch
|
||||
|
||||
From aa4af9af0a0a5111a8ad21bc1b43bbdb586ee8af Mon Sep 17 00:00:00 2001
|
||||
From: Vincent Bernat <vincent@bernat.ch>
|
||||
Date: Sun, 3 Nov 2019 07:48:08 +0100
|
||||
Subject: [PATCH] Use shift() instead of replace() to modify dates
|
||||
|
||||
Previously, the `replace()` method from arrow was shifting the date
|
||||
when the arguments were using the plural form. Since Arrow 0.9.0, this
|
||||
has been deprecated in favor of a `shift()` method. Arrow 0.14.5
|
||||
completely removed the ability for `replace()` to shift dates. This
|
||||
leads to errors like `AttributeError: unknown attribute: "hours"` when
|
||||
using plural form.
|
||||
|
||||
This commit replace the use of `replace()` by `shift()` since the
|
||||
intent is always to shift the current date.
|
||||
---
|
||||
jinja2_time/jinja2_time.py | 6 +++---
|
||||
setup.py | 4 ++--
|
||||
2 files changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/jinja2_time/jinja2_time.py b/jinja2_time/jinja2_time.py
|
||||
index ce713cb..717c8a0 100755
|
||||
--- a/jinja2_time/jinja2_time.py
|
||||
+++ b/jinja2_time/jinja2_time.py
|
||||
@@ -19,11 +19,11 @@ def _datetime(self, timezone, operator, offset, datetime_format):
|
||||
d = arrow.now(timezone)
|
||||
|
||||
# Parse replace kwargs from offset and include operator
|
||||
- replace_params = {}
|
||||
+ shift_params = {}
|
||||
for param in offset.split(','):
|
||||
interval, value = param.split('=')
|
||||
- replace_params[interval.strip()] = float(operator + value.strip())
|
||||
- d = d.replace(**replace_params)
|
||||
+ shift_params[interval.strip()] = float(operator + value.strip())
|
||||
+ d = d.shift(**shift_params)
|
||||
|
||||
if datetime_format is None:
|
||||
datetime_format = self.environment.datetime_format
|
|
@ -0,0 +1,97 @@
|
|||
#!/bin/bash
|
||||
|
||||
# Slackware build script for python3-jinja2-time
|
||||
|
||||
# Copyright 2023 Isaac Yu <isaacyu1@isaacyu1.com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=python3-jinja2-time
|
||||
VERSION=${VERSION:-0.2.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
||||
SRCNAM=jinja2-time
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i586 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
||||
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
|
||||
exit 0
|
||||
fi
|
||||
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i586" ]; then
|
||||
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $SRCNAM-$VERSION
|
||||
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
|
||||
cd $SRCNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Fix python3-arrow's shifting of dates: https://github.com/hackebrot/jinja2-time/issues/15
|
||||
patch -p1 < $CWD/jinja-time-0.2.0-arrow_shift.patch
|
||||
|
||||
python3 setup.py install --root=$PKG
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a CONTRIBUTING.rst CONTRIBUTORS.rst HISTORY.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="python3-jinja2-time"
|
||||
VERSION="0.2.0"
|
||||
HOMEPAGE="https://github.com/hackebrot/jinja2-time"
|
||||
DOWNLOAD="https://files.pythonhosted.org/packages/source/j/jinja2-time/jinja2-time-0.2.0.tar.gz"
|
||||
MD5SUM="b6ebc4ecac395a18982532f4c2869c06"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="python3-arrow"
|
||||
MAINTAINER="Isaac Yu"
|
||||
EMAIL="isaacyu1@isaacyu1.com"
|
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
python3-jinja2-time: python3-jinja2-time (Jinja2 Extension for Dates and Times)
|
||||
python3-jinja2-time:
|
||||
python3-jinja2-time: Jinja2 Time is a Jinja2 Extension for Dates and Times.
|
||||
python3-jinja2-time:
|
||||
python3-jinja2-time:
|
||||
python3-jinja2-time:
|
||||
python3-jinja2-time:
|
||||
python3-jinja2-time:
|
||||
python3-jinja2-time:
|
||||
python3-jinja2-time:
|
||||
python3-jinja2-time:
|
Loading…
Reference in New Issue