desktop/icewm: Included a couple of build fix patches

These are only needed for -current, but they don't hurt anything
for 13.37 and they reduce the workload later when getting all of
the repo ready for slackware-next.

Thanks to Morten Langlo for the fontconfig patch.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Robby Workman 2012-05-11 10:40:56 -05:00 committed by Erik Hanson
parent 612fd0840a
commit deaf02228b
4 changed files with 41 additions and 1 deletions

View File

@ -69,8 +69,15 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Explicitly link fontconfig - this isn't needed on 13.37, but it also doesn't
# hurt anything, so we'll included it since it's needed for -current
patch -p1 < $CWD/patches/explicitly-link-fontconfig.diff
# Here's another -current only patch that's harmless on 13.37:
patch -p1 < $CWD/patches/use_ICEWM_deprecated.patch
# Since we put the html files in $docdir/html/, let's fix the integrated help:
patch -p1 < $CWD/icewm-1.3.7-fix_html_docdir.diff
patch -p1 < $CWD/patches/icewm-1.3.7-fix_html_docdir.diff
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \

View File

@ -0,0 +1,12 @@
diff -Nur icewm-1.3.7.orig/src/Makefile.in icewm-1.3.7/src/Makefile.in
--- icewm-1.3.7.orig/src/Makefile.in 2010-10-31 09:09:36.000000000 -0500
+++ icewm-1.3.7/src/Makefile.in 2012-05-11 10:29:55.356344991 -0500
@@ -37,7 +37,7 @@
CXXFLAGS = @CXXFLAGS@ $(DEBUG) $(DEFS) `pkg-config gdk-pixbuf-xlib-2.0 --cflags` \
@CORE_CFLAGS@ @IMAGE_CFLAGS@ @AUDIO_CFLAGS@ # `fc-config --cflags`
LFLAGS = @LDFLAGS@
-LIBS = @LIBS@ `pkg-config gdk-pixbuf-xlib-2.0 --libs`
+LIBS = @LIBS@ `pkg-config gdk-pixbuf-xlib-2.0 fontconfig --libs`
CORE_LIBS = @CORE_LIBS@ # `fc-config --libs`
IMAGE_LIBS = @IMAGE_LIBS@

View File

@ -0,0 +1,21 @@
Description: Don't use "deprecated" as identifier, will FTBFS if another
library defines functions as deprecated.
Author: Andreas Moog <amoog@ubuntu.com>
Bug: https://sourceforge.net/tracker/?func=detail&aid=3494034&group_id=31&atid=100031
Bug-Ubuntu: https://bugs.launchpad.net/bugs/935179
Forwarded: Yes
--- icewm-1.3.7.orig/src/base.h
+++ icewm-1.3.7/src/base.h
@@ -2,9 +2,9 @@
#define __BASE_H
#if ( __GNUC__ == 3 && __GNUC_MINOR__ > 0 ) || __GNUC__ > 3
-#define deprecated __attribute__((deprecated))
+#define ICEWM_deprecated __attribute__((deprecated))
#else
-#define deprecated
+#define ICEWM_deprecated
#endif
/*** Atomar Data Types ********************************************************/