python/python2-automat: Fix offline build.
If fixed this in9c7bc63003
by adding python-m2r as a dependency. This is correct since upstream's `setup_requires` declares m2r as a dependency: https://github.com/glyph/automat/blob/v20.2.0/setup.py#L27 If m2r is not installed, the build will try to download it. If this fails, the build fails. This means the package cannot be built without internet at the moment. ``` distutils.errors.DistutilsError: Command '['/usr/bin/python2', '-m', 'pip', '--disable-pip-version-check', 'wheel', '--no-deps', '-w', '/tmp/SBo/build_python2-automat/tmpN8eQGt', '--quiet', 'm2r']' returned non-zero exit status 1 ``` In5f580e046a
, a change was made to make m2r optional, but this does not work since it is still declared in setup.py. It should be optional, since it is only used for formatting the contents of README.md for use as long_description in setup and that is wrapped in a try / except and will use the raw, unformatted text of README.md if it is not found. So for this change, I have patched out the declaration of m2r in setup.py and you can now build the package without downloading things as root during the build. Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
2a74ab6a36
commit
de55c77bbf
|
@ -0,0 +1,11 @@
|
|||
diff -Naur Automat-20.2.0.orig/setup.py Automat-20.2.0/setup.py
|
||||
--- Automat-20.2.0.orig/setup.py 2020-02-17 04:33:10.000000000 +0900
|
||||
+++ Automat-20.2.0/setup.py 2022-10-31 21:14:14.926665030 +0900
|
||||
@@ -24,7 +24,6 @@
|
||||
package_dir={'automat': 'automat'},
|
||||
setup_requires=[
|
||||
'setuptools-scm',
|
||||
- 'm2r',
|
||||
],
|
||||
install_requires=[
|
||||
"attrs>=19.2.0",
|
|
@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
|
|||
PRGNAM=python2-automat
|
||||
SRCNAM=Automat
|
||||
VERSION=${VERSION:-20.2.0}
|
||||
BUILD=${BUILD:-2}
|
||||
BUILD=${BUILD:-3}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
||||
|
@ -74,6 +74,7 @@ cd $TMP
|
|||
rm -rf $SRCNAM-$VERSION
|
||||
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
|
||||
cd $SRCNAM-$VERSION
|
||||
cat $CWD/optional_m2r.diff | patch -p1
|
||||
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
|
|
Loading…
Reference in New Issue