desktop/razorqt: Updated for version 0.5.2.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
1985746094
commit
dae601189d
|
@ -1,29 +1,25 @@
|
|||
diff --git a/razorqt-config/src/CMakeLists.txt b/razorqt-config/src/CMakeLists.txt
|
||||
index 193809c..76df89d 100644
|
||||
--- a/razorqt-config/src/CMakeLists.txt
|
||||
+++ b/razorqt-config/src/CMakeLists.txt
|
||||
@@ -52,4 +52,4 @@ target_link_libraries( razor-config qcategorizedview)
|
||||
diff -Naur razor-qt-0.5.2.orig/razorqt-config/src/CMakeLists.txt razor-qt-0.5.2/razorqt-config/src/CMakeLists.txt
|
||||
--- razor-qt-0.5.2.orig/razorqt-config/src/CMakeLists.txt 2013-01-12 17:40:48.000000000 +0100
|
||||
+++ razor-qt-0.5.2/razorqt-config/src/CMakeLists.txt 2013-01-14 07:03:35.907315151 +0100
|
||||
@@ -52,4 +52,4 @@
|
||||
|
||||
INSTALL(TARGETS razor-config RUNTIME DESTINATION bin)
|
||||
install(FILES ${DESKTOP_FILES} DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications)
|
||||
-install(FILES razor-config.menu DESTINATION /etc/xdg/menus/)
|
||||
+install(FILES razor-config.menu DESTINATION ${RAZOR_ETC_XDG_DIRECTORY}/menus/)
|
||||
diff --git a/razorqt-resources/application-menu/CMakeLists.txt b/razorqt-resources/application-menu/CMakeLists.txt
|
||||
index cfb1a64..356d7e5 100644
|
||||
--- a/razorqt-resources/application-menu/CMakeLists.txt
|
||||
+++ b/razorqt-resources/application-menu/CMakeLists.txt
|
||||
@@ -26,5 +26,5 @@ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/razor-applications.menu.in
|
||||
${CMAKE_CURRENT_BINARY_DIR}/razor-applications.menu
|
||||
@ONLY)
|
||||
diff -Naur razor-qt-0.5.2.orig/razorqt-resources/application-menu/CMakeLists.txt razor-qt-0.5.2/razorqt-resources/application-menu/CMakeLists.txt
|
||||
--- razor-qt-0.5.2.orig/razorqt-resources/application-menu/CMakeLists.txt 2013-01-12 17:40:48.000000000 +0100
|
||||
+++ razor-qt-0.5.2/razorqt-resources/application-menu/CMakeLists.txt 2013-01-14 07:04:24.877315008 +0100
|
||||
@@ -28,4 +28,4 @@
|
||||
|
||||
add_subdirectory(desktop-directories)
|
||||
|
||||
-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/razor-applications.menu DESTINATION /etc/xdg/menus/)
|
||||
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/razor-applications.menu DESTINATION ${RAZOR_ETC_XDG_DIRECTORY}/menus/)
|
||||
install(DIRECTORY desktop-directories DESTINATION share/ PATTERN ".desktop")
|
||||
diff --git a/razorqt-resources/autostart/CMakeLists.txt b/razorqt-resources/autostart/CMakeLists.txt
|
||||
index aa9dece..a00c119 100644
|
||||
--- a/razorqt-resources/autostart/CMakeLists.txt
|
||||
+++ b/razorqt-resources/autostart/CMakeLists.txt
|
||||
@@ -11,4 +11,4 @@ razor_translate_desktop(DESKTOP_FILES
|
||||
diff -Naur razor-qt-0.5.2.orig/razorqt-resources/autostart/CMakeLists.txt razor-qt-0.5.2/razorqt-resources/autostart/CMakeLists.txt
|
||||
--- razor-qt-0.5.2.orig/razorqt-resources/autostart/CMakeLists.txt 2013-01-12 17:40:48.000000000 +0100
|
||||
+++ razor-qt-0.5.2/razorqt-resources/autostart/CMakeLists.txt 2013-01-14 07:03:35.908315132 +0100
|
||||
@@ -11,4 +11,4 @@
|
||||
add_custom_target(autostart_desktop_files ALL DEPENDS ${DESKTOP_FILES})
|
||||
#************************************************
|
||||
|
||||
|
|
|
@ -29,7 +29,7 @@
|
|||
# Same for me (the only difference is that I use lxde ;p ) --ponce
|
||||
|
||||
PRGNAM=razorqt
|
||||
VERSION=${VERSION:-0.5.1}
|
||||
VERSION=${VERSION:-0.5.2}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -112,9 +112,9 @@ for i in desktop razor session windowmanagers razor-panel/panel; do
|
|||
done
|
||||
# Add missing section entry in razor.conf, to avoid complains
|
||||
# from razor-confupdate python script...
|
||||
sed -i '/^theme/i [General]' $PKG/$RCONFDIR/razor/razor.conf.new
|
||||
sed -i '/^theme/i [General]' $PKG/$RCONFDIR/razor/razor.conf.new || exit 1
|
||||
# ...beside the fact that it looks in the wrong path...
|
||||
sed -i "s|\.razor|.config/razor|" $PKG/usr/share/razor/razor-confupdate/*
|
||||
sed -i "s|\.razor|.config/razor|" $PKG/usr/share/razor/razor-confupdate/* || exit 1
|
||||
|
||||
# There's a small issue: seems like default configs are not created when
|
||||
# you launch razor the first time: copy them from their global dir if
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="razorqt"
|
||||
VERSION="0.5.1"
|
||||
VERSION="0.5.2"
|
||||
HOMEPAGE="http://razor-qt.org/"
|
||||
DOWNLOAD="https://github.com/downloads/Razor-qt/razor-qt/razorqt-0.5.1.tar.bz2"
|
||||
MD5SUM="a4c195c289c0843eb6152808ff21bd5a"
|
||||
DOWNLOAD="http://razor-qt.org/downloads/razorqt-0.5.2.tar.bz2"
|
||||
MD5SUM="8b2da8ab69065926bfc998cf1960bffb"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="libstatgrab"
|
||||
|
|
|
@ -12,7 +12,7 @@ sysmodmap=/etc/X11/xinit/.Xmodmap
|
|||
[ -f $usermodmap ] && /usr/bin/xmodmap $usermodmap
|
||||
|
||||
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
|
||||
ck-launch-session startrazor
|
||||
ck-launch-session dbus-launch --exit-with-session startrazor
|
||||
else
|
||||
exec startrazor
|
||||
fi
|
||||
|
|
Loading…
Reference in New Issue