academic/pyCRAC: Updated for version 1.2.4.0.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
This commit is contained in:
parent
cca112722f
commit
da57b65b95
|
@ -1,79 +0,0 @@
|
|||
diff -Naur sgrann-pycrac-8792459eeef7/pyCRAC/scripts/pyGTF2bedGraph.py sgrann-pycrac-8792459eeef7-slack/pyCRAC/scripts/pyGTF2bedGraph.py
|
||||
--- sgrann-pycrac-8792459eeef7/pyCRAC/scripts/pyGTF2bedGraph.py 2017-09-11 15:11:12.000000000 +0100
|
||||
+++ sgrann-pycrac-8792459eeef7-slack/pyCRAC/scripts/pyGTF2bedGraph.py 2017-09-10 00:47:13.014633000 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
# not compatible with python 3
|
||||
__author__ = "Sander Granneman"
|
||||
__copyright__ = "Copyright 2017"
|
||||
-__version__ = "0.0.7"
|
||||
+__version__ = "0.0.6"
|
||||
__credits__ = ["Sander Granneman"]
|
||||
__maintainer__ = "Sander Granneman"
|
||||
__email__ = "sgrannem@staffmail.ed.ac.uk"
|
||||
@@ -80,14 +80,12 @@
|
||||
chromdata = processChromFile(chromlengthfile)
|
||||
###
|
||||
|
||||
- normvalue = 1.0
|
||||
- if permillion and normvalue == 1.0:
|
||||
- assert data.mapped_reads, "No information on the number of mapped reads could be found in the gtf file. Cannot normalize the data"
|
||||
- normvalue = float(data.mapped_reads)/1000000.0
|
||||
-
|
||||
while True:
|
||||
lines = data.readLineByLine()
|
||||
- # to normalize the data to per million reads
|
||||
+ normvalue = 1.0
|
||||
+ if permillion and normvalue == 1.0:
|
||||
+ assert data.mapped_reads, "No information on the number of mapped reads could be found in the gtf file. Cannot normalize the data"
|
||||
+ normvalue = float(data.mapped_reads)/1000000.0 # to normalize the data to per million reads
|
||||
if current_chromosome and data.chromosome != current_chromosome or not lines:
|
||||
for strand in chromdict:
|
||||
start = 0
|
||||
diff -Naur sgrann-pycrac-8792459eeef7/pyCRAC/scripts/pyGTF2sgr.py sgrann-pycrac-8792459eeef7-slack/pyCRAC/scripts/pyGTF2sgr.py
|
||||
--- sgrann-pycrac-8792459eeef7/pyCRAC/scripts/pyGTF2sgr.py 2017-09-11 15:11:12.000000000 +0100
|
||||
+++ sgrann-pycrac-8792459eeef7-slack/pyCRAC/scripts/pyGTF2sgr.py 2017-09-10 00:47:13.014633000 +0100
|
||||
@@ -1,8 +1,8 @@
|
||||
#!/usr/bin/python
|
||||
# not compatible with python 3
|
||||
__author__ = "Sander Granneman"
|
||||
-__copyright__ = "Copyright 2017"
|
||||
-__version__ = "0.0.6"
|
||||
+__copyright__ = "Copyright 2015"
|
||||
+__version__ = "0.0.5"
|
||||
__credits__ = ["Sander Granneman"]
|
||||
__maintainer__ = "Sander Granneman"
|
||||
__email__ = "sgrannem@staffmail.ed.ac.uk"
|
||||
@@ -13,7 +13,7 @@
|
||||
# pyGTF2sgr.py
|
||||
#
|
||||
#
|
||||
-# Copyright (c) Sander Granneman 2017
|
||||
+# Copyright (c) Sander Granneman 2015
|
||||
#
|
||||
# Permission is hereby granted, free of charge, to any person obtaining a copy
|
||||
# of this software and associated documentation files (the "Software"), to deal
|
||||
@@ -73,12 +73,11 @@
|
||||
###
|
||||
|
||||
normvalue = 1.0
|
||||
- if permillion:
|
||||
- assert data.mapped_reads, "No information on the number of mapped reads could be found in the gtf file. Cannot normalize the data"
|
||||
- normvalue = float(data.mapped_reads)/1000000.0
|
||||
-
|
||||
while True:
|
||||
lines = data.readLineByLine()
|
||||
+ if permillion and normvalue == 1.0:
|
||||
+ assert data.mapped_reads, "No information on the number of mapped reads could be found in the gtf file. Cannot normalize the data"
|
||||
+ normvalue = float(data.mapped_reads)/1000000.0
|
||||
if current_chromosome and data.chromosome != current_chromosome or not lines:
|
||||
for strand in strands:
|
||||
if min_cov:
|
||||
@@ -118,6 +117,8 @@
|
||||
if data.substitutions: chromdict[data.strand][data.substitutions] += data.number_of_reads
|
||||
elif type == "deletions":
|
||||
if data.deletions: chromdict[data.strand][data.deletions] += data.number_of_reads
|
||||
+ else:
|
||||
+ break
|
||||
|
||||
def gtf2dropoffrates(gtffile,chromosomedata,out_files=[],score=False,log=sys.stdout,zeros=False,min_cov=0):
|
||||
"""Produces an sgr output file for hits, substitutions and deletions. It requires, besides data a file containing
|
|
@ -1,8 +1,8 @@
|
|||
The pyCRAC package is a collection of python2-scripts to analyse high
|
||||
throughput data generated by RNA-sequencing, especially of molecules
|
||||
crosslinked by UV to an immunoprecipitated protein of interest (i.e.
|
||||
data generated by CLIP or CRAC protocols).
|
||||
It can be used to remove duplicate reads,tackles directional libraries
|
||||
throughput data generated by RNA-sequencing, especially of molecules
|
||||
crosslinked by UV to an immunoprecipitated protein of interest (i.e.
|
||||
data generated by CLIP or CRAC protocols).
|
||||
It can be used to remove duplicate reads,tackles directional libraries
|
||||
and reports sense and anti-sense hits.
|
||||
|
||||
Included is the pipeline used for the analysis of a group of CRAC data
|
||||
|
|
|
@ -23,12 +23,12 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=pyCRAC
|
||||
VERSION=${VERSION:-1.2.3.0}
|
||||
VERSION=${VERSION:-1.2.4.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
SRCNAM=sgrann-pycrac
|
||||
SRCVER=${SRCVER:-8792459eeef7}
|
||||
SRCVER=${SRCVER:-eadda2b95c34}
|
||||
|
||||
PIPENAM=kinetic_crac_pipeline
|
||||
PIPEVER=${PIPEVER:-73dff1be9488}
|
||||
|
@ -73,8 +73,6 @@ mkdir $PRGNAM/$PIPENAM
|
|||
tar xvf $CWD/sgrann-$PIPENAM-$PIPEVER.tar.gz -C $PRGNAM/$PIPENAM --strip-components=1 || \
|
||||
tar xvf $CWD/$PIPEVER.tar.gz -C $PRGNAM/$PIPENAM --strip-components=1
|
||||
|
||||
patch -p1 < $CWD/GTF2-scripts.patch
|
||||
|
||||
#replace setup.py
|
||||
rm setup.py
|
||||
cp $CWD/setup_slack.py setup.py
|
||||
|
@ -94,7 +92,7 @@ python setup.py install --root=$PKG
|
|||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
# The pipeline-R script
|
||||
# The pipeline-R script
|
||||
mkdir -p $PKG/usr/share/$PRGNAM-$VERSION/$PIPENAM
|
||||
cp $PRGNAM/$PIPENAM/gaussianProcessAnalysis.R $PKG/usr/share/$PRGNAM-$VERSION/$PIPENAM
|
||||
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
PRGNAM="pyCRAC"
|
||||
VERSION="1.2.3.0"
|
||||
VERSION="1.2.4.0"
|
||||
HOMEPAGE="https://bitbucket.org/sgrann/"
|
||||
DOWNLOAD="https://bitbucket.org/sgrann/pycrac/get/8792459eeef7.tar.gz \
|
||||
DOWNLOAD="https://bitbucket.org/sgrann/pycrac/get/eadda2b95c34.tar.gz \
|
||||
https://bitbucket.org/sgrann/kinetic_crac_pipeline/get/73dff1be9488.tar.gz"
|
||||
MD5SUM="a0e05b812dc765a2b1f673078ea43e3d \
|
||||
MD5SUM="c6b37913a6f7da123e3243166806aa56 \
|
||||
8f968d1dca38aa2b3ac401ba8da70cef"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
# not compatible with python 3
|
||||
__author__ = "Sander Granneman"
|
||||
__copyright__ = "Copyright 2017"
|
||||
__version__ = "1.2.3.0"
|
||||
__version__ = "1.2.4.0"
|
||||
__credits__ = ["Sander Granneman","Hywell Dunn Davies"]
|
||||
__maintainer__ = ["Rob van Nues, via SlackBuilds.org"]
|
||||
__email__ = "sgrannem@staffmail.ed.ac.uk"
|
||||
|
|
Loading…
Reference in New Issue