academic/qrupdate: Update URLs and patches.

Signed-off-by: Kyle Guinn <elyk03@gmail.com>
This commit is contained in:
Kyle Guinn 2019-01-01 18:12:44 -06:00 committed by Willy Sudiarto Raharjo
parent df6aa3381d
commit d693923f50
No known key found for this signature in database
GPG Key ID: 887B8374D7333381
3 changed files with 61 additions and 62 deletions

View File

@ -2,14 +2,56 @@ diff --git a/Makefile.am b/Makefile.am
new file mode 100644
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,3 @@
@@ -0,0 +1,5 @@
+ACLOCAL_AMFLAGS = -I m4
+
+SUBDIRS = src test
+
+pkgconfig_DATA = qrupdate.pc
diff --git a/ax_blas.m4 b/ax_blas.m4
diff --git a/configure.ac b/configure.ac
new file mode 100644
--- /dev/null
+++ b/ax_blas.m4
+++ b/configure.ac
@@ -0,0 +1,35 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.69])
+AC_INIT([qrupdate],[1.1.2],[highegg@gmail.com],[qrupdate],[https://sourceforge.net/projects/qrupdate/])
+AC_CONFIG_SRCDIR([src/sqr1up.f])
+AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_HEADERS([src/config.h])
+AM_INIT_AUTOMAKE([foreign])
+AM_SILENT_RULES([yes])
+LT_INIT([disable-static])
+
+# Checks for programs.
+AC_PROG_INSTALL
+AC_PROG_F77
+
+# Checks for libraries.
+AX_BLAS([], [AC_MSG_ERROR([cannot find BLAS])])
+AX_LAPACK([], [AC_MSG_ERROR([cannot find LAPACK])])
+
+# Checks for header files.
+
+# Checks for typedefs, structures, and compiler characteristics.
+
+# Checks for library functions.
+
+m4_ifdef([PKG_INSTALLDIR], [PKG_INSTALLDIR], [AC_SUBST([pkgconfigdir], [${libdir}/pkgconfig])])
+AC_CONFIG_FILES([
+ qrupdate.pc
+ Makefile
+ src/Makefile
+ test/Makefile
+])
+AC_OUTPUT
diff --git a/m4/ax_blas.m4 b/m4/ax_blas.m4
new file mode 100644
--- /dev/null
+++ b/m4/ax_blas.m4
@@ -0,0 +1,238 @@
+# ===========================================================================
+# https://www.gnu.org/software/autoconf-archive/ax_blas.html
@ -76,11 +118,11 @@ new file mode 100644
+# modified version of the Autoconf Macro, you may extend this special
+# exception to the GPL to apply to your modified version as well.
+
+#serial 15
+#serial 16
+
+AU_ALIAS([ACX_BLAS], [AX_BLAS])
+AC_DEFUN([AX_BLAS], [
+AC_PREREQ(2.50)
+AC_PREREQ([2.55])
+AC_REQUIRE([AC_F77_LIBRARY_LDFLAGS])
+AC_REQUIRE([AC_CANONICAL_HOST])
+ax_blas_ok=no
@ -106,7 +148,7 @@ new file mode 100644
+if test "x$BLAS_LIBS" != x; then
+ save_LIBS="$LIBS"; LIBS="$BLAS_LIBS $LIBS"
+ AC_MSG_CHECKING([for $sgemm in $BLAS_LIBS])
+ AC_TRY_LINK_FUNC($sgemm, [ax_blas_ok=yes], [BLAS_LIBS=""])
+ AC_LINK_IFELSE([AC_LANG_CALL([], [$sgemm])], [ax_blas_ok=yes], [BLAS_LIBS=""])
+ AC_MSG_RESULT($ax_blas_ok)
+ LIBS="$save_LIBS"
+fi
@ -116,7 +158,7 @@ new file mode 100644
+if test $ax_blas_ok = no; then
+ save_LIBS="$LIBS"; LIBS="$LIBS"
+ AC_MSG_CHECKING([if $sgemm is being linked in already])
+ AC_TRY_LINK_FUNC($sgemm, [ax_blas_ok=yes])
+ AC_LINK_IFELSE([AC_LANG_CALL([], [$sgemm])], [ax_blas_ok=yes])
+ AC_MSG_RESULT($ax_blas_ok)
+ LIBS="$save_LIBS"
+fi
@ -187,7 +229,7 @@ new file mode 100644
+if test $ax_blas_ok = no; then
+ save_LIBS="$LIBS"; LIBS="-framework vecLib $LIBS"
+ AC_MSG_CHECKING([for $sgemm in -framework vecLib])
+ AC_TRY_LINK_FUNC($sgemm, [ax_blas_ok=yes;BLAS_LIBS="-framework vecLib"])
+ AC_LINK_IFELSE([AC_LANG_CALL([], [$sgemm])], [ax_blas_ok=yes;BLAS_LIBS="-framework vecLib"])
+ AC_MSG_RESULT($ax_blas_ok)
+ LIBS="$save_LIBS"
+fi
@ -249,10 +291,10 @@ new file mode 100644
+ $2
+fi
+])dnl AX_BLAS
diff --git a/ax_lapack.m4 b/ax_lapack.m4
diff --git a/m4/ax_lapack.m4 b/m4/ax_lapack.m4
new file mode 100644
--- /dev/null
+++ b/ax_lapack.m4
+++ b/m4/ax_lapack.m4
@@ -0,0 +1,131 @@
+# ===========================================================================
+# https://www.gnu.org/software/autoconf-archive/ax_lapack.html
@ -320,7 +362,7 @@ new file mode 100644
+# modified version of the Autoconf Macro, you may extend this special
+# exception to the GPL to apply to your modified version as well.
+
+#serial 8
+#serial 9
+
+AU_ALIAS([ACX_LAPACK], [AX_LAPACK])
+AC_DEFUN([AX_LAPACK], [
@ -349,7 +391,7 @@ new file mode 100644
+if test "x$LAPACK_LIBS" != x; then
+ save_LIBS="$LIBS"; LIBS="$LAPACK_LIBS $BLAS_LIBS $LIBS $FLIBS"
+ AC_MSG_CHECKING([for $cheev in $LAPACK_LIBS])
+ AC_TRY_LINK_FUNC($cheev, [ax_lapack_ok=yes], [LAPACK_LIBS=""])
+ AC_LINK_IFELSE([AC_LANG_CALL([], [$cheev])], [ax_lapack_ok=yes], [LAPACK_LIBS=""])
+ AC_MSG_RESULT($ax_lapack_ok)
+ LIBS="$save_LIBS"
+ if test $ax_lapack_ok = no; then
@ -385,47 +427,6 @@ new file mode 100644
+ $2
+fi
+])dnl AX_LAPACK
diff --git a/configure.ac b/configure.ac
new file mode 100644
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,36 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.69])
+AC_INIT([qrupdate],[1.1.2],[highegg@gmail.com],[qrupdate],[https://sourceforge.net/projects/qrupdate/])
+AC_CONFIG_SRCDIR([src/sqr1up.f])
+AC_CONFIG_HEADERS([src/config.h])
+AM_INIT_AUTOMAKE([foreign])
+LT_INIT
+
+# Checks for programs.
+AC_PROG_INSTALL
+AC_PROG_F77
+
+# Checks for libraries.
+sinclude([ax_blas.m4])
+AX_BLAS([], [AC_MSG_ERROR([cannot find BLAS])])
+
+sinclude([ax_lapack.m4])
+AX_LAPACK([], [AC_MSG_ERROR([cannot find LAPACK])])
+
+# Checks for header files.
+
+# Checks for typedefs, structures, and compiler characteristics.
+
+# Checks for library functions.
+
+m4_ifdef([PKG_INSTALLDIR], [PKG_INSTALLDIR], [AC_SUBST([pkgconfigdir], [${libdir}/pkgconfig])])
+
+AC_CONFIG_FILES([
+ qrupdate.pc
+ Makefile
+ src/Makefile
+ test/Makefile
+])
+AC_OUTPUT
diff --git a/qrupdate.pc.in b/qrupdate.pc.in
new file mode 100644
--- /dev/null

View File

@ -2,7 +2,7 @@
# Slackware build script for qrupdate
# Copyright 2017 Kyle Guinn <elyk03@gmail.com>, USA
# Copyright 2017-2019 Kyle Guinn <elyk03@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -24,7 +24,7 @@
PRGNAM=qrupdate
VERSION=${VERSION:-1.1.2}
BUILD=${BUILD:-3}
BUILD=${BUILD:-4}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -37,7 +37,7 @@ fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
PKG=$TMP/package-$PRGNAM-$VERSION
OUTPUT=${OUTPUT:-/tmp}
DOCS="COPYING ChangeLog README"
@ -70,8 +70,8 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go-w,a+rX-st .
patch -p1 < $CWD/patches/autotoolize.diff
patch -p2 < $CWD/patches/atlas-lib-rename.diff
patch -p1 < $CWD/patches/autoconfiscate.diff
patch -p1 < $CWD/patches/atlas-lib-rename.diff
autoreconf -vif
./configure \
@ -82,8 +82,6 @@ autoreconf -vif
--mandir=/usr/man \
--infodir=/usr/info \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--enable-shared \
--disable-static \
--disable-dependency-tracking \
--build=$ARCH-slackware-linux \
FFLAGS="$SLKCFLAGS" \

View File

@ -1,7 +1,7 @@
PRGNAM="qrupdate"
VERSION="1.1.2"
HOMEPAGE="http://qrupdate.sourceforge.net/"
DOWNLOAD="http://downloads.sourceforge.net/qrupdate/qrupdate-1.1.2.tar.gz"
HOMEPAGE="https://sourceforge.net/projects/qrupdate/"
DOWNLOAD="https://sourceforge.net/projects/qrupdate/files/qrupdate/1.2/qrupdate-1.1.2.tar.gz"
MD5SUM="6d073887c6e858c24aeda5b54c57a8c4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""