libraries/libopensync: Removed. Dead upstream.
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
This commit is contained in:
parent
2de8614619
commit
d3fc1b5e04
|
@ -1,4 +0,0 @@
|
||||||
OpenSync is a plugin-based application that basically provides a framework
|
|
||||||
for syncing groups which can have two or more members. These members could
|
|
||||||
be just about any kind of database, where a plugin is available. OpenSync
|
|
||||||
is not only limited to sync PIM data.
|
|
|
@ -1,113 +0,0 @@
|
||||||
#!/bin/sh
|
|
||||||
|
|
||||||
# Slackware build script for libopensync
|
|
||||||
|
|
||||||
# Copyright 2008-2011 Heinz Wiesinger, Amsterdam, The Netherlands
|
|
||||||
# All rights reserved.
|
|
||||||
#
|
|
||||||
# Redistribution and use of this script, with or without modification, is
|
|
||||||
# permitted provided that the following conditions are met:
|
|
||||||
#
|
|
||||||
# 1. Redistributions of this script must retain the above copyright
|
|
||||||
# notice, this list of conditions and the following disclaimer.
|
|
||||||
#
|
|
||||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
||||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
||||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
||||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
||||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
||||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
||||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
||||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
||||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
||||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
||||||
|
|
||||||
PRGNAM=libopensync
|
|
||||||
VERSION=0.22
|
|
||||||
BUILD=${BUILD:-3}
|
|
||||||
TAG=${TAG:-_SBo}
|
|
||||||
|
|
||||||
if [ -z "$ARCH" ]; then
|
|
||||||
case "$( uname -m )" in
|
|
||||||
i?86) ARCH=i486 ;;
|
|
||||||
arm*) ARCH=arm ;;
|
|
||||||
*) ARCH=$( uname -m ) ;;
|
|
||||||
esac
|
|
||||||
fi
|
|
||||||
|
|
||||||
CWD=$(pwd)
|
|
||||||
TMP=${TMP:-/tmp/SBo}
|
|
||||||
PKG=$TMP/package-$PRGNAM
|
|
||||||
OUTPUT=${OUTPUT:-/tmp}
|
|
||||||
|
|
||||||
if [ "$ARCH" = "i486" ]; then
|
|
||||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
|
||||||
LIBDIRSUFFIX=""
|
|
||||||
elif [ "$ARCH" = "i686" ]; then
|
|
||||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
|
||||||
LIBDIRSUFFIX=""
|
|
||||||
elif [ "$ARCH" = "x86_64" ]; then
|
|
||||||
SLKCFLAGS="-O2 -fPIC"
|
|
||||||
LIBDIRSUFFIX="64"
|
|
||||||
else
|
|
||||||
SLKCFLAGS="-O2"
|
|
||||||
LIBDIRSUFFIX=""
|
|
||||||
fi
|
|
||||||
|
|
||||||
set -e
|
|
||||||
|
|
||||||
rm -rf $PKG
|
|
||||||
mkdir -p $TMP $PKG $OUTPUT
|
|
||||||
cd $TMP
|
|
||||||
rm -rf $PRGNAM-$VERSION
|
|
||||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
|
|
||||||
cd $PRGNAM-$VERSION
|
|
||||||
chown -R root:root .
|
|
||||||
find -L . \
|
|
||||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
|
||||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
|
||||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
|
||||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
|
||||||
|
|
||||||
# Cmake-based build-system used by libopensync >= 0.30
|
|
||||||
# Uncomment this if you want to build newer versions.
|
|
||||||
# (also comment the "standard" build method below it)
|
|
||||||
|
|
||||||
# cmake \
|
|
||||||
# -DCMAKE_C_FLAGS="$SLKCFLAGS" \
|
|
||||||
# -DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
|
|
||||||
# -DCMAKE_INSTALL_PREFIX=/usr
|
|
||||||
|
|
||||||
# Apply some patches from gentoo
|
|
||||||
for i in $CWD/patches/* ; do patch -p1 < $i ; done
|
|
||||||
sed -i "s%python_path/lib%python_path/lib${LIBDIRSUFFIX}%g" acinclude.m4
|
|
||||||
|
|
||||||
autoreconf -i
|
|
||||||
|
|
||||||
CFLAGS="$SLKCFLAGS -Wno-error" \
|
|
||||||
CXXFLAGS="$SLKCFLAGS -Wno-error" \
|
|
||||||
./configure \
|
|
||||||
--prefix=/usr \
|
|
||||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
|
||||||
--sysconfdir=/etc \
|
|
||||||
--localstatedir=/var \
|
|
||||||
--disable-static \
|
|
||||||
--build=$ARCH-slackware-linux
|
|
||||||
|
|
||||||
make
|
|
||||||
make install DESTDIR=$PKG
|
|
||||||
|
|
||||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
|
||||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
|
||||||
|
|
||||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
|
||||||
cp -a \
|
|
||||||
AUTHORS COPYING INSTALL NEWS README TODO \
|
|
||||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
|
||||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
|
||||||
|
|
||||||
mkdir -p $PKG/install
|
|
||||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
||||||
|
|
||||||
cd $PKG
|
|
||||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
|
|
@ -1,10 +0,0 @@
|
||||||
PRGNAM="libopensync"
|
|
||||||
VERSION="0.22"
|
|
||||||
HOMEPAGE="http://www.opensync.org/"
|
|
||||||
DOWNLOAD="http://pkgs.fedoraproject.org/repo/pkgs/libopensync/libopensync-0.22.tar.bz2/f563ce2543312937a9afb4f8445ef932/libopensync-0.22.tar.bz2"
|
|
||||||
MD5SUM="f563ce2543312937a9afb4f8445ef932"
|
|
||||||
DOWNLOAD_x86_64=""
|
|
||||||
MD5SUM_x86_64=""
|
|
||||||
REQUIRES=""
|
|
||||||
MAINTAINER="Heinz Wiesinger"
|
|
||||||
EMAIL="pprkut@liwjatan.at"
|
|
|
@ -1,82 +0,0 @@
|
||||||
https://bugs.gentoo.org/355291
|
|
||||||
|
|
||||||
--- a/opensync/Makefile.am
|
|
||||||
+++ b/opensync/Makefile.am
|
|
||||||
@@ -77,5 +77,5 @@ CLEANFILES = \
|
|
||||||
*.bbg \
|
|
||||||
*.da
|
|
||||||
|
|
||||||
-libopensync_la_LDFLAGS = @PACKAGE_LIBS@ @GCOV_LDFLAGS@
|
|
||||||
-libopensync_la_LIBADD = @XML_LIBS@
|
|
||||||
+libopensync_la_LDFLAGS = @GCOV_LDFLAGS@
|
|
||||||
+libopensync_la_LIBADD = @PACKAGE_LIBS@ @XML_LIBS@
|
|
||||||
--- a/osengine/Makefile.am
|
|
||||||
+++ b/osengine/Makefile.am
|
|
||||||
@@ -43,5 +43,5 @@ CLEANFILES = \
|
|
||||||
*.bbg \
|
|
||||||
*.da
|
|
||||||
|
|
||||||
-libosengine_la_LDFLAGS = $(PACKAGE_LIBS) -R $(libdir) @GCOV_LDFLAGS@
|
|
||||||
-libosengine_la_LIBADD = $(top_builddir)/opensync/libopensync.la
|
|
||||||
+libosengine_la_LDFLAGS = @GCOV_LDFLAGS@
|
|
||||||
+libosengine_la_LIBADD = $(top_builddir)/opensync/libopensync.la $(PACKAGE_LIBS)
|
|
||||||
--- a/osplugin/Makefile.am
|
|
||||||
+++ b/osplugin/Makefile.am
|
|
||||||
@@ -9,8 +9,8 @@ libexec_PROGRAMS = osplugin
|
|
||||||
ospluginincludedir = @OPENSYNC_HEADERDIR@
|
|
||||||
|
|
||||||
osplugin_SOURCES = osplugin.c
|
|
||||||
-osplugin_LDFLAGS = @PACKAGE_LIBS@ @XML_LIBS@ -R $(libdir) @GCOV_LDFLAGS@
|
|
||||||
-osplugin_LDADD = $(top_builddir)/opensync/libopensync.la
|
|
||||||
+osplugin_LDFLAGS = @GCOV_LDFLAGS@
|
|
||||||
+osplugin_LDADD = $(top_builddir)/opensync/libopensync.la @PACKAGE_LIBS@ @XML_LIBS@
|
|
||||||
|
|
||||||
CLEANFILES = \
|
|
||||||
*.bb \
|
|
||||||
--- a/tools/Makefile.am
|
|
||||||
+++ b/tools/Makefile.am
|
|
||||||
@@ -9,24 +9,24 @@ bin_PROGRAMS = osyncdump osyncstress osyncplugin osynctest osyncbinary
|
|
||||||
endif
|
|
||||||
|
|
||||||
osyncdump_SOURCES = osyncdump.c
|
|
||||||
-osyncdump_LDFLAGS = @PACKAGE_LIBS@ @XML_LIBS@ -R $(libdir) @GCOV_LDFLAGS@
|
|
||||||
-osyncdump_LDADD = $(top_builddir)/opensync/libopensync.la
|
|
||||||
+osyncdump_LDFLAGS = @GCOV_LDFLAGS@
|
|
||||||
+osyncdump_LDADD = $(top_builddir)/opensync/libopensync.la @PACKAGE_LIBS@ @XML_LIBS@
|
|
||||||
|
|
||||||
osyncstress_SOURCES = osyncstress.c
|
|
||||||
-osyncstress_LDFLAGS = @PACKAGE_LIBS@ -R $(libdir) @GCOV_LDFLAGS@
|
|
||||||
-osyncstress_LDADD = $(top_builddir)/osengine/libosengine.la $(top_builddir)/opensync/libopensync.la
|
|
||||||
+osyncstress_LDFLAGS = @GCOV_LDFLAGS@
|
|
||||||
+osyncstress_LDADD = $(top_builddir)/osengine/libosengine.la $(top_builddir)/opensync/libopensync.la @PACKAGE_LIBS@
|
|
||||||
|
|
||||||
osyncplugin_SOURCES = osyncplugin.c
|
|
||||||
-osyncplugin_LDFLAGS = @PACKAGE_LIBS@ -R $(libdir) @GCOV_LDFLAGS@
|
|
||||||
-osyncplugin_LDADD = $(top_builddir)/opensync/libopensync.la
|
|
||||||
+osyncplugin_LDFLAGS = @GCOV_LDFLAGS@
|
|
||||||
+osyncplugin_LDADD = $(top_builddir)/opensync/libopensync.la @PACKAGE_LIBS@
|
|
||||||
|
|
||||||
osynctest_SOURCES = osynctest.c
|
|
||||||
-osynctest_LDFLAGS = @PACKAGE_LIBS@ -R $(libdir) @GCOV_LDFLAGS@
|
|
||||||
-osynctest_LDADD = $(top_builddir)/osengine/libosengine.la $(top_builddir)/opensync/libopensync.la
|
|
||||||
+osynctest_LDFLAGS = @GCOV_LDFLAGS@
|
|
||||||
+osynctest_LDADD = $(top_builddir)/osengine/libosengine.la $(top_builddir)/opensync/libopensync.la @PACKAGE_LIBS@
|
|
||||||
|
|
||||||
osyncbinary_SOURCES = osyncbinary.c
|
|
||||||
-osyncbinary_LDFLAGS = @PACKAGE_LIBS@ -R $(libdir)
|
|
||||||
-osyncbinary_LDADD = $(top_builddir)/opensync/libopensync.la
|
|
||||||
+osyncbinary_LDFLAGS =
|
|
||||||
+osyncbinary_LDADD = $(top_builddir)/opensync/libopensync.la @PACKAGE_LIBS@
|
|
||||||
|
|
||||||
CLEANFILES = \
|
|
||||||
*.bb \
|
|
||||||
--- a/wrapper/Makefile.am
|
|
||||||
+++ b/wrapper/Makefile.am
|
|
||||||
@@ -22,5 +22,5 @@ osbindings_LTLIBRARIES = _opensync.la
|
|
||||||
endif
|
|
||||||
|
|
||||||
nodist__opensync_la_SOURCES = opensync_wrap.c
|
|
||||||
-_opensync_la_LDFLAGS = @PACKAGE_LIBS@ @XML_LIBS@ $(PYTHON_LDFLAGS) -R $(libdir) -module -avoid-version
|
|
||||||
-_opensync_la_LIBADD = $(top_builddir)/opensync/libopensync.la
|
|
||||||
+_opensync_la_LDFLAGS = -module -avoid-version
|
|
||||||
+_opensync_la_LIBADD = $(top_builddir)/opensync/libopensync.la $(PYTHON_LDFLAGS) @PACKAGE_LIBS@ @XML_LIBS@
|
|
|
@ -1,63 +0,0 @@
|
||||||
diff --git a/acinclude.m4 b/acinclude.m4
|
|
||||||
index 2bf9951..a3b617c 100644
|
|
||||||
--- a/acinclude.m4
|
|
||||||
+++ b/acinclude.m4
|
|
||||||
@@ -1008,9 +1008,9 @@ AC_DEFUN([AC_PROG_SWIG],[
|
|
||||||
if test -z "$available_patch" ; then
|
|
||||||
[available_patch=0]
|
|
||||||
fi
|
|
||||||
- if test $available_major -ne $required_major \
|
|
||||||
- -o $available_minor -ne $required_minor \
|
|
||||||
- -o $available_patch -lt $required_patch ; then
|
|
||||||
+ if test $available_major -lt $required_major \
|
|
||||||
+ -a $available_minor -lt $required_minor \
|
|
||||||
+ -a $available_patch -lt $required_patch ; then
|
|
||||||
AC_MSG_WARN([SWIG version >= $1 is required. You have $swig_version. You should look at http://www.swig.org])
|
|
||||||
SWIG='echo "Error: SWIG version >= $1 is required. You have '"$swig_version"'. You should look at http://www.swig.org" ; false'
|
|
||||||
else
|
|
||||||
@@ -1114,7 +1114,7 @@ AC_DEFUN([AC_PYTHON_DEVEL],[
|
|
||||||
AC_MSG_CHECKING([for Python include path])
|
|
||||||
python_path=`echo $PYTHON | sed "s,/bin.*$,,"`
|
|
||||||
for i in "$python_path/include/python$PYTHON_VERSION/" "$python_path/include/python/" "$python_path/" ; do
|
|
||||||
- python_path=`find $i -type f -name Python.h -print | sed "1q"`
|
|
||||||
+ python_path=`find $i -type f -name Python.h -print 2>/dev/null | sed "1q"`
|
|
||||||
if test -n "$python_path" ; then
|
|
||||||
break
|
|
||||||
fi
|
|
||||||
@@ -1129,8 +1129,8 @@ AC_DEFUN([AC_PYTHON_DEVEL],[
|
|
||||||
# Check for Python library path
|
|
||||||
AC_MSG_CHECKING([for Python library path])
|
|
||||||
python_path=`echo $PYTHON | sed "s,/bin.*$,,"`
|
|
||||||
- for i in "$python_path/lib/python$PYTHON_VERSION/config/" "$python_path/lib/python$PYTHON_VERSION/" "$python_path/lib/python/config/" "$python_path/lib/python/" "$python_path/" ; do
|
|
||||||
- python_path=`find $i -type f -name libpython$PYTHON_VERSION.* -print | sed "1q"`
|
|
||||||
+ for i in "$python_path/lib/python$PYTHON_VERSION/config/" "$python_path/lib/python$PYTHON_VERSION/" "$python_path/lib/python/config/" "$python_path/lib/python/" "$python_path/lib/" ; do
|
|
||||||
+ python_path=`find $i -type f -name libpython$PYTHON_VERSION.* -print 2>/dev/null | sed "1q"`
|
|
||||||
if test -n "$python_path" ; then
|
|
||||||
break
|
|
||||||
fi
|
|
||||||
@@ -1142,16 +1142,21 @@ AC_DEFUN([AC_PYTHON_DEVEL],[
|
|
||||||
fi
|
|
||||||
AC_SUBST([PYTHON_LDFLAGS],["-L$python_path -lpython$PYTHON_VERSION"])
|
|
||||||
#
|
|
||||||
- python_site=`echo $python_path | sed "s/config/site-packages/"`
|
|
||||||
- AC_SUBST([PYTHON_SITE_PKG],[$python_site])
|
|
||||||
+ # site-packages directory
|
|
||||||
+ #
|
|
||||||
+ AC_MSG_CHECKING(python site-packages)
|
|
||||||
+ PYTHON_SITE_PKG=`$PYTHON -c "from distutils.sysconfig import get_python_lib; \
|
|
||||||
+ print get_python_lib()"`
|
|
||||||
+ AC_MSG_RESULT($PYTHON_SITE_PKG)
|
|
||||||
+ AC_SUBST(PYTHON_SITE_PKG)
|
|
||||||
#
|
|
||||||
# libraries which must be linked in when embedding
|
|
||||||
#
|
|
||||||
AC_MSG_CHECKING(python extra libraries)
|
|
||||||
PYTHON_EXTRA_LIBS=`$PYTHON -c "import distutils.sysconfig; \
|
|
||||||
conf = distutils.sysconfig.get_config_var; \
|
|
||||||
- print conf('LOCALMODLIBS')+' '+conf('LIBS')"
|
|
||||||
- AC_MSG_RESULT($PYTHON_EXTRA_LIBS)`
|
|
||||||
+ print conf('LOCALMODLIBS')+' '+conf('LIBS')"`
|
|
||||||
+ AC_MSG_RESULT($PYTHON_EXTRA_LIBS)
|
|
||||||
AC_SUBST(PYTHON_EXTRA_LIBS)
|
|
||||||
])
|
|
||||||
dnl as-ac-expand.m4 0.2.0
|
|
|
@ -1,13 +0,0 @@
|
||||||
diff --git a/wrapper/opensync.i b/wrapper/opensync.i
|
|
||||||
index 623c0f4..8131158 100644
|
|
||||||
--- a/wrapper/opensync.i
|
|
||||||
+++ b/wrapper/opensync.i
|
|
||||||
@@ -82,7 +82,7 @@ typedef struct {} OSyncHashTable;
|
|
||||||
%extend OSyncChange {
|
|
||||||
OSyncChange(PyObject *obj=NULL) {
|
|
||||||
OSyncChange *change = NULL;
|
|
||||||
- if (obj)
|
|
||||||
+ if ((obj) && (obj != Py_None))
|
|
||||||
change = (OSyncChange *)PyCObject_AsVoidPtr(obj);
|
|
||||||
else
|
|
||||||
change = osync_change_new();
|
|
|
@ -1,19 +0,0 @@
|
||||||
# HOW TO EDIT THIS FILE:
|
|
||||||
# The "handy ruler" below makes it easier to edit a package description.
|
|
||||||
# Line up the first '|' above the ':' following the base package name, and
|
|
||||||
# the '|' on the right side marks the last column you can put a character in.
|
|
||||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
|
||||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
|
||||||
|
|
||||||
|-----handy-ruler------------------------------------------------------|
|
|
||||||
libopensync: libopensync (plugin-based synchronisation)
|
|
||||||
libopensync:
|
|
||||||
libopensync: OpenSync is a plugin-based application that basically provides
|
|
||||||
libopensync: a framework for syncing groups which can have two or more
|
|
||||||
libopensync: members. These members could be just about any kind of
|
|
||||||
libopensync: database, where a plugin is available. OpenSync is not only
|
|
||||||
libopensync: limited to sync PIM data.
|
|
||||||
libopensync:
|
|
||||||
libopensync: Homepage: http://www.opensync.org/
|
|
||||||
libopensync:
|
|
||||||
libopensync:
|
|
Loading…
Reference in New Issue