desktop/quickswitch-i3: Added (utility for i3 wm).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
7b6dee361a
commit
d3ca46e662
|
@ -0,0 +1,17 @@
|
||||||
|
--- quickswitch-i3-2.1/quickswitch.original.py 2014-05-02 13:32:46.939145487 +0300
|
||||||
|
+++ quickswitch-i3-2.1/quickswitch.py 2014-05-02 13:41:20.155729397 +0300
|
||||||
|
@@ -30,8 +30,13 @@
|
||||||
|
try:
|
||||||
|
import i3
|
||||||
|
except ImportError:
|
||||||
|
+ print("")
|
||||||
|
+ print("----------------------------------------------------")
|
||||||
|
print("quickswitch requires i3-py.")
|
||||||
|
- print("You can install it from the PyPI with ``pip install i3-py''.")
|
||||||
|
+ print("You can install it from http://slackbuilds.org site")
|
||||||
|
+ print("or from PyPI with ``pip install i3-py''.")
|
||||||
|
+ print("----------------------------------------------------")
|
||||||
|
+ print("")
|
||||||
|
exit(1)
|
||||||
|
|
||||||
|
|
|
@ -0,0 +1,5 @@
|
||||||
|
This utility for i3, inspired by Pentadactyl's :buffers command,
|
||||||
|
allows you to quickly switch to and locate windows on all your
|
||||||
|
workspaces, using an interactive dmenu prompt. It has since gained
|
||||||
|
a lot of other functionality to make working with i3 even more
|
||||||
|
efficient.
|
|
@ -0,0 +1,3 @@
|
||||||
|
if [ -x /usr/bin/update-desktop-database ]; then
|
||||||
|
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||||
|
fi
|
|
@ -0,0 +1,89 @@
|
||||||
|
#!/bin/sh
|
||||||
|
|
||||||
|
# Slackware build script for quickswitch-i3
|
||||||
|
|
||||||
|
# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
|
||||||
|
# All rights reserved.
|
||||||
|
#
|
||||||
|
# Redistribution and use of this script, with or without modification, is
|
||||||
|
# permitted provided that the following conditions are met:
|
||||||
|
#
|
||||||
|
# 1. Redistributions of this script must retain the above copyright
|
||||||
|
# notice, this list of conditions and the following disclaimer.
|
||||||
|
#
|
||||||
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||||
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||||
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||||
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||||
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||||
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||||
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||||
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||||
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||||
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
|
|
||||||
|
PRGNAM=quickswitch-i3
|
||||||
|
VERSION=${VERSION:-2.1}
|
||||||
|
BUILD=${BUILD:-1}
|
||||||
|
TAG=${TAG:-_SBo}
|
||||||
|
|
||||||
|
if [ -z "$ARCH" ]; then
|
||||||
|
case "$( uname -m )" in
|
||||||
|
i?86) ARCH=i486 ;;
|
||||||
|
arm*) ARCH=arm ;;
|
||||||
|
*) ARCH=$( uname -m ) ;;
|
||||||
|
esac
|
||||||
|
fi
|
||||||
|
|
||||||
|
CWD=$(pwd)
|
||||||
|
TMP=${TMP:-/tmp/SBo}
|
||||||
|
PKG=$TMP/package-$PRGNAM
|
||||||
|
OUTPUT=${OUTPUT:-/tmp}
|
||||||
|
|
||||||
|
if [ "$ARCH" = "i486" ]; then
|
||||||
|
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||||
|
LIBDIRSUFFIX=""
|
||||||
|
elif [ "$ARCH" = "i686" ]; then
|
||||||
|
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||||
|
LIBDIRSUFFIX=""
|
||||||
|
elif [ "$ARCH" = "x86_64" ]; then
|
||||||
|
SLKCFLAGS="-O2 -fPIC"
|
||||||
|
LIBDIRSUFFIX="64"
|
||||||
|
else
|
||||||
|
SLKCFLAGS="-O2"
|
||||||
|
LIBDIRSUFFIX=""
|
||||||
|
fi
|
||||||
|
|
||||||
|
set -e
|
||||||
|
|
||||||
|
rm -rf $PKG
|
||||||
|
mkdir -p $TMP $PKG $OUTPUT
|
||||||
|
cd $TMP
|
||||||
|
rm -rf $PRGNAM-$VERSION
|
||||||
|
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||||
|
cd $PRGNAM-$VERSION
|
||||||
|
chown -R root:root .
|
||||||
|
find -L . \
|
||||||
|
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||||
|
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||||
|
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||||
|
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||||
|
|
||||||
|
# fix i3-py error message for slackbuilds.org users
|
||||||
|
patch -p1 < $CWD/13_py_message.patch
|
||||||
|
|
||||||
|
python setup.py install --root=$PKG
|
||||||
|
|
||||||
|
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||||
|
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||||
|
|
||||||
|
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
|
cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
|
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||||
|
|
||||||
|
mkdir -p $PKG/install
|
||||||
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||||
|
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||||
|
|
||||||
|
cd $PKG
|
||||||
|
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
|
@ -0,0 +1,10 @@
|
||||||
|
PRGNAM="quickswitch-i3"
|
||||||
|
VERSION="2.1"
|
||||||
|
HOMEPAGE="https://github.com/proxypoke/quickswitch-for-i3"
|
||||||
|
DOWNLOAD="https://pypi.python.org/packages/source/q/quickswitch-i3/quickswitch-i3-2.1.tar.gz"
|
||||||
|
MD5SUM="70a0f15f10720ae71efc64e0ca10b540"
|
||||||
|
DOWNLOAD_x86_64=""
|
||||||
|
MD5SUM_x86_64=""
|
||||||
|
REQUIRES="i3-py"
|
||||||
|
MAINTAINER="Dimitris Zlatanidis"
|
||||||
|
EMAIL="d.zlatanidis@gmail.com"
|
|
@ -0,0 +1,19 @@
|
||||||
|
# HOW TO EDIT THIS FILE:
|
||||||
|
# The "handy ruler" below makes it easier to edit a package description.
|
||||||
|
# Line up the first '|' above the ':' following the base package name, and
|
||||||
|
# the '|' on the right side marks the last column you can put a character in.
|
||||||
|
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||||
|
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||||
|
|
||||||
|
|-----handy-ruler------------------------------------------------------|
|
||||||
|
quickswitch-i3: quickswitch-i3 (utility for i3 wm)
|
||||||
|
quickswitch-i3:
|
||||||
|
quickswitch-i3: This utility for i3, inspired by Pentadactyl's :buffers command,
|
||||||
|
quickswitch-i3: allows you to quickly switch to and locate windows on all your
|
||||||
|
quickswitch-i3: workspaces, using an interactive dmenu prompt. It has since gained
|
||||||
|
quickswitch-i3: a lot of other functionality to make working with i3 even more
|
||||||
|
quickswitch-i3: efficient.
|
||||||
|
quickswitch-i3:
|
||||||
|
quickswitch-i3: Homepage: https://github.com/proxypoke/quickswitch-for-i3
|
||||||
|
quickswitch-i3:
|
||||||
|
quickswitch-i3:
|
Loading…
Reference in New Issue