libraries/CHOLMOD: Updated for version 1.7.3.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
parent
6600559a54
commit
d34b25d836
|
@ -4,7 +4,7 @@
|
|||
# Written by Kyle Guinn <elyk03@gmail.com>
|
||||
|
||||
PRGNAM=CHOLMOD
|
||||
VERSION=${VERSION:-1.7.1}
|
||||
VERSION=${VERSION:-1.7.3}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -38,6 +38,9 @@ else
|
|||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
# Recommended by SuiteSparse
|
||||
SLKCFLAGS="$SLKCFLAGS -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE"
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
|
@ -57,14 +60,17 @@ fi
|
|||
autoreconf -vif
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
FFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--infodir=/usr/info \
|
||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--enable-shared \
|
||||
--disable-static \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="CHOLMOD"
|
||||
VERSION="1.7.1"
|
||||
VERSION="1.7.3"
|
||||
HOMEPAGE="http://www.cise.ufl.edu/research/sparse/cholmod/"
|
||||
DOWNLOAD="http://www.cise.ufl.edu/research/sparse/cholmod/CHOLMOD-1.7.1.tar.gz"
|
||||
MD5SUM="9032c5724bee43ccd8f4546338a29fac"
|
||||
DOWNLOAD="http://www.cise.ufl.edu/research/sparse/cholmod/CHOLMOD-1.7.3.tar.gz"
|
||||
MD5SUM="e3bcfeefe40a2f3ef712e1bd3ec36781"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Kyle Guinn"
|
||||
|
|
|
@ -3,7 +3,7 @@ new file mode 100644
|
|||
--- /dev/null
|
||||
+++ b/Check/Makefile.am
|
||||
@@ -0,0 +1,24 @@
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(UFCONFIG_CFLAGS)
|
||||
+
|
||||
+EXTRA_DIST = \
|
||||
+ License.txt \
|
||||
|
@ -32,7 +32,7 @@ new file mode 100644
|
|||
--- /dev/null
|
||||
+++ b/Cholesky/Makefile.am
|
||||
@@ -0,0 +1,41 @@
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(COLAMD_CFLAGS) $(AMD_CFLAGS) $(UFCONFIG_CFLAGS)
|
||||
+
|
||||
+EXTRA_DIST = \
|
||||
+ License.txt \
|
||||
|
@ -64,11 +64,11 @@ new file mode 100644
|
|||
+ libcholesky.la
|
||||
+
|
||||
+libcholeskyi_la_SOURCES = $(CHOLESKYSRC)
|
||||
+libcholeskyi_la_LIBADD = -lcolamd -lamd -lm
|
||||
+libcholeskyi_la_LIBADD = $(COLAMD_LIBS) $(AMD_LIBS) -lm
|
||||
+libcholeskyi_la_CPPFLAGS = $(AM_CPPFLAGS)
|
||||
+
|
||||
+libcholeskyl_la_SOURCES = $(CHOLESKYSRC)
|
||||
+libcholeskyl_la_LIBADD = -lcolamd -lamd -lm
|
||||
+libcholeskyl_la_LIBADD = $(COLAMD_LIBS) $(AMD_LIBS) -lm
|
||||
+libcholeskyl_la_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
|
||||
+
|
||||
+libcholesky_la_SOURCES =
|
||||
|
@ -78,7 +78,7 @@ new file mode 100644
|
|||
--- /dev/null
|
||||
+++ b/Core/Makefile.am
|
||||
@@ -0,0 +1,43 @@
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(UFCONFIG_CFLAGS)
|
||||
+
|
||||
+EXTRA_DIST = \
|
||||
+ License.txt \
|
||||
|
@ -126,7 +126,7 @@ new file mode 100644
|
|||
--- /dev/null
|
||||
+++ b/Demo/Makefile.am
|
||||
@@ -0,0 +1,51 @@
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(UFCONFIG_CFLAGS)
|
||||
+
|
||||
+EXTRA_DIST = \
|
||||
+ License.txt \
|
||||
|
@ -421,16 +421,18 @@ diff --git a/Include/Makefile.am b/Include/Makefile.am
|
|||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/Include/Makefile.am
|
||||
@@ -0,0 +1,40 @@
|
||||
@@ -0,0 +1,42 @@
|
||||
+EXTRA_DIST = \
|
||||
+ License.txt \
|
||||
+ README.txt
|
||||
+
|
||||
+pkgincludedir = $(includedir)/cholmod
|
||||
+
|
||||
+# Automatically generated headers
|
||||
+nodist_include_HEADERS = \
|
||||
+nodist_pkginclude_HEADERS = \
|
||||
+ cholmod_config.h
|
||||
+
|
||||
+include_HEADERS = \
|
||||
+pkginclude_HEADERS = \
|
||||
+ cholmod.h \
|
||||
+ cholmod_blas.h \
|
||||
+ cholmod_complexity.h \
|
||||
|
@ -440,27 +442,27 @@ new file mode 100644
|
|||
+ cholmod_template.h
|
||||
+
|
||||
+if MOD_CHECK
|
||||
+include_HEADERS += cholmod_check.h
|
||||
+pkginclude_HEADERS += cholmod_check.h
|
||||
+endif
|
||||
+
|
||||
+if MOD_CHOLESKY
|
||||
+include_HEADERS += cholmod_cholesky.h
|
||||
+pkginclude_HEADERS += cholmod_cholesky.h
|
||||
+endif
|
||||
+
|
||||
+if MOD_PARTITION
|
||||
+include_HEADERS += cholmod_partition.h
|
||||
+pkginclude_HEADERS += cholmod_partition.h
|
||||
+endif
|
||||
+
|
||||
+if MOD_MATRIXOPS
|
||||
+include_HEADERS += cholmod_matrixops.h
|
||||
+pkginclude_HEADERS += cholmod_matrixops.h
|
||||
+endif
|
||||
+
|
||||
+if MOD_MODIFY
|
||||
+include_HEADERS += cholmod_modify.h
|
||||
+pkginclude_HEADERS += cholmod_modify.h
|
||||
+endif
|
||||
+
|
||||
+if MOD_SUPERNODAL
|
||||
+include_HEADERS += cholmod_supernodal.h
|
||||
+pkginclude_HEADERS += cholmod_supernodal.h
|
||||
+endif
|
||||
diff --git a/Include/cholmod_config.h b/Include/cholmod_config.h.in
|
||||
rename from Include/cholmod_config.h
|
||||
|
@ -514,15 +516,18 @@ diff --git a/Makefile.am b/Makefile.am
|
|||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/Makefile.am
|
||||
@@ -0,0 +1,40 @@
|
||||
@@ -0,0 +1,43 @@
|
||||
+SUBDIRS = Include Core
|
||||
+EXTRA_DIST = README.txt
|
||||
+
|
||||
+pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfig_DATA = cholmod.pc
|
||||
+
|
||||
+lib_LTLIBRARIES = libcholmod.la
|
||||
+
|
||||
+libcholmod_la_SOURCES =
|
||||
+libcholmod_la_LIBADD = $(top_builddir)/Core/libcore.la
|
||||
+libcholmod_la_LDFLAGS = -no-undefined -version-info 8:1:7
|
||||
+libcholmod_la_LDFLAGS = -no-undefined -version-info 8:3:7
|
||||
+
|
||||
+if MOD_CHECK
|
||||
+SUBDIRS += Check
|
||||
|
@ -560,7 +565,7 @@ new file mode 100644
|
|||
--- /dev/null
|
||||
+++ b/MatrixOps/Makefile.am
|
||||
@@ -0,0 +1,35 @@
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(UFCONFIG_CFLAGS)
|
||||
+
|
||||
+EXTRA_DIST = \
|
||||
+ License.txt \
|
||||
|
@ -600,7 +605,7 @@ new file mode 100644
|
|||
--- /dev/null
|
||||
+++ b/Modify/Makefile.am
|
||||
@@ -0,0 +1,30 @@
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(UFCONFIG_CFLAGS)
|
||||
+
|
||||
+EXTRA_DIST = \
|
||||
+ License.txt \
|
||||
|
@ -635,7 +640,7 @@ new file mode 100644
|
|||
--- /dev/null
|
||||
+++ b/Partition/Makefile.am
|
||||
@@ -0,0 +1,28 @@
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(METIS_CFLAGS)
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(METIS_CFLAGS) $(CCOLAMD_CFLAGS) $(CAMD_CFLAGS) $(UFCONFIG_CFLAGS)
|
||||
+
|
||||
+EXTRA_DIST = \
|
||||
+ License.txt \
|
||||
|
@ -654,11 +659,11 @@ new file mode 100644
|
|||
+ libpartition.la
|
||||
+
|
||||
+libpartitioni_la_SOURCES = $(PARTITIONSRC)
|
||||
+libpartitioni_la_LIBADD = $(METIS_LIBS) -lccolamd -lcamd -lm
|
||||
+libpartitioni_la_LIBADD = $(METIS_LIBS) $(CCOLAMD_LIBS) $(CAMD_LIBS) -lm
|
||||
+libpartitioni_la_CPPFLAGS = $(AM_CPPFLAGS)
|
||||
+
|
||||
+libpartitionl_la_SOURCES = $(PARTITIONSRC)
|
||||
+libpartitionl_la_LIBADD = $(METIS_LIBS) -lccolamd -lcamd -lm
|
||||
+libpartitionl_la_LIBADD = $(METIS_LIBS) $(CCOLAMD_LIBS) $(CAMD_LIBS) -lm
|
||||
+libpartitionl_la_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
|
||||
+
|
||||
+libpartition_la_SOURCES =
|
||||
|
@ -668,7 +673,7 @@ new file mode 100644
|
|||
--- /dev/null
|
||||
+++ b/Supernodal/Makefile.am
|
||||
@@ -0,0 +1,30 @@
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(UFCONFIG_CFLAGS)
|
||||
+
|
||||
+EXTRA_DIST = \
|
||||
+ License.txt \
|
||||
|
@ -1032,13 +1037,30 @@ new file mode 100644
|
|||
+ $2
|
||||
+fi
|
||||
+])dnl ACX_LAPACK
|
||||
diff --git a/cholmod.pc.in b/cholmod.pc.in
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/cholmod.pc.in
|
||||
@@ -0,0 +1,12 @@
|
||||
+prefix=@prefix@
|
||||
+exec_prefix=@exec_prefix@
|
||||
+libdir=@libdir@
|
||||
+includedir=@includedir@
|
||||
+
|
||||
+Name: @PACKAGE_NAME@
|
||||
+Description: Sparse Cholesky factorization
|
||||
+Version: @PACKAGE_VERSION@
|
||||
+Requires.private: @CHOLMOD_REQUIRES@
|
||||
+Libs: -L${libdir} -lcholmod
|
||||
+Libs.private: @LAPACK_LIBS@ @BLAS_LIBS@ -lm
|
||||
+Cflags: -I${includedir}/cholmod
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/configure.ac
|
||||
@@ -0,0 +1,179 @@
|
||||
+AC_PREREQ([2.65])
|
||||
+AC_INIT([CHOLMOD], [1.7.1], [davis@cise.ufl.edu])
|
||||
@@ -0,0 +1,177 @@
|
||||
+AC_PREREQ([2.68])
|
||||
+AC_INIT([CHOLMOD],[1.7.3],[davis@cise.ufl.edu])
|
||||
+AC_CONFIG_SRCDIR([Core/cholmod_common.c])
|
||||
+AC_CONFIG_HEADER([config.h])
|
||||
+AM_INIT_AUTOMAKE([foreign])
|
||||
|
@ -1136,38 +1158,36 @@ new file mode 100644
|
|||
+
|
||||
+AC_CHECK_LIB([m], [sqrt])
|
||||
+
|
||||
+if test "x$mod_cholesky" = "xyes"; then
|
||||
+ AC_CHECK_HEADERS([amd.h])
|
||||
+ AC_CHECK_LIB([amd], [amd_info],
|
||||
+ [],
|
||||
+ [AC_MSG_ERROR([cannot find libamd (required by mod-cholesky)])])
|
||||
+AC_CHECK_HEADERS([stddef.h stdlib.h string.h])
|
||||
+
|
||||
+ AC_CHECK_HEADERS([colamd.h])
|
||||
+ AC_CHECK_LIB([colamd], [colamd_recommended],
|
||||
+ [],
|
||||
+ [AC_MSG_ERROR([cannot find libcolamd (required by mod-cholesky)])])
|
||||
+PKG_PROG_PKG_CONFIG
|
||||
+PKG_CHECK_MODULES([UFCONFIG],[ufconfig],
|
||||
+ [],
|
||||
+ [AC_MSG_ERROR([cannot find ufconfig])])
|
||||
+CHOLMOD_REQUIRES="ufconfig"
|
||||
+
|
||||
+if test "x$mod_cholesky" = "xyes"; then
|
||||
+ PKG_CHECK_MODULES([AMD],[amd],
|
||||
+ [CHOLMOD_REQUIRES="$CHOLMOD_REQUIRES amd"],
|
||||
+ [AC_MSG_ERROR([cannot find amd (required by mod-cholesky)])])
|
||||
+
|
||||
+ PKG_CHECK_MODULES([COLAMD],[colamd],
|
||||
+ [CHOLMOD_REQUIRES="$CHOLMOD_REQUIRES colamd"],
|
||||
+ [AC_MSG_ERROR([cannot find colamd (required by mod-cholesky)])])
|
||||
+fi
|
||||
+
|
||||
+if test "x$mod_partition" = "xyes"; then
|
||||
+ PKG_PROG_PKG_CONFIG
|
||||
+ if test -n "$PKG_CONFIG"; then
|
||||
+ PKG_CHECK_MODULES([METIS], [metis])
|
||||
+ else
|
||||
+ AC_CHECK_HEADERS([metis.h])
|
||||
+ AC_CHECK_LIB([metis], [METIS_NodeND],
|
||||
+ [METIS_LIBS=-lmetis],
|
||||
+ [AC_MSG_ERROR([cannot find libmetis (required by mod-partition)])])
|
||||
+ fi
|
||||
+ PKG_CHECK_MODULES([METIS],[metis],
|
||||
+ [CHOLMOD_REQUIRES="$CHOLMOD_REQUIRES metis"],
|
||||
+ [AC_MSG_ERROR([cannot find metis (required by mod-partition)])])
|
||||
+
|
||||
+ AC_CHECK_HEADERS([ccolamd.h])
|
||||
+ AC_CHECK_LIB([ccolamd], [ccolamd_report],
|
||||
+ [],
|
||||
+ [AC_MSG_ERROR([cannot find libccolamd (required by mod-partition)])])
|
||||
+PKG_CHECK_MODULES([CAMD],[camd],
|
||||
+ [CHOLMOD_REQUIRES="$CHOLMOD_REQUIRES camd"],
|
||||
+ [AC_MSG_ERROR([cannot find camd (required by mod-partition)])])
|
||||
+
|
||||
+ AC_CHECK_HEADERS([camd.h])
|
||||
+ AC_CHECK_LIB([camd], [camd_info],
|
||||
+ [],
|
||||
+ [AC_MSG_ERROR([cannot find libcamd (required by mod-partition)])])
|
||||
+PKG_CHECK_MODULES([CCOLAMD],[ccolamd],
|
||||
+ [CHOLMOD_REQUIRES="$CHOLMOD_REQUIRES ccolamd"],
|
||||
+ [AC_MSG_ERROR([cannot find ccolamd (required by mod-partition)])])
|
||||
+fi
|
||||
+
|
||||
+if test "x$mod_supernodal" = "xyes"; then
|
||||
|
@ -1184,9 +1204,6 @@ new file mode 100644
|
|||
+ fi
|
||||
+fi
|
||||
+
|
||||
+AC_CHECK_HEADERS([stddef.h stdlib.h string.h])
|
||||
+AC_CHECK_HEADERS([UFconfig.h])
|
||||
+
|
||||
+AC_TYPE_SIZE_T
|
||||
+
|
||||
+AC_FUNC_MALLOC
|
||||
|
@ -1201,7 +1218,10 @@ new file mode 100644
|
|||
+AM_CONDITIONAL([MOD_MODIFY], [test "x$mod_modify" = "xyes"])
|
||||
+AM_CONDITIONAL([MOD_SUPERNODAL], [test "x$mod_supernodal" = "xyes"])
|
||||
+
|
||||
+AC_SUBST([CHOLMOD_REQUIRES])
|
||||
+
|
||||
+AC_CONFIG_FILES([
|
||||
+ cholmod.pc
|
||||
+ Makefile
|
||||
+ Check/Makefile
|
||||
+ Cholesky/Makefile
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
CHOLMOD: CHOLMOD (sparse matrix factorizing routines)
|
||||
CHOLMOD: CHOLMOD (sparse matrix factoring routines)
|
||||
CHOLMOD:
|
||||
CHOLMOD: CHOLMOD is a set of ANSI C routines for sparse Cholesky
|
||||
CHOLMOD: factorization and update/downdate.
|
||||
|
|
Loading…
Reference in New Issue