ham/xwxapt: Added (GTK+ weather satellite image decoder).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
aebf0a606c
commit
d13e718fb0
|
@ -0,0 +1,16 @@
|
|||
--- Makefile.in 2013-10-08 07:33:03.000000000 -0500
|
||||
+++ Makefile.in.fixed 2014-07-13 15:33:30.471310610 -0500
|
||||
@@ -820,13 +820,6 @@
|
||||
done \
|
||||
fi
|
||||
|
||||
- if test -d $(HOME)/$(PACKAGE); then \
|
||||
- echo Working directory exists: $(HOME)/$(PACKAGE) - not copying; \
|
||||
- else \
|
||||
- echo Copying $(PACKAGE) working directory to $(HOME)/$(PACKAGE); \
|
||||
- cp -r $(srcdir)/$(PACKAGE) $(HOME); \
|
||||
- fi
|
||||
-
|
||||
dist-hook:
|
||||
if test -d pixmaps; then \
|
||||
mkdir $(distdir)/pixmaps; \
|
|
@ -0,0 +1,10 @@
|
|||
xwxapt is a GTK+ graphical version of wxapt. It uses the same decoding
|
||||
engine as wxapt but it displays APT images at half-size as they are
|
||||
received, storing the full-sized files when reception is completed.
|
||||
It also displays some status information (audio level, sync level,
|
||||
sync status etc) and text messages as it runs.
|
||||
|
||||
By default, xwxapt wants to create a directory in the home directory
|
||||
of the installing user. The SlackBuild disables that, but the directory
|
||||
structure including config file has been made availabe in
|
||||
/usr/share/xwxapt-$VERSION
|
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
xwxapt: xwxapt (GTK+ weather satellite image decoder)
|
||||
xwxapt:
|
||||
xwxapt: xwxapt is a GTK+ version of wxapt, a program for decoding and saving
|
||||
xwxapt: weather images transmitted in the APT format of NOAA and METEOR
|
||||
xwxapt: satellites.
|
||||
xwxapt:
|
||||
xwxapt:
|
||||
xwxapt:
|
||||
xwxapt:
|
||||
xwxapt: Homepage: http://www.qsl.net/5b4az/
|
||||
xwxapt:
|
|
@ -0,0 +1,103 @@
|
|||
#!/bin/sh
|
||||
# Slackbuild for xwxapt
|
||||
# Written by JK Wood <joshuakwood@gmail.com>
|
||||
|
||||
# Slackbuild is released under the Dog-on-Fire License:
|
||||
# If use of this script causes your dog to catch on fire,
|
||||
# you agree to send me five dollars. Or a picture
|
||||
# of the dog on fire.
|
||||
# Otherwise, you're on your own. I've tested the script
|
||||
# on my own computer, and it hasn't broken anything.
|
||||
# So if it does it on your computer, that falls in
|
||||
# the realm of "Not my problem."
|
||||
#
|
||||
# Of course, if you'll send a bug report to the above
|
||||
# email address, I may be able to see what you did
|
||||
# wrong and prevent it from happening in the future.
|
||||
# In which case, I may just send YOU five dollars.
|
||||
|
||||
# Oh, and feel free to copy it and modify it as you
|
||||
# see fit. Or as I see fit. Or as I fit. Although
|
||||
# that is unlikely, as I am rather tall.
|
||||
|
||||
PRGNAM=xwxapt
|
||||
VERSION=${VERSION:-2.3}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar -xvf $CWD/$PRGNAM-$VERSION.tar.bz2
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Fix Makefile putting directory in /root
|
||||
patch -p0 < $CWD/Makefile.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--mandir=/usr/man \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
mkdir -p $PKG/usr/share/$PRGNAM-$VERSION/xwxapt/images
|
||||
mkdir -p $PKG/usr/share/$PRGNAM-$VERSION/xwxapt/record
|
||||
install -m 644 xwxapt/xwxaptrc $PKG/usr/share/$PRGNAM-$VERSION/xwxapt/
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a AUTHORS COPYING ChangeLog INSTALL NEWS README doc/* $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
find $PKG/usr/doc -name "Makefile" -exec rm {} \;
|
||||
find $PKG/usr/doc -type f -exec chmod 644 {} \;
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG${PKGTYPE:-.tgz}
|
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="xwxapt"
|
||||
VERSION="2.3"
|
||||
HOMEPAGE="http://www.qsl.net/5b4az/"
|
||||
DOWNLOAD="http://www.qsl.net/5b4az/pkg/apt/xwxapt/xwxapt-2.3.tar.bz2"
|
||||
MD5SUM="36fb2747138d5a600bb685c2f4679662"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
MAINTAINER="JK Wood"
|
||||
EMAIL="joshuakwood@gmail.com"
|
Loading…
Reference in New Issue