system/I-Nex: Updated for version 7.6.1.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Cristiano Urban 2019-12-15 09:30:59 +07:00 committed by Willy Sudiarto Raharjo
parent 7d150591f8
commit d05f7c0f65
No known key found for this signature in database
GPG Key ID: 887B8374D7333381
3 changed files with 4 additions and 30 deletions

View File

@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=I-Nex
VERSION=${VERSION:-7.6.0}
VERSION=${VERSION:-7.6.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -69,11 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
sed -i 's|python3$|python2|' pastebinit
sed -i -e 's|^STATIC.*|STATIC = false|' i-nex.mk
patch -p1 -i $CWD/I-Nex_fix.patch
cd $PRGNAM
autoreconf --install

View File

@ -1,8 +1,8 @@
PRGNAM="I-Nex"
VERSION="7.6.0"
VERSION="7.6.1"
HOMEPAGE="https://github.com/eloaders/I-Nex"
DOWNLOAD="https://github.com/i-nex/I-Nex/archive/7.6.0/I-Nex-7.6.0.tar.gz"
MD5SUM="4fd4686e860b7dc47c8baccce5764d3b"
DOWNLOAD="https://github.com/i-nex/I-Nex/archive/7.6.1/I-Nex-7.6.1.tar.gz"
MD5SUM="03c2622075c15f24b3b3fa5dd7cf3597"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="qt5 gambas3 libcpuid"

View File

@ -1,23 +0,0 @@
--- a/I-Nex/i-nex/.src/Finfosys.class 2019-09-28 17:03:37.613473723 +0200
+++ b/I-Nex/i-nex/.src/Finfosys.class 2019-09-28 17:04:45.017472516 +0200
@@ -322,6 +322,7 @@
Public Sub System()
Dim hostname, arch, gcc, timezone, xorg_version, glx_version As String
Dim SCREENFETCH_P As Process
+ Dim sLine2 As String
SCREENFETCH_P = Exec ["" & ChkPrm.ChkExecDir("bash") & ""] For Write
Write #SCREENFETCH_P, File.Load("Data/screenfetch-dev")
SCREENFETCH_P.Wait
@@ -332,9 +333,9 @@
Shell "timedatectl status | grep \"Time zone:\" | cut -d \":\" -f 2 | cut -d \"(\" -f 1" Wait To timezone
Endif
'Detect heap size
- For Each sLine In Split(File.Load("/proc/self/maps"), "\n")
- If InStr(sLine, "[heap]") Then
- aScan = Scan(sLine, "*-* *")
+ For Each sLine2 In Split(File.Load("/proc/self/maps"), "\n")
+ If InStr(sLine2, "[heap]") Then
+ aScan = Scan(sLine2, "*-* *")
Label176.Text = "Heap size is " & Format(Val("&H" & aScan[1] & "&") - Val("&H" & aScan[0] & "&"), "#,##0") & " bytes."
Break
Endif