desktop/nwg-panel: Added (GTK Wayland-based panel)

Signed-off-by: bedlam <dave@slackbuilds.org>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Jay Lanagan 2023-03-03 23:05:33 +00:00 committed by Willy Sudiarto Raharjo
parent 1964672dad
commit ca6365cd03
No known key found for this signature in database
GPG Key ID: 3F617144D7238786
6 changed files with 166 additions and 0 deletions

4
desktop/nwg-panel/README Normal file
View File

@ -0,0 +1,4 @@
nwg-panel (gtk wayland based panel)
Combining features of Waybar and tint2, nwg-panel has a total of
12 modules for desktop settings configuration for the nwg-shell.

View File

@ -0,0 +1,3 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi

View File

@ -0,0 +1,17 @@
--- a/nwg_panel/config/config
+++ b/nwg_panel/config/config
@@ -64,11 +64,11 @@
},
{
"name": "Reboot",
- "cmd": "systemctl reboot"
+ "cmd": "loginctl reboot"
},
{
"name": "Shutdown",
- "cmd": "systemctl -i poweroff"
+ "cmd": "loginctl poweroff"
}
]
}

View File

@ -0,0 +1,113 @@
#!/bin/bash
# Slackware build script for nwg-panel
# Copyright 2023 Jay Lanagan (j@lngn.net), Detroit, MI, USA.
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=nwg-panel
VERSION=${VERSION:-0.7.17}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
elif [ "$ARCH" = "aarch64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/v$VERSION.tar.?z || tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
cd $PRGNAM-$VERSION
# fix reboot/shutdown options in menu
patch -Np1 -i $CWD/loginctl.patch || exit 1
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python3 setup.py install --optimize=1 --root=$PKG
chmod 644 *.svg *.desktop
mkdir -p /$PKG/usr/share/{pixmaps,applications}
cp nwg-panel.svg $PKG/usr/share/pixmaps
cp nwg-shell.svg $PKG/usr/share/pixmaps
cp nwg-panel-config.desktop $PKG/usr/share/applications
cp nwg-processes.svg $PKG/usr/share/pixmaps/
cp nwg-processes.desktop $PKG/usr/share/applications/
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/*.la
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CONTRIBUTING.md LICENSE README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE

View File

@ -0,0 +1,10 @@
PRGNAM="nwg-panel"
VERSION="0.7.17"
HOMEPAGE="https://github.com/nwg-piotr/nwg-panel/"
DOWNLOAD="https://github.com/nwg-piotr/nwg-panel/archive/v0.7.17/nwg-panel-0.7.17.tar.gz"
MD5SUM="5300a9df07a16f01d3aab1dc831a6207"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="gtk-layer-shell nwg-icon-picker playerctl python3-psutil i3ipc python3-dasbus python3-netifaces wheel SwayNotificationCenter wlr-randr"
MAINTAINER="Jay Lanagan"
EMAIL="j@lngn.net"

View File

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
nwg-panel: nwg-panel (GTK Wayland-based panel)
nwg-panel:
nwg-panel: Combining features of Waybar and tint2, nwg-panel has a total of
nwg-panel: 12 modules for desktop settings configuration for the nwg-shell.
nwg-panel:
nwg-panel: Homepage: https://github.com/nwg-piotr/nwg-panel
nwg-panel:
nwg-panel:
nwg-panel:
nwg-panel:
nwg-panel: