libraries/podofo: Updated for version 0.9.2.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
82e4fd9180
commit
c8a8350369
|
@ -1,11 +0,0 @@
|
|||
diff -up podofo-0.9.1/test/unit/TestUtils.cpp.unistd podofo-0.9.1/test/unit/TestUtils.cpp
|
||||
--- podofo-0.9.1/test/unit/TestUtils.cpp.unistd 2012-01-16 18:12:52.000000000 +0100
|
||||
+++ podofo-0.9.1/test/unit/TestUtils.cpp 2012-01-16 18:13:00.000000000 +0100
|
||||
@@ -23,6 +23,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
+#include <unistd.h>
|
||||
|
||||
#if defined(_WIN32) || defined(_WIN64)
|
||||
#include <windows.h>
|
|
@ -2,11 +2,29 @@
|
|||
|
||||
# Slackware build script for podofo
|
||||
|
||||
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
# Copyright 2009-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=podofo
|
||||
VERSION=0.9.1
|
||||
BUILD=${BUILD:-2}
|
||||
VERSION=${VERSION:-0.9.2}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
CWD=$(pwd)
|
||||
|
@ -53,10 +71,8 @@ find . \
|
|||
|
||||
# Fix mandir directory.
|
||||
sed -i 's|share/man|man|' CMakeLists.txt
|
||||
|
||||
# Fix building with gcc-4.7.x
|
||||
# http://sourceforge.net/tracker/?func=detail&aid=3474494&group_id=154028&atid=790130
|
||||
patch -p1 < $CWD/podofo-0.9.1-unistd.patch
|
||||
# Remove innocuous build warning for zlib.
|
||||
rm -f cmake/modules/FindZLIB.cmake
|
||||
|
||||
mkdir build
|
||||
cd build
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="podofo"
|
||||
VERSION="0.9.1"
|
||||
VERSION="0.9.2"
|
||||
HOMEPAGE="http://podofo.sourceforge.net/"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/podofo/podofo-0.9.1.tar.gz"
|
||||
MD5SUM="cec586ab69f92bc88d38b5d4b8eee5a0"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/podofo/podofo-0.9.2.tar.gz"
|
||||
MD5SUM="41966c57fa4266ac5cef80bfade0c8e7"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
Loading…
Reference in New Issue