desktop/avant-window-navigator: Updated for version 0.4.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
6e96506222
commit
c79906a54e
|
@ -7,3 +7,6 @@ applets.
|
|||
In order to handle transparencies that this application makes use of, you
|
||||
MUST use a composite desktop manager and, of course, enable compositing.
|
||||
Both KDE and XFCE from Slackware distro are composite capable.
|
||||
|
||||
NOTE:
|
||||
The prefences applet crashes on startup, this is a known issue.
|
||||
|
|
|
@ -2,30 +2,30 @@
|
|||
|
||||
# Slackware build script for avant-window-navigator
|
||||
|
||||
# Copyright (c) 2010 Roberto Metere. All rights reserved.
|
||||
# Copyright (c) 2010 Roberto Metere.
|
||||
# Currently maintained by Ryan P.C. McQuen, WA, ryan.q@linux.com
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use in source and binary forms, with or without
|
||||
# modification, are permitted provided that the following conditions are
|
||||
# met:
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# * Redistributions of source code must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
|
||||
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
|
||||
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
|
||||
# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
|
||||
# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
|
||||
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
|
||||
# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
|
||||
# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
|
||||
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
|
||||
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=avant-window-navigator
|
||||
VERSION=0.4.0
|
||||
BUILD=${BUILD:-4}
|
||||
VERSION=${VERSION:-0.4.2}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -65,13 +65,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
|||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Fix underlinking.
|
||||
patch -p1 -i $CWD/dso.patch
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Configure
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
|
@ -82,28 +79,15 @@ CXXFLAGS="$SLKCFLAGS" \
|
|||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--enable-static=yes \
|
||||
--enable-static=no \
|
||||
--enable-gtk-doc \
|
||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
# Some error on 64 bit system which I cannot handle in other way
|
||||
if [ "$ARCH" = "x86_64" ]; then
|
||||
MAKEFILES=$(ls -1 */*/Makefile */Makefile Makefile)
|
||||
for i in $MAKEFILES
|
||||
do
|
||||
printf "Fixing \"$i\"... "
|
||||
cat $i | sed "s/\/lib\ /\/lib${LIBDIRSUFFIX}\ /g" > $i.new
|
||||
mv $i.new $i
|
||||
printf "done.\n"
|
||||
done
|
||||
fi
|
||||
|
||||
# Build and install
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="avant-window-navigator"
|
||||
VERSION="0.4.0"
|
||||
VERSION="0.4.2"
|
||||
HOMEPAGE="https://launchpad.net/awn"
|
||||
DOWNLOAD="http://launchpad.net/awn/0.4/0.4.0/+download/avant-window-navigator-0.4.0.tar.gz"
|
||||
MD5SUM="03654b45dd95cbb83fa7e112bd00523c"
|
||||
DOWNLOAD="https://launchpad.net/awn/0.4/0.4.2/+download/avant-window-navigator-0.4.2.tar.gz"
|
||||
MD5SUM="df3bd413de19bdda461df7ed4f9e2409"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="bzr libdesktop-agnostic libgtop pyxdg"
|
||||
MAINTAINER="Roberto Metere"
|
||||
EMAIL="roberto{at}metere{dot}it"
|
||||
REQUIRES="libdesktop-agnostic pyxdg gtkmm libgtop"
|
||||
MAINTAINER="Ryan P.C. McQuen"
|
||||
EMAIL="ryan.q@linux.com"
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
--- avant-window-navigator-0.4.0.orig/configure 2010-04-11 15:29:20.000000000 +0100
|
||||
+++ avant-window-navigator-0.4.0/configure 2010-04-12 17:24:42.000000000 +0100
|
||||
@@ -13993,7 +13993,7 @@ fi
|
||||
|
||||
|
||||
LIBRARY_MODULES="glib-2.0 >= $MIN_GLIB_VERSION gthread-2.0 gobject-2.0 desktop-agnostic >= $MIN_LDA_VERSION gtk+-2.0 >= $MIN_GTK_VERSION gdk-2.0 >= $MIN_GTK_VERSION dbus-glib-1"
|
||||
-DOCK_MODULES="x11 xproto xcomposite xrender xext"
|
||||
+DOCK_MODULES="x11 xproto xcomposite xrender xext desktop-agnostic gtk+-2.0 dbus-glib-1"
|
||||
TASKMANAGER_MODULES="libwnck-1.0 >= $MIN_WNCK_VERSION x11 libgtop-2.0 xext"
|
||||
|
||||
|
||||
--- avant-window-navigator-0.4.0.orig/tests/Makefile.in 2010-04-11 15:29:23.000000000 +0100
|
||||
+++ avant-window-navigator-0.4.0/tests/Makefile.in 2010-04-12 21:24:56.000000000 +0100
|
||||
@@ -179,7 +179,7 @@ LD = @LD@
|
||||
LDA_BINDIR = @LDA_BINDIR@
|
||||
LDA_DEFSDIR = @LDA_DEFSDIR@
|
||||
LDA_VAPIDIR = @LDA_VAPIDIR@
|
||||
-LDFLAGS = @LDFLAGS@
|
||||
+LDFLAGS = @LDFLAGS@ -lglib-2.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -lgdk_pixbuf-2.0 -lcairo -lgobject-2.0
|
||||
LIBAPPLETDIR = @LIBAPPLETDIR@
|
||||
LIBDIR = @LIBDIR@
|
||||
LIBOBJS = @LIBOBJS@
|
Loading…
Reference in New Issue