network/guacamole-server: Removed.

Signed-off-by: Dave Woodfall <dave@slackbuilds.org>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Dave Woodfall 2022-02-28 07:24:07 +00:00 committed by Willy Sudiarto Raharjo
parent e122832496
commit c4c5f91d90
No known key found for this signature in database
GPG Key ID: 3F617144D7238786
7 changed files with 0 additions and 261 deletions

View File

@ -1,7 +0,0 @@
guacamole-server - Guacamole server
guacamole-server contains all the native, server-side components
required by Guacamole to connect to remote desktops. It provides
a common C library, libguac, which all other native components
depend on, as well as separate libraries for each supported
protocol, and guacd, the heart of Guacamole.

View File

@ -1,22 +0,0 @@
config() {
NEW="$1"
OLD="$(dirname $NEW)/$(basename $NEW .new)"
if [ ! -r $OLD ]; then
mv $NEW $OLD
elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
rm $NEW
fi
}
preserve_perms() {
NEW="$1"
OLD="$(dirname $NEW)/$(basename $NEW .new)"
if [ -e $OLD ]; then
cp -a $OLD ${NEW}.incoming
cat $NEW > ${NEW}.incoming
mv ${NEW}.incoming $NEW
fi
config $NEW
}
preserve_perms etc/rc.d/rc.guacd.new

View File

@ -1,119 +0,0 @@
#!/bin/bash
# Slackware build script for guacamole-server
# Copyright 2015-2020 Zhu Qun-Ying
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=guacamole-server
VERSION=${VERSION:-1.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
SRC_DIR=$PRGNAM-$VERSION
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRC_DIR
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $SRC_DIR
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# use system uuid library from util-linux instead of OSSP uuid
for file in $CWD/patch/* ; do
patch -p1 < $file
done
autoreconf -fi
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--with-init-dir=/etc/rc.d \
--localstatedir=/var \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--enable-static=no \
--build=$ARCH-slackware-linux
make
make install-strip DESTDIR=$PKG
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README LICENSE NOTICE CONTRIBUTING $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
mv $PKG/etc/rc.d/guacd $PKG/etc/rc.d/rc.guacd.new
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE

View File

@ -1,10 +0,0 @@
PRGNAM="guacamole-server"
VERSION="1.1.0"
HOMEPAGE="http://guacamole.apache.org/"
DOWNLOAD="https://github.com/apache/guacamole-server/archive/1.1.0/guacamole-server-1.1.0.tar.gz"
MD5SUM="089cdb864d5d0d196312eaee889a02cf"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libtelnet"
MAINTAINER="Zhu Qun-Ying"
EMAIL="zhu.qunying@gmail.com"

View File

@ -1,11 +0,0 @@
--- guacamole-server-0.9.14/src/terminal/terminal/typescript.h 2018-01-01 13:23:37.000000000 -0800
+++ guacamole-server-0.9.14-new/src/terminal/terminal/typescript.h 2018-01-26 17:11:22.180187667 -0800
@@ -97,7 +97,7 @@
* The full path to the file which will contain the timing information for
* this typescript.
*/
- char timing_filename[GUAC_TERMINAL_TYPESCRIPT_MAX_NAME_LENGTH];
+ char timing_filename[GUAC_TERMINAL_TYPESCRIPT_MAX_NAME_LENGTH + sizeof(GUAC_TERMINAL_TYPESCRIPT_TIMING_SUFFIX) + 1];
/**
* The file descriptor of the file into which raw terminal output should be

View File

@ -1,73 +0,0 @@
--- guacamole-server-0.9.8/configure.ac 2015-09-04 17:36:05.000000000 -0700
+++ guacamole-server-0.9.8.new/configure.ac 2015-11-27 16:36:00.229847035 -0800
@@ -68,19 +68,25 @@
# OSSP UUID
AC_CHECK_LIB([ossp-uuid], [uuid_make], [UUID_LIBS=-lossp-uuid],
- AC_CHECK_LIB([uuid], [uuid_make], [UUID_LIBS=-luuid],
+ AC_CHECK_LIB([uuid], [uuid_generate], [UUID_LIBS=-luuid],
AC_MSG_ERROR("The OSSP UUID library is required")))
# Check for and validate OSSP uuid.h header
-AC_CHECK_HEADERS([ossp/uuid.h])
-AC_CHECK_DECL([uuid_make],,
- AC_MSG_ERROR("No OSSP uuid.h found in include path"),
+AC_CHECK_HEADERS([ossp/uuid.h], [uuid/uuid.h])
+AC_CHECK_DECL([uuid_make],, ,
[#ifdef HAVE_OSSP_UUID_H
#include <ossp/uuid.h>
#else
#include <uuid.h>
#endif
])
+AC_CHECK_DECL([uuid_generate],, ,
+ [#ifdef HAVE_OSSP_UUID_H
+ #include <ossp/uuid.h>
+ #else
+ #include <uuid/uuid.h>
+ #endif
+ ])
# cunit
AC_CHECK_LIB([cunit], [CU_run_test], [CUNIT_LIBS=-lcunit])
--- incubator-guacamole-server-0.9.10-incubating/src/libguac/id.c 2016-12-18 10:44:24.000000000 -0800
+++ incubator-guacamole-server-0.9.10-incubating.new/src/libguac/id.c 2017-01-20 14:48:45.273476934 -0800
@@ -25,7 +25,7 @@
#ifdef HAVE_OSSP_UUID_H
#include <ossp/uuid.h>
#else
-#include <uuid.h>
+#include <uuid/uuid.h>
#endif
#include <stdlib.h>
@@ -34,6 +34,7 @@
char* buffer;
char* identifier;
+#ifdef HAVE_OSSP_UUID_H
size_t identifier_length;
uuid_t* uuid;
@@ -75,6 +76,21 @@
}
uuid_destroy(uuid);
+#else
+ uuid_t uuid;
+#define UUID_LEN_STR 36
+
+ buffer = malloc (UUID_LEN_STR + 2);
+ if (buffer == NULL) {
+ guac_error = GUAC_STATUS_NO_MEMORY;
+ guac_error_message = "Could not allocate memory for connection ID";
+ return NULL;
+ }
+ identifier = buffer + 1;
+
+ uuid_generate (uuid);
+ uuid_unparse (uuid, identifier);
+#endif
buffer[0] = prefix;
buffer[UUID_LEN_STR + 1] = '\0';

View File

@ -1,19 +0,0 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
guacamole-server: guacamole-server (Guacamole server)
guacamole-server:
guacamole-server: guacamole-server contains all the native, server-side
guacamole-server: components required by Guacamole to connect to remote
guacamole-server: desktops. It provides a common C library, libguac, which all
guacamole-server: other native components depend on, as well as separate
guacamole-server: libraries for each supported protocol, and guacd, the heart
guacamole-server: of Guacamole.
guacamole-server:
guacamole-server: http://guacamole.apache.org/
guacamole-server: