network/ssvnc: Added (Adds encryption/security to VNC connections).

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Wayne Cuddy 2014-01-26 08:21:47 +07:00 committed by Erik Hanson
parent 9a15b1639f
commit c357f39a0e
6 changed files with 177 additions and 0 deletions

View File

@ -0,0 +1,20 @@
--- ssvnc-1.0.30/Makefile.orig 2014-01-26 08:11:30.168836072 +0700
+++ ssvnc-1.0.30/Makefile 2014-01-26 08:12:03.465391347 +0700
@@ -24,7 +24,7 @@
PREFIX ?= /usr/local
ROOT ?=
BIN = bin
-LIB = lib/ssvnc
+LIB ?= lib/ssvnc
MAN = man
MANDIR ?= $(MAN)
APPS ?= share/applications
@@ -32,7 +32,7 @@
VSRC = vnc_unixsrc
-JSRC = ultraftp
+JSRC ?= ultraftp
PSRC = vncstorepw
VIEWER = $(VSRC)/vncviewer/vncviewer

29
network/ssvnc/README Normal file
View File

@ -0,0 +1,29 @@
The Enhanced TightVNC Viewer, SSVNC, adds encryption security to VNC
connections.
The package provides a GUI for Windows, Mac OS X, and Unix that
automatically starts up an STUNNEL SSL tunnel for SSL or ssh/plink for
SSH connections to any VNC server, such as x11vnc, and then launches the
VNC Viewer to use the encrypted tunnel.
The x11vnc server has built-in SSL support, however SSVNC can make SSL
encrypted VNC connections to any VNC Server if they are running an SSL
tunnel, such as STUNNEL or socat, at their end. SSVNC's SSH tunnel will
work to any VNC Server host running sshd that you can log into.
The SSVNC Unix vncviewer can also be run without the SSVNC encryption
GUI as an enhanced replacement for the xvncviewer, xtightvncviewer,
etc., viewers.
In addition to normal SSL, SSVNC also supports the VeNCrypt SSL/TLS and
Vino/ANONTLS encryption extensions to VNC on Unix, Mac OS X, and
Windows. Via the provided SSVNC VeNCrypt bridge, VeNCrypt and ANONTLS
encryption also works with any third party VNC Viewer (e.g. RealVNC,
TightVNC, UltraVNC, etc...) you select via 'Change VNC Viewer'.
There is a simplified SSH-Only mode (sshvnc). And an even more
simplified Terminal-Services mode (tsvnc) for use with x11vnc on the
remote side.
Note:
Use "su -" instead of regular "su" to build this package

3
network/ssvnc/doinst.sh Normal file
View File

@ -0,0 +1,3 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi

20
network/ssvnc/slack-desc Normal file
View File

@ -0,0 +1,20 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
ssvnc: ssvnc (Adds encryption/security to VNC connections)
ssvnc:
ssvnc: The package provides a GUI for Windows, Mac OS X, and Unix that
ssvnc: automatically starts up an STUNNEL SSL tunnel for SSL or ssh/plink
ssvnc: for SSH connections to any VNC server, such as x11vnc, and then
ssvnc: launches the VNC Viewer to use the encrypted tunnel.
ssvnc: The package also includes an enhanced TightVNCViewer.
ssvnc:
ssvnc:
ssvnc:
ssvnc:

View File

@ -0,0 +1,95 @@
#!/bin/sh
# Slackware build script for ssvnc
# Copyright 2014 Wayne Cuddy Fairfax, VA (USA)
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
# modification, are permitted provided that the following conditions are
# met:
#
# * Redistributions of source code must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=ssvnc
VERSION=${VERSION:-1.0.30}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.src.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch < $CWD/Makefile.patch
make config
make all
make ROOT=$PKG PREFIX=/usr install LIB=lib${LIBDIRSUFFIX}/ssvnc
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING README* ReleaseNotes $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

10
network/ssvnc/ssvnc.info Normal file
View File

@ -0,0 +1,10 @@
PRGNAM="ssvnc"
VERSION="1.0.30"
HOMEPAGE="http://www.karlrunge.com/x11vnc/ssvnc.html"
DOWNLOAD="http://ssvnc.sourceforge.net/dev/ssvnc-1.0.30.src.tar.gz"
MD5SUM="33d7c2d22d80ed26803275a9a83ddbb5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="jdk"
MAINTAINER="Wayne Cuddy"
EMAIL="wcuddy@useunix.net"