system/vinterm: Fix icon/desktop installation.
Signed-off-by: B. Watson <yalhcru@gmail.com>
This commit is contained in:
parent
81f58e6dc3
commit
c2137dda00
|
@ -1,3 +1,9 @@
|
|||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
|
||||
fi
|
||||
fi
|
||||
|
|
|
@ -0,0 +1,34 @@
|
|||
diff -Naur vinterm-0.5.0/Makefile vinterm-0.5.0.patched/Makefile
|
||||
--- vinterm-0.5.0/Makefile 2013-08-19 12:34:06.000000000 -0400
|
||||
+++ vinterm-0.5.0.patched/Makefile 2017-03-04 03:15:33.786462685 -0500
|
||||
@@ -86,14 +86,22 @@
|
||||
@echo compiling terminfo data
|
||||
@tic -s data/vinterm.info
|
||||
@echo installing icons
|
||||
- @cp -f icon/icon_16.png /usr/share/icons/hicolor/16x16/apps/vinterm.png
|
||||
- @cp -f icon/icon_22.png /usr/share/icons/hicolor/22x22/apps/vinterm.png
|
||||
- @cp -f icon/icon_32.png /usr/share/icons/hicolor/32x32/apps/vinterm.png
|
||||
- @cp -f icon/icon_48.png /usr/share/icons/hicolor/48x48/apps/vinterm.png
|
||||
- @cp -f icon/icon_64.png /usr/share/icons/hicolor/64x64/apps/vinterm.png
|
||||
- @cp -f icon/icon_128.png /usr/share/icons/hicolor/128x128/apps/vinterm.png
|
||||
- @cp -f icon/icon.svg /usr/share/icons/hicolor/scalable/apps/vinterm.svg
|
||||
- @cp -f data/vinterm.desktop /usr/share/applications
|
||||
+ @mkdir -p ${DESTDIR}/usr/share/icons/hicolor/16x16/apps
|
||||
+ @mkdir -p ${DESTDIR}/usr/share/icons/hicolor/22x22/apps
|
||||
+ @mkdir -p ${DESTDIR}/usr/share/icons/hicolor/32x32/apps
|
||||
+ @mkdir -p ${DESTDIR}/usr/share/icons/hicolor/48x48/apps
|
||||
+ @mkdir -p ${DESTDIR}/usr/share/icons/hicolor/64x64/apps
|
||||
+ @mkdir -p ${DESTDIR}/usr/share/icons/hicolor/128x128/apps
|
||||
+ @mkdir -p ${DESTDIR}/usr/share/icons/hicolor/scalable/apps
|
||||
+ @mkdir -p ${DESTDIR}/usr/share/applications
|
||||
+ @cp -f icon/icon_16.png ${DESTDIR}/usr/share/icons/hicolor/16x16/apps/vinterm.png
|
||||
+ @cp -f icon/icon_22.png ${DESTDIR}/usr/share/icons/hicolor/22x22/apps/vinterm.png
|
||||
+ @cp -f icon/icon_32.png ${DESTDIR}/usr/share/icons/hicolor/32x32/apps/vinterm.png
|
||||
+ @cp -f icon/icon_48.png ${DESTDIR}/usr/share/icons/hicolor/48x48/apps/vinterm.png
|
||||
+ @cp -f icon/icon_64.png ${DESTDIR}/usr/share/icons/hicolor/64x64/apps/vinterm.png
|
||||
+ @cp -f icon/icon_128.png ${DESTDIR}/usr/share/icons/hicolor/128x128/apps/vinterm.png
|
||||
+ @cp -f icon/icon.svg ${DESTDIR}/usr/share/icons/hicolor/scalable/apps/vinterm.svg
|
||||
+ @cp -f data/vinterm.desktop ${DESTDIR}/usr/share/applications
|
||||
|
||||
# TODO - check data
|
||||
uninstall:
|
|
@ -6,9 +6,14 @@
|
|||
|
||||
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
|
||||
|
||||
# 20170304 bkw:
|
||||
# - BUILD=2
|
||||
# - include icons/desktop in the package instead of spamming them
|
||||
# to /usr (!)
|
||||
|
||||
PRGNAM=vinterm
|
||||
VERSION=${VERSION:-0.5.0}
|
||||
BUILD=${BUILD:-1}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -55,6 +60,9 @@ find -L . \
|
|||
|
||||
sed -i -e "s,-Os,$SLKCFLAGS," -e "s,usr/lib,usr/lib$LIBDIRSUFFIX," config.mk
|
||||
|
||||
# GRR. "make install" respects DESTDIR... except for the icons and .desktop.
|
||||
patch -p1 < $CWD/fix_destdir.diff
|
||||
|
||||
export TERMINFO=$PKG/usr/share/terminfo
|
||||
mkdir -p $TERMINFO
|
||||
make all install DEBUG=no DESTDIR=$PKG PREFIX=/usr MANPREFIX=/usr/man
|
||||
|
@ -62,8 +70,7 @@ make all install DEBUG=no DESTDIR=$PKG PREFIX=/usr MANPREFIX=/usr/man
|
|||
# exe already stripped
|
||||
gzip $PKG/usr/man/man1/$PRGNAM.1
|
||||
|
||||
mkdir -p $PKG/usr/share/applications
|
||||
ln -s ../$PRGNAM/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
|
||||
ln -sf ../$PRGNAM/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
|
||||
|
||||
mkdir -p $PKG/usr/share/pixmaps
|
||||
cat icon/icon_128.png > $PKG/usr/share/pixmaps/$PRGNAM.png
|
||||
|
|
Loading…
Reference in New Issue