system/xen: Updated for version 4.3.1.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
69dba3a692
commit
c1e2151736
|
@ -0,0 +1,11 @@
|
|||
--- xen-4.3.1/tools/firmware/Makefile.ORIG 2013-10-30 09:18:28.000000000 +0100
|
||||
+++ xen-4.3.1/tools/firmware/Makefile 2013-11-04 12:28:10.056796654 +0100
|
||||
@@ -18,7 +18,7 @@
|
||||
cp ovmf-makefile ovmf/Makefile;
|
||||
|
||||
seabios-dir:
|
||||
- GIT=$(GIT) $(XEN_ROOT)/scripts/git-checkout.sh $(SEABIOS_UPSTREAM_URL) $(SEABIOS_UPSTREAM_TAG) seabios-dir
|
||||
+# GIT=$(GIT) $(XEN_ROOT)/scripts/git-checkout.sh $(SEABIOS_UPSTREAM_URL) $(SEABIOS_UPSTREAM_TAG) seabios-dir
|
||||
cp seabios-config seabios-dir/.config;
|
||||
|
||||
.PHONY: all
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for xen
|
||||
|
||||
# Copyright 2010-2013, mario <mario@slackverse.org>
|
||||
# Copyright 2010-2013 Mario Preksavec, Zagreb, HR
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -23,7 +23,7 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=xen
|
||||
VERSION=${VERSION:-4.3.0}
|
||||
VERSION=${VERSION:-4.3.1}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -86,7 +86,11 @@ patch -p1 <$CWD/patches/remove_obsolete_udev_rules.diff
|
|||
patch -p1 <$CWD/patches/use_already_present_ipxe.diff
|
||||
cp -a $CWD/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz \
|
||||
tools/firmware/etherboot/_ipxe.tar.gz
|
||||
cp -a $CWD/{lwip,zlib,newlib,pciutils,grub}-*.tar.?z* stubdom
|
||||
patch -p1 <$CWD/patches/use_already_present_seabios.diff
|
||||
tar -xf $CWD/seabios-git-3a28511b46f0c2af5fae1b6ed2b0c19d7913cee3.tar.gz \
|
||||
-C tools/firmware
|
||||
cp -a $CWD/{lwip,zlib,newlib,pciutils,grub,gmp,tpm_emulator}-*.tar.?z* \
|
||||
$CWD/polarssl-*.tgz stubdom
|
||||
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
|
|
|
@ -1,22 +1,30 @@
|
|||
PRGNAM="xen"
|
||||
VERSION="4.3.0"
|
||||
VERSION="4.3.1"
|
||||
HOMEPAGE="http://www.xen.org/"
|
||||
DOWNLOAD="http://bits.xensource.com/oss-xen/release/4.3.0/xen-4.3.0.tar.gz \
|
||||
http://xenbits.xensource.com/xen-extfiles/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz \
|
||||
http://xenbits.xensource.com/xen-extfiles/lwip-1.3.0.tar.gz \
|
||||
http://xenbits.xensource.com/xen-extfiles/zlib-1.2.3.tar.gz \
|
||||
http://xenbits.xensource.com/xen-extfiles/newlib-1.16.0.tar.gz \
|
||||
http://xenbits.xensource.com/xen-extfiles/pciutils-2.2.9.tar.bz2 \
|
||||
http://xenbits.xensource.com/xen-extfiles/grub-0.97.tar.gz"
|
||||
MD5SUM="7b18cfb58f1ac2ce39cf35a1867f0c0a \
|
||||
DOWNLOAD="http://bits.xensource.com/oss-xen/release/4.3.1/xen-4.3.1.tar.gz \
|
||||
http://xenbits.xen.org/xen-extfiles/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz \
|
||||
http://xenbits.xen.org/xen-extfiles/lwip-1.3.0.tar.gz \
|
||||
http://xenbits.xen.org/xen-extfiles/zlib-1.2.3.tar.gz \
|
||||
http://xenbits.xen.org/xen-extfiles/newlib-1.16.0.tar.gz \
|
||||
http://xenbits.xen.org/xen-extfiles/pciutils-2.2.9.tar.bz2 \
|
||||
http://xenbits.xen.org/xen-extfiles/grub-0.97.tar.gz \
|
||||
http://xenbits.xen.org/xen-extfiles/polarssl-1.1.4-gpl.tgz \
|
||||
http://xenbits.xen.org/xen-extfiles/gmp-4.3.2.tar.bz2 \
|
||||
http://xenbits.xen.org/xen-extfiles/tpm_emulator-0.7.4.tar.gz \
|
||||
http://mirror.slackware.hr/sources/xen-extfiles/seabios-git-3a28511b46f0c2af5fae1b6ed2b0c19d7913cee3.tar.gz"
|
||||
MD5SUM="7616b8704e1ab89c81f011f0e3703bc8 \
|
||||
7496268cebf47d5c9ccb0696e3b26065 \
|
||||
36cc57650cffda9a0269493be2a169bb \
|
||||
debc62758716a169df9f62e6ab2bc634 \
|
||||
bf8f1f9e3ca83d732c00a79a6ef29bc4 \
|
||||
cec05e7785497c5e19da2f114b934ffd \
|
||||
cd3f3eb54446be6003156158d51f4884"
|
||||
cd3f3eb54446be6003156158d51f4884 \
|
||||
7b72caf22b01464ee7d6165f2fd85f44 \
|
||||
dd60683d7057917e34630b4a787932e8 \
|
||||
e26becb8a6a2b6695f6b3e8097593db8 \
|
||||
451b0dfc69b48a45841cb10c53f82ddb"
|
||||
REQUIRES="acpica yajl"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="mario"
|
||||
EMAIL="mario@slackverse.org"
|
||||
MAINTAINER="Mario Preksavec"
|
||||
EMAIL="mario at slackware dot hr"
|
||||
|
|
Loading…
Reference in New Issue