libraries/gtkextra: Added (extra widgets for GTK+)

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Niels Horn 2010-12-12 14:03:00 -06:00 committed by Robby Workman
parent 16ba364505
commit bd1ded0654
6 changed files with 158 additions and 0 deletions

View File

@ -0,0 +1,3 @@
GtkExtra is a useful set of widgets for creating GUI's for the Xwindows
system using GTK+. You can use it complementary to GTK+ and it is written
in C. It is also Free Software and released under the LGPL license.

View File

@ -0,0 +1,11 @@
--- gtk+extra-2.1.2_orig/gtkextra/gtkcolorcombo.c 2004-09-16 14:48:05.000000000 -0300
+++ gtk+extra-2.1.2/gtkextra/gtkcolorcombo.c 2010-11-01 00:22:36.000000000 -0200
@@ -146,7 +146,7 @@
GTK_CLASS_TYPE(object_class),
GTK_SIGNAL_OFFSET(GtkColorComboClass,
changed),
- gtkextra_VOID__INT_BOXED,
+ gtkextra_VOID__BOXED_BOXED,
GTK_TYPE_NONE,
2, GTK_TYPE_INT, GDK_TYPE_COLOR);

View File

@ -0,0 +1,92 @@
#!/bin/sh
# Slackware build script for gtkextra
# A set of extra widgets for GTK+
# Written by Niels Horn <niels.horn@gmail.com>
# Revision date: 2010/11/01
PRGNAM=gtkextra
VERSION=${VERSION:-2.1.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
SRCNAM=gtk+extra
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Solve a problem with spaces in gtkextra/Makefile.in
# (This only breaks with make 3.82 from -current, but won't harm in 13.1)
patch -p1 < $CWD/make382.patch
# Resolve a bug in the code (thanks to the Gentoo people for finding it)
patch -p1 < $CWD/gtkcolorcombo.patch
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--build=$ARCH-slackware-linux
make
make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
AUTHORS COPYING ChangeLog INSTALL NEWS README TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View File

@ -0,0 +1,10 @@
PRGNAM="gtkextra"
VERSION="2.1.2"
HOMEPAGE="http://gtkextra.sourceforge.net/"
DOWNLOAD="http://downloads.sourceforge.net/gtkextra/gtk+extra-2.1.2.tar.gz"
MD5SUM="10779394f39d39115fa3fd0f3dea4436"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Niels Horn"
EMAIL="niels.horn@gmail.com"
APPROVED="rworkman"

View File

@ -0,0 +1,23 @@
--- gtk+extra-2.1.2_orig/gtkextra/Makefile.in 2010-03-20 21:05:56.000000000 -0300
+++ gtk+extra-2.1.2/gtkextra/Makefile.in 2010-10-31 23:56:00.000000000 -0200
@@ -1028,13 +1028,14 @@
$(libgtkextra_x11_2_0_la_OBJECTS) $(libgtkextra_linux_fb_2_0_la_OBJECTS) $(libgtkextra_win32_2_0_la_OBJECTS): ${gtkextra_built_public_sources} ${gtkextra_built_private_headers}
$(srcdir)/gtkextra-marshal.h: gtkextra-marshal.list
- ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --header > gtkextra-marshal.tmp \
- && mv gtkextra-marshal.tmp gtkextra-marshal.h ) \
- || ( rm -f gtkextra-marshal.tmp && exit 1 )
+ ( glib-genmarshal --prefix=gtkextra gtkextra-marshal.list --header > gtkextra-marshal.tmp \
+ && mv gtkextra-marshal.tmp gtkextra-marshal.h ) \
+ || ( rm -f gtkextra-marshal.tmp && exit 1 )
+
$(srcdir)/gtkextra-marshal.c: gtkextra-marshal.h
- ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --body > gtkextra-marshal.tmp \
- && mv gtkextra-marshal.tmp gtkextra-marshal.c ) \
- || ( rm -f gtkextra-marshal.tmp && exit 1 )
+ ( glib-genmarshal --prefix=gtkextra gtkextra-marshal.list --body > gtkextra-marshal.tmp \
+ && mv gtkextra-marshal.tmp gtkextra-marshal.c ) \
+ || ( rm -f gtkextra-marshal.tmp && exit 1 )
$(srcdir)/gtkextratypebuiltins.h: $(gtkextra_public_h_sources)
( cd $(srcdir) && glib-mkenums \

View File

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
gtkextra: gtkextra (extra widgets for GTK+)
gtkextra:
gtkextra: GtkExtra is a useful set of widgets for creating GUI's for the
gtkextra: Xwindows system using GTK+. You can use it complementary to GTK+ and
gtkextra: it is written in C. It is also Free Software and released under the
gtkextra: LGPL license.
gtkextra:
gtkextra: Homepage: http://gtkextra.sourceforge.net/
gtkextra:
gtkextra:
gtkextra: