desktop/fvwm3: Updated for version 1.0.2.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Alexander Verbovetsky 2020-12-26 11:31:39 +07:00 committed by Willy Sudiarto Raharjo
parent 12c5fb16be
commit bb2b1f6d91
No known key found for this signature in database
GPG Key ID: 3F617144D7238786
3 changed files with 39 additions and 16 deletions

View File

@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=fvwm3
VERSION=${VERSION:-1.0.1}
BUILD=${BUILD:-2}
VERSION=${VERSION:-1.0.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -63,6 +63,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
patch -p1 < $CWD/update_fvwm_screen-dont_lose_desk_from_StartsOnScreen.patch
sed -i '/^@FVWM_BUILD_GOLANG_TRUE@GOBUILD = $(GOCMD) build/s/$/ -mod=vendor/' \
bin/FvwmPrompt/Makefile.in
@ -127,18 +129,10 @@ zcat $CWD/xinitrc.fvwm3.gz > $PKG/etc/X11/xinit/xinitrc.fvwm3
chmod 755 $PKG/etc/X11/xinit/xinitrc.fvwm3
rm -rf $PKG/usr/share/doc
rm -rf $PKG/usr/share/locale
rm -rf $PKG/usr/bin/fvwm3-convert-2.6
rm -rf $PKG/usr/man/man1/fvwm3-convert-2.6.1.gz
rm -f $PKG/usr/bin/fvwm3-convert-2.6
mv $PKG/usr/bin/FvwmCommand $PKG/usr/bin/Fvwm3Command
mv $PKG/usr/bin/xpmroot $PKG/usr/bin/xpmroot3
mv $PKG/usr/man/man1/xpmroot.1 $PKG/usr/man/man1/xpmroot3.1
for m in $PKG/usr/man/man1/Fvwm* ; do
mv $m ${m/Fvwm/Fvwm3}
done
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@ -146,6 +140,22 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
for m in $PKG/usr/man/man1/Fvwm* ; do
case "$m" in *FvwmPrompt*) continue ;; esac
mv $m ${m/Fvwm/Fvwm3}
done
for m in $PKG/usr/man/man1/fvwm-* ; do
mv $m ${m/fvwm-/fvwm3-}
done
mv $PKG/usr/man/man1/xpmroot.1.gz $PKG/usr/man/man1/xpmroot3.1.gz
rm -f $PKG/usr/man/man1/fvwm3-convert-2.6.1.gz
rm -f $PKG/usr/man/man1/fvwm3-config-2.6.1.gz
rm -f $PKG/usr/man/man1/Fvwm3Console.1.gz
rm -f $PKG/usr/man/man1/Fvwm3ConsoleC.pl.1.gz
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a NEWS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

View File

@ -1,7 +1,7 @@
PRGNAM="fvwm3"
VERSION="1.0.1"
VERSION="1.0.2"
HOMEPAGE="https://github.com/fvwmorg/fvwm3"
DOWNLOAD="https://github.com/fvwmorg/fvwm3/releases/download/1.0.1/fvwm3-1.0.1.tar.gz \
DOWNLOAD="https://github.com/fvwmorg/fvwm3/releases/download/1.0.2/fvwm3-1.0.2.tar.gz \
https://github.com/abiosoft/ishell/archive/v2.0.0/ishell-2.0.0.tar.gz \
https://github.com/abiosoft/readline/archive/155bce2042db95a783081fab225e74dd879055b0/readline-155bce2042db95a783081fab225e74dd879055b0.tar.gz \
https://github.com/fatih/color/archive/v1.9.0/color-1.9.0.tar.gz \
@ -10,7 +10,7 @@ DOWNLOAD="https://github.com/fvwmorg/fvwm3/releases/download/1.0.1/fvwm3-1.0.1.t
https://github.com/mattn/go-isatty/archive/v0.0.12/go-isatty-0.0.12.tar.gz \
https://github.com/sirupsen/logrus/archive/v1.6.0/logrus-1.6.0.tar.gz \
https://github.com/golang/sys/archive/12a6c2dcc1e4cb348b57847c73987099e261714b/sys-12a6c2dcc1e4cb348b57847c73987099e261714b.tar.gz"
MD5SUM="5bf56ca74f4a111df66de3c61cf6fcba \
MD5SUM="afdf88159cf06486a8a86d3d64b69b18 \
3058feb8c64ce23c122c212673a769fc \
5f9283762aece4866ec12481c911dc04 \
63c08b74df39b3df587594710c13d543 \
@ -21,6 +21,6 @@ MD5SUM="5bf56ca74f4a111df66de3c61cf6fcba \
62bb00c7e07850c8fa836a3614667ded"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libbson google-go-lang"
REQUIRES="libbson google-go-lang python3 rubygem-asciidoctor"
MAINTAINER="Alexander Verbovetsky"
EMAIL="alik@ejik.org"

View File

@ -0,0 +1,13 @@
diff -Nur fvwm3-1.0.2.orig/fvwm/screen.h fvwm3-1.0.2/fvwm/screen.h
--- fvwm3-1.0.2.orig/fvwm/screen.h 2020-12-12 03:37:08.000000000 +0300
+++ fvwm3-1.0.2/fvwm/screen.h 2020-12-22 03:21:41.103120674 +0300
@@ -485,8 +485,7 @@
get_unshaded_geometry((fw), &g); \
mnew = FindScreenOfXY((fw)->g.frame.x, (fw)->g.frame.y); \
/* Avoid unnecessary updates. */ \
- if (mnew == (fw)->m && \
- (fw)->Desk == mnew->virtual_scr.CurrentDesk) \
+ if (mnew == (fw)->m) \
break; \
(fw)->m_prev = (fw)->m; \
(fw)->m = mnew; \