network/uTox: Use git tarball to match latest c-toxcore

Signed-off-by: Christoph Willing <chris.willing@linux.com>
This commit is contained in:
Christoph Willing 2018-04-02 10:09:27 +10:00 committed by Willy Sudiarto Raharjo
parent c69f349837
commit b8b6125e8a
4 changed files with 10 additions and 23 deletions

View File

@ -1,14 +0,0 @@
--- CMakeLists.txt.orig 2017-08-23 06:19:33.000000000 +1000
+++ CMakeLists.txt 2017-12-15 16:07:38.446002260 +1000
@@ -73,6 +73,11 @@
set(ASAN_DEFAULT ON)
endif()
+# ASAN causes uTox to be slower so do no use it for release builds
+if (CMAKE_BUILD_TYPE MATCHES "Release")
+ set(ASAN_DEFAULT OFF)
+endif()
+
###########
# Options #
###########

View File

@ -1,11 +1,13 @@
--- src/xlib/gtk.c.orig 2017-08-25 20:40:13.735005837 +1000
+++ src/xlib/gtk.c 2017-08-25 21:35:10.165215607 +1000
@@ -24,7 +24,7 @@
--- src/xlib/gtk.c.orig 2018-03-26 14:52:33.000000000 +1000
+++ src/xlib/gtk.c 2018-04-02 09:59:02.201013926 +1000
@@ -24,8 +24,8 @@
#include <stdlib.h>
#include <string.h>
-#define LIBGTK_FILENAME "libgtk-3.so"
-#define LIBGTK_FILENAME_FALLBACK "libgtk-3.so.0"
+#define LIBGTK_FILENAME "libgtk-x11-2.0.so"
+#define LIBGTK_FILENAME_FALLBACK "libgtk-x11-2.0.so.0"
#define GTK_FILE_CHOOSER_ACTION_OPEN 0
#define GTK_FILE_CHOOSER_ACTION_SAVE 1

View File

@ -19,8 +19,8 @@
# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
PRGNAM=uTox
VERSION=${VERSION:-0.16.1}
BUILD=${BUILD:-2}
VERSION=${VERSION:-0.16.1.0git20180402}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -58,7 +58,6 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
cd $PRGNAM-$VERSION
patch -p0 < $CWD/asan_off.diff
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \

View File

@ -1,8 +1,8 @@
PRGNAM="uTox"
VERSION="0.16.1"
VERSION="0.16.1.0git20180402"
HOMEPAGE="https://github.com/uTox/uTox"
DOWNLOAD="https://github.com/uTox/uTox/archive/v0.16.1/uTox-0.16.1.tar.gz"
MD5SUM="218e5fa1db9917d4060283225110deec"
DOWNLOAD="http://sourceforge.net/projects/slackbuildsdirectlinks/files/uTox/uTox-0.16.1.0git20180402.tar.gz"
MD5SUM="9027b62fbe606869085bf2d71c372187"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="c-toxcore libfilteraudio check"