libraries/wbxml2: Removed from 12.2 repository

This commit is contained in:
Heinz Wiesinger 2010-05-12 11:47:54 +02:00
parent 3b0edc5b17
commit b8967c3212
5 changed files with 0 additions and 123 deletions

View File

@ -1,12 +0,0 @@
--- Makefile.am~ 2008-10-20 22:05:44.000000000 +0200
+++ Makefile.am 2008-10-20 22:06:02.000000000 +0200
@@ -24,9 +24,6 @@
TODO\
doxygen.h
-install-data-local:
- $(mkinstalldirs) $(DESTDIR)$(wbxmldocdir)/manual
- cp -Rp doc/* $(DESTDIR)$(wbxmldocdir)/manual
dist-bz2: distdir
sed -e "s/tar.gz/tar.bz2/g" $(distdir)/wbxml2.spec > $(distdir)/wbxml2.spec.aux

View File

@ -1,3 +0,0 @@
wbxml2
Parse, encode and handle WBXML documents.

View File

@ -1,19 +0,0 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler---------------------------------------------------|
wbxml2: wbxml2 (Parse, encode and handle WBXML documents)
wbxml2:
wbxml2: Parse, encode and handle WBXML documents.
wbxml2:
wbxml2: Homepage http://libwbxml.aymerick.com
wbxml2:
wbxml2:
wbxml2:
wbxml2:
wbxml2:
wbxml2:

View File

@ -1,81 +0,0 @@
#!/bin/sh
#
# Slackware build script for wbxml2
# (C) 2008 Michael Wagner <slackware.wagnerm@arcor.de>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=wbxml2
VERSION=0.9.2
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
#Patch Makefile.am
patch -p0 < $CWD/Makefile.am.diff
autoreconf -is
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--disable-static \
--build=$ARCH-slackware-linux
make
make install-strip DESTDIR=$PKG VERSION=0.9.2
mv $PKG/usr/share/doc $PKG/usr && rm -rf $PKG/usr/share
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
chmod 644 $PKG/usr/doc/$PRGNAM-$VERSION/*
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz

View File

@ -1,8 +0,0 @@
PRGNAM="wbxml2"
VERSION="0.9.2"
HOMEPAGE="http://libwbxml.aymerick.com/"
DOWNLOAD="http://prdownloads.sourceforge.net/wbxmllib/wbxml2-0.9.2.tar.gz"
MD5SUM="67a48fd9b69db8818a4dca5375c7993a"
MAINTAINER="Michael Wagner"
EMAIL="slackware.wagnerm@arcor.de"
APPROVED="dsomero"