libraries/libva: Updated for version 1.6.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
e7e2799318
commit
b7cbca15c0
|
@ -26,7 +26,7 @@
|
|||
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=libva
|
||||
VERSION=${VERSION:-1.5.1}
|
||||
VERSION=${VERSION:-1.6.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -72,6 +72,11 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# --enable-wayland=no isn't working without this patch
|
||||
patch -p1 < $CWD/wayland-automagic.patch
|
||||
mkdir m4
|
||||
|
||||
autoreconf -if
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
|
@ -81,6 +86,7 @@ CXXFLAGS="$SLKCFLAGS" \
|
|||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--enable-wayland=no \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
# configure creates its own libtool, but that libtool seems broken:
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="libva"
|
||||
VERSION="1.5.1"
|
||||
VERSION="1.6.0"
|
||||
HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi/"
|
||||
DOWNLOAD="http://www.freedesktop.org/software/vaapi/releases/libva/libva-1.5.1.tar.bz2"
|
||||
MD5SUM="d6d34cd725a0100a5e476e711838e1b1"
|
||||
DOWNLOAD="http://www.freedesktop.org/software/vaapi/releases/libva/libva-1.6.0.tar.bz2"
|
||||
MD5SUM="3f1241b4080db53c120325932f393f33"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
|
@ -0,0 +1,19 @@
|
|||
--- a/configure.ac 2015-06-14 18:17:48.776175722 +0200
|
||||
+++ b/configure.ac 2015-06-14 18:26:45.710159385 +0200
|
||||
@@ -275,14 +275,13 @@
|
||||
if test "$USE_WAYLAND" = "yes"; then
|
||||
AC_DEFINE([HAVE_VA_WAYLAND], [1],
|
||||
[Defined to 1 if VA/Wayland API is built])
|
||||
+ m4_ifdef([WAYLAND_SCANNER_RULES],
|
||||
+ [WAYLAND_SCANNER_RULES(['$(top_buildir)/va/wayland/protocol'])],
|
||||
+ [wayland_scanner_rules=""; AC_SUBST(wayland_scanner_rules)])
|
||||
fi
|
||||
fi
|
||||
AM_CONDITIONAL(USE_WAYLAND, test "$USE_WAYLAND" = "yes")
|
||||
|
||||
-m4_ifdef([WAYLAND_SCANNER_RULES],
|
||||
- [WAYLAND_SCANNER_RULES(['$(top_builddir)/va/wayland/protocol'])],
|
||||
- [wayland_scanner_rules=""; AC_SUBST(wayland_scanner_rules)])
|
||||
-
|
||||
pkgconfigdir=${libdir}/pkgconfig
|
||||
AC_SUBST(pkgconfigdir)
|
Loading…
Reference in New Issue