games/mog: Added (The Maze of Galious remake).

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Dimitris Zlatanidis 2015-03-28 07:41:05 +07:00 committed by Willy Sudiarto Raharjo
parent 630005bf47
commit b6b5c54fca
6 changed files with 146 additions and 0 deletions

4
games/mog/README Normal file
View File

@ -0,0 +1,4 @@
The Maze of Galious (MoG in short) was originally a Konami game
for the MSX computer system. Its real name is Knightmare II: The
Maze of Galious and is the sequel of another Konami game called
Knightmare.

3
games/mog/doinst.sh Normal file
View File

@ -0,0 +1,3 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi

18
games/mog/makefile.patch Normal file
View File

@ -0,0 +1,18 @@
--- mog-0.63.1548/build/linux/Makefile.orig 2015-03-28 01:25:41.748009321 +0200
+++ mog-0.63.1548/build/linux/Makefile 2015-03-28 01:26:40.989268703 +0200
@@ -3,11 +3,11 @@
PREFIX = /usr
EXTRADIR = ./build/linux
-GAMEDIR = $(PREFIX)/games
+GAMEDIR = $(PREFIX)/usr/bin
STARTUP = $(GAMEDIR)/$(EXE)
-BINDIR = $(PREFIX)/share/games/$(EXE)
-ICNDIR = $(PREFIX)/share/pixmaps
-APPDIR = $(PREFIX)/share/applications
+BINDIR = $(PREFIX)/usr/share/games/$(EXE)
+ICNDIR = $(PREFIX)/usr/share/pixmaps
+APPDIR = $(PREFIX)/usr/share/applications
DATA = graphics rooms sound leeme.txt liesmich.txt readme.txt MoG-FAQ.txt LICENSE
ICON = mog.png

92
games/mog/mog.SlackBuild Normal file
View File

@ -0,0 +1,92 @@
#!/bin/sh
# Slackware build script for mog
# Copyright 2015 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
SRCNAM=mog.src
PRGNAM=$(echo $SRCNAM | cut -c1-3)
VERSION=${VERSION:-0.63.1548}
SRCVER=$(echo $VERSION | sed "s/.1548/-1548/")
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$SRCNAM\_$SRCVER.tgz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# fix installation path
patch -p1 < $CWD/makefile.patch
make
make install PREFIX=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a *.txt LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

10
games/mog/mog.info Normal file
View File

@ -0,0 +1,10 @@
PRGNAM="mog"
VERSION="0.63.1458"
HOMEPAGE="http://www.braingames.getput.com/mog/"
DOWNLOAD="http://braingames.jorito.net/mog/downloads/mog.src_0.63-1548.tgz"
MD5SUM="68604c258ce7347662777d853d895769"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="SDL_sound"
MAINTAINER="Dimitris Zlatanidis"
EMAIL="d.zlatanidis@gmail.com"

19
games/mog/slack-desc Normal file
View File

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
mog: mog (The Maze of Galious remake)
mog:
mog: The Maze of Galious (MoG in short) was originally a Konami game for
mog: the MSX computer system. Its real name is Knightmare II: The Maze
mog: of Galious and is the sequel of another Konami game called
mog: Knightmare.
mog:
mog: Homepage: http://www.braingames.getput.com/mog/
mog:
mog:
mog: