libraries/LucenePlusPlus: Updated for version 3.0.7.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Willy Sudiarto Raharjo 2015-02-08 15:51:37 +07:00
parent 46be8fe6a2
commit b4f7c7d98f
4 changed files with 5 additions and 66 deletions

View File

@ -1,38 +0,0 @@
commit 994f03cf736229044a168835ae7387696041658f
Author: rezso <rezso@example.com>
Date: Mon May 19 09:20:40 2014 +0100
fix installing lucene++ headers in 3.0.6
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b0f3f20..6ae96b7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -138,6 +138,14 @@ if(NOT WIN32)
DESTINATION "${LIB_DESTINATION}/pkgconfig")
endif()
+#################################
+# install Config.h
+#################################
+install(
+ FILES
+ "${CMAKE_CURRENT_BINARY_DIR}/include/Config.h"
+ DESTINATION include/lucene++)
+
####################################
# custom targets
####################################
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 83eb578..7d6153d 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -20,7 +20,7 @@ file(GLOB_RECURSE lucene_internal_headers
)
file(GLOB_RECURSE lucene_headers
- include/*.h
+ "${lucene++_SOURCE_DIR}/include/*.h"
)
add_definitions(-DLPP_BUILDING_LIB)

View File

@ -2,7 +2,7 @@
# Slackware build script for LucenePlusPlus
# Copyright 2014 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# Copyright 2014-2015 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=LucenePlusPlus
VERSION=${VERSION:-3.0.6}
VERSION=${VERSION:-3.0.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -73,10 +73,6 @@ find -L . \
sed -i "s/include(CMakeExternal.txt)/#include(CMakeExternal.txt)/" CMakeLists.txt
sed -i "s/enable_testing()/#enable_testing()/" CMakeLists.txt
# Upstream patches to fix building and header location
patch -p1 < $CWD/LuceneTestFixture.patch
patch -p1 < $CWD/LuceneHeaders.patch
mkdir -p build
cd build
cmake \

View File

@ -1,8 +1,8 @@
PRGNAM="LucenePlusPlus"
VERSION="3.0.6"
VERSION="3.0.7"
HOMEPAGE="https://github.com/luceneplusplus/LucenePlusPlus"
DOWNLOAD="https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_3.0.6.tar.gz"
MD5SUM="80f38e7faf88472b5f2ac82320a9b920"
DOWNLOAD="https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_3.0.7.tar.gz"
MD5SUM="e260c1ff9c10af7070faee29f325f955"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="gtest"

View File

@ -1,19 +0,0 @@
commit 4c1f1371e98c387cb07043c26b99beff5b5111a8
Author: Alan Wright <alan@spotify.com>
Date: Mon Apr 28 13:53:48 2014 +0100
Throw exception in fixture destructor instead of FAIL().
diff --git a/src/test/util/LuceneTestFixture.cpp b/src/test/util/LuceneTestFixture.cpp
index 27c61e0..e737bdb 100644
--- a/src/test/util/LuceneTestFixture.cpp
+++ b/src/test/util/LuceneTestFixture.cpp
@@ -21,7 +21,7 @@ LuceneTestFixture::~LuceneTestFixture() {
if (ConcurrentMergeScheduler::anyUnhandledExceptions()) {
// Clear the failure so that we don't just keep failing subsequent test cases
ConcurrentMergeScheduler::clearUnhandledExceptions();
- FAIL() << "ConcurrentMergeScheduler hit unhandled exceptions";
+ boost::throw_exception(RuntimeException(L"ConcurrentMergeScheduler hit unhandled exceptions"));
}
}