office/org-mode: Updated for version 7.7.
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
parent
0d6a089515
commit
b44744c289
|
@ -1,27 +1,29 @@
|
|||
--- Makefile 2010-10-29 10:43:29.000000000 +0400
|
||||
+++ Makefile.new 2010-10-30 01:08:48.379339339 +0400
|
||||
@@ -14,13 +14,13 @@
|
||||
--- Makefile.back 2011-10-14 00:08:29.754834385 +0400
|
||||
+++ Makefile 2011-10-14 00:47:36.227996214 +0400
|
||||
@@ -14,7 +14,7 @@
|
||||
EMACS=emacs
|
||||
|
||||
# Where local software is found
|
||||
-prefix=/usr/local
|
||||
+prefix=$(DESTDIR)
|
||||
+prefix=${DESTDIR}
|
||||
|
||||
# Where local lisp files go.
|
||||
lispdir = $(prefix)/share/emacs/site-lisp
|
||||
|
||||
# Where info files go.
|
||||
-infodir = $(prefix)/share/info
|
||||
+infodir = $(prefix)/info
|
||||
|
||||
##----------------------------------------------------------------------
|
||||
## YOU MAY NEED TO EDIT THESE
|
||||
@@ -243,7 +243,7 @@
|
||||
@@ -246,7 +246,7 @@
|
||||
|
||||
doc/org.html: doc/org.texi
|
||||
(cd doc; $(TEXI2HTML) --no-split -o org.html org.texi)
|
||||
(cd doc && $(TEXI2HTML) --no-split -o org.html org.texi)
|
||||
- UTILITIES/manfull.pl doc/org.html
|
||||
+# UTILITIES/manfull.pl doc/org.html
|
||||
|
||||
doc/orgcard.pdf: doc/orgcard.tex
|
||||
(cd doc; pdftex orgcard.tex)
|
||||
(cd doc && pdftex orgcard.tex)
|
||||
@@ -277,7 +277,7 @@
|
||||
$(TEXI2HTML) -o doc/guide doc/orgguide.texi
|
||||
UTILITIES/guidesplit.pl doc/guide/*.html
|
||||
|
||||
-info: doc/org
|
||||
+info: doc/org-7.7
|
||||
|
||||
pdf: doc/org.pdf doc/orgguide.pdf
|
||||
|
||||
|
|
|
@ -5,37 +5,17 @@
|
|||
# Written by Valeriy Timchenko <ValTimchenko@gmail.com>
|
||||
|
||||
PRGNAM=org-mode
|
||||
VERSION=${VERSION:-7.5}
|
||||
VERSION=${VERSION:-7.7}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
ARCH="noarch"
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
|
@ -52,17 +32,20 @@ find . \
|
|||
-exec chmod 644 {} \;
|
||||
|
||||
patch Makefile $CWD/Makefile.patch
|
||||
DESTDIR=/usr make all pdf html
|
||||
DESTDIR=/usr make all html
|
||||
mv doc/{org,org-$pkgver}
|
||||
DESTDIR=$PKG/usr make install
|
||||
DESTDIR=$PKG/usr PKG=$PKG make install-info
|
||||
DESTDIR=$PKG/usr make install-info
|
||||
#DESTDIR=$PKG/usr PKG=$PKG make install-info
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
rm -f $PKG/usr/info/dir
|
||||
gzip -9 $PKG/usr/info/*
|
||||
rm -f $PKG/usr/share/info/dir
|
||||
gzip -9 $PKG/usr/share/info/*
|
||||
# Move org.gz to org-$VERSION.gz, so EMACS's org.gz won't be overwritten
|
||||
mv $PKG/usr/info/{org,org-$VERSION}.gz
|
||||
mv $PKG/usr/share/info/{org,org-$VERSION}.gz
|
||||
mv $PKG/usr/share/info $PKG/usr/info
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="org-mode"
|
||||
VERSION="7.5"
|
||||
VERSION="7.7"
|
||||
HOMEPAGE="http://orgmode.org"
|
||||
DOWNLOAD="http://orgmode.org/org-7.5.tar.gz"
|
||||
MD5SUM="556215534aa7a308ddc84c796f695e32"
|
||||
DOWNLOAD="http://orgmode.org/org-7.7.tar.gz"
|
||||
MD5SUM="236289876d9c33ac47c6383ec738ce6a"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Valeriy Timchenko"
|
||||
EMAIL="ValTimchenko@gmail.com"
|
||||
APPROVED="dsomero"
|
||||
APPROVED="Niels Horn"
|
||||
|
|
|
@ -8,8 +8,8 @@
|
|||
|-----handy-ruler------------------------------------------------------|
|
||||
org-mode: Org-mode ("An Emacs mode for Notes, Project Planning, and Authoring")
|
||||
org-mode:
|
||||
org-mode: Org-mode is for keeping notes, maintaining ToDo lists, doing project
|
||||
org-mode: planning, and authoring with a fast and effective plain-text system.
|
||||
org-mode: Org-mode is for keeping notes, maintaining ToDo lists, doing project
|
||||
org-mode: planning, and authoring with a fast and effective plain-text system.
|
||||
org-mode:
|
||||
org-mode: "If humans could mate with software, I'd have org-mode's babies."
|
||||
org-mode: Chris League on his Twitter feed.
|
||||
|
|
Loading…
Reference in New Issue