libraries/gtkimageview: Avoid breaking because of depr. functions.

Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Matteo Bernardini 2015-09-02 10:47:59 +02:00 committed by Willy Sudiarto Raharjo
parent d8de9e2123
commit a923c9685c
2 changed files with 25 additions and 1 deletions

View File

@ -0,0 +1,21 @@
diff -Naur gtkimageview-1.6.4.orig/configure.in gtkimageview-1.6.4/configure.in
--- gtkimageview-1.6.4.orig/configure.in 2009-04-05 22:02:43.000000000 +0200
+++ gtkimageview-1.6.4/configure.in 2015-09-02 10:43:04.455960995 +0200
@@ -20,7 +20,7 @@
# Initialize GNOME environment
GNOME_COMMON_INIT
GNOME_COMPILE_WARNINGS(error)
-DEPRECATED_FLAGS="-DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED"
+DEPRECATED_FLAGS="-DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED"
AC_SUBST(DEPRECATED_FLAGS)
PKG_CHECK_MODULES(DEP,
@@ -39,7 +39,7 @@
######################################################################
##### Twiddle CFLAGS #################################################
######################################################################
-CFLAGS="${CFLAGS} -Wall -Werror -std=c99 -Wmissing-prototypes"
+CFLAGS="${CFLAGS} -Wall -std=c99 -Wmissing-prototypes"
######################################################################

View File

@ -6,7 +6,7 @@
PRGNAM=gtkimageview
VERSION=${VERSION:-1.6.4}
BUILD=${BUILD:-2}
BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -51,6 +51,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Build breaks because functions in gdk-pixbuf are now deprecated
patch -p1 < $CWD/disable_Werror_for_gdk_pixbuf.patch
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \