gis/OWSLib: Fix script if Python 3.11 is found.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Giancarlo Dessi 2024-04-06 07:08:46 +07:00 committed by Willy Sudiarto Raharjo
parent f78e9a825e
commit a7a0144d25
No known key found for this signature in database
GPG Key ID: 3F617144D7238786
2 changed files with 18 additions and 1 deletions

View File

@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=OWSLib
VERSION=${VERSION:-0.30.0}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@ -76,6 +76,10 @@ find -L . \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
if [ -x /usr/bin/python3.11 ]; then
patch -p1 < $CWD/pytz-not-required.patch
fi
python3 setup.py install --root=$PKG

View File

@ -0,0 +1,13 @@
python-pytz has been removed from Slackware -current because
not needed with Python 3.11
This patch prevents pip check from indicating the lack of
pytz as dependency required by OWSLib in -current
--- ./requirements.txt 2024-04-05 23:42:52.864498274 +0200
+++ ./requirements.txt 2024-04-05 23:43:13.322499915 +0200
@@ -1,6 +1,5 @@
dataclasses; python_version < '3.7'
lxml
python-dateutil>=1.5
-pytz
pyyaml
requests>=1.0