office/abook: Updated for version 0.6.1 + new maintainer.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Frédéric Galusik 2017-04-17 07:57:09 +07:00 committed by Willy Sudiarto Raharjo
parent 4f0f8a85d4
commit a6f7d04d82
5 changed files with 49 additions and 18 deletions

View File

@ -1,2 +1,2 @@
abook is a Unix ncurse-based addressbook.
It goes very well when used with the mutt MUA.
Abook is a text-based addressbook program designed to use with mutt mail
client.

View File

@ -2,6 +2,7 @@
# Slackware build script for abook
# Copyright 2017 Frédéric Galusik, Lyon, France
# Copyright 2006 Martin Lefebvre <dadexter@gmail.com>
# Copyright 2007-2009 Michiel van Wessem, Manchester, United Kingdom
@ -25,7 +26,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=abook
VERSION=${VERSION:-0.5.6}
VERSION=${VERSION:-0.6.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -56,10 +57,8 @@ else
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
@ -75,24 +74,32 @@ find -L . \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
aclocal && automake --add-missing && autoconf
sed 's/0.18/0.19/g' -i po/Makefile.in.in
# thanks to the archers for this patch ;)
patch -p1 -i $CWD/gcc5.patch
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--mandir=/usr/man \
--localstatedir=/var \
--build=$ARCH-slackware-linux
make
make install-strip DESTDIR=$PKG
make install DESTDIR=$PKG
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
)
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a ABOUT-NLS ANNOUNCE AUTHORS BUGS COPYING ChangeLog FAQ INSTALL NEWS \
README THANKS TODO $PKG/usr/doc/$PRGNAM-$VERSION
README RELEASE_NOTES THANKS TODO doc/HOWTO.translating_abook \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install

View File

@ -1,10 +1,10 @@
PRGNAM="abook"
VERSION="0.5.6"
VERSION="0.6.1"
HOMEPAGE="http://abook.sourceforge.net"
DOWNLOAD="http://downloads.sourceforge.net/abook/abook-0.5.6.tar.gz"
MD5SUM="87d25df96864a7c507a4965e6d1da49d"
DOWNLOAD="http://abook.sourceforge.net/devel/abook-0.6.1.tar.gz"
MD5SUM="4bffd4c47ac41b688abd58f65bfe0bfb"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="Michiel van Wessem"
EMAIL="michiel@slackbuilds.org"
MAINTAINER="Frédéric Galusik"
EMAIL="slack+SBo@galusik.xyz"

24
office/abook/gcc5.patch Normal file
View File

@ -0,0 +1,24 @@
diff -up abook-git-6e550af8a907a680dc845c22a7d6c36d89e900c1/database.c.gcc5 abook-git-6e550af8a907a680dc845c22a7d6c36d89e900c1/database.c
--- abook-git-6e550af8a907a680dc845c22a7d6c36d89e900c1/database.c.gcc5 2014-11-28 16:29:52.000000000 +0100
+++ abook-git-6e550af8a907a680dc845c22a7d6c36d89e900c1/database.c 2015-02-11 16:02:15.837789303 +0100
@@ -859,7 +859,7 @@ item_merge(list_item dest, list_item src
*/
/* quick lookup by "standard" field number */
-inline int
+extern inline int
field_id(int i)
{
assert((i >= 0) && (i < ITEM_FIELDS));
diff -up abook-git-6e550af8a907a680dc845c22a7d6c36d89e900c1/database.h.gcc5 abook-git-6e550af8a907a680dc845c22a7d6c36d89e900c1/database.h
--- abook-git-6e550af8a907a680dc845c22a7d6c36d89e900c1/database.h.gcc5 2014-11-28 16:29:52.000000000 +0100
+++ abook-git-6e550af8a907a680dc845c22a7d6c36d89e900c1/database.h 2015-02-11 16:02:23.465818915 +0100
@@ -61,7 +61,7 @@ struct db_enumerator {
/*
* Field operations
*/
-inline int field_id(int i);
+extern inline int field_id(int i);
abook_field *find_standard_field(char *key, int do_declare);
abook_field *real_find_field(char *key, abook_field_list *list, int *nb);
#define find_field(key, list) real_find_field(key, list, NULL)

View File

@ -8,8 +8,8 @@
|-----handy-ruler------------------------------------------------------|
abook: abook (Unix ncurse-based addressbook)
abook:
abook: abook is a Unix ncurse-based addressbook.
abook: It goes very well when used with the mutt MUA.
abook: Abook is a text-based addressbook program designed to use with mutt
abook: mail client.
abook:
abook:
abook: