development/motor: Initial import

This commit is contained in:
Martin Lefebvre 2010-05-11 14:05:52 +02:00 committed by Robby Workman
parent c0c524017f
commit a6e6f4427a
5 changed files with 121 additions and 0 deletions

View File

@ -0,0 +1,13 @@
--- share/Makefile.orig 2007-02-11 09:56:05.000000000 -0500
+++ share/Makefile 2007-02-11 09:56:41.000000000 -0500
@@ -225,8 +225,8 @@
-if test -d templates; then rm -f tmpl.tar.gz; fi
install-data-local: tmpl.tar.gz
- tar zxvf tmpl.tar.gz -C $(datadir)/motor/
- -find $(datadir)/motor/ -name CVS -type d -exec rm -rf {} \;
+ tar zxvf tmpl.tar.gz -C ${DESTDIR}/$(datadir)/motor/
+ -find ${DESTDIR}/$(datadir)/motor/ -name CVS -type d -exec rm -rf {} \;
if test -d templates; then rm -f tmpl.tar.gz; fi
uninstall-local:

7
development/motor/README Normal file
View File

@ -0,0 +1,7 @@
Motor is a text mode based programming environment for Linux. It
consists of a powerful editor with syntax highlight feature, project
manager, makefile generator, gcc and gdb front-end, etc. Deep CVS
integration is also provided. A symbol browser is provided to make it
easier to move between various definitions in the source, and the
regexper tool helps you to create and debug regular expressions.

View File

@ -0,0 +1,82 @@
#!/bin/sh
# Slackware build script for motor
# Copyright 2007 Martin Lefebvre <dadexter@slackadelic.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
set -e
PRGNAM=motor
VERSION=3.4.0
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=`pwd`
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
fi
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar -xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man
# Thanks to robw810 for this patch!
patch -p0 < $CWD/Makefile.patch
make
make DESTDIR=$PKG install
find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a ABOUT-NLS AUTHORS COPYING ChangeLog FAQ INSTALL README TODO tutorial \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
# Set permissions right, throughout the package
chown -R root:root $PKG/usr/share/$PRGNAM
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz

View File

@ -0,0 +1,8 @@
PRGNAM="motor"
VERSION="3.4.0"
HOMEPAGE="http://thekonst.net/motor"
DOWNLOAD="http://www.thekonst.net/download/motor-3.4.0.tar.bz2"
MD5SUM="0fcf7ce0386b269e8bdbb7a86e9bee19"
MAINTAINER="Martin Lefebvre"
EMAIL="dadexter@slackadelic.com"
APPROVED="robw810"

View File

@ -0,0 +1,11 @@
motor: motor - text mode integrated development environment
motor:
motor: Motor is a text mode based programming environment for Linux. It
motor: consists of a powerful editor with syntax highlight feature, project
motor: manager, makefile generator, gcc and gdb front-end, etc. Deep CVS
motor: integration is also provided. A symbol browser is provided to make it
motor: easier to move between various definitions in the source, and the
motor: regexper tool helps you to create and debug regular expressions.
motor:
motor:
motor: